Arena - Hilfe -Willkommen

Willkommen!

Dies ist das Hilfesystem für die Oberfläche für Schachmotoren "Arena".

Die Startseite von Arena im Internet ist:

http://www.playwitharena.com

Aktuelle Arena-Version: 1.99beta3

small arrow Wählen Sie auf der linken Seite ein Hilfethema aus. Einige Themen haben weitere Unterthemen, die bei einem Mausklick erscheinen.

Diese Hilfe befindet sich auch noch im Beta-Stadium.

Diese Hilfedatei wurde erstellt am: 2006-12-12, 22:19


Arena - Hilfe -Hinweis

Hinweis

Arena ist eine Oberfläche zum Schachspielen gegen Programme (Motoren). Sie wurde von Martin Blume, Marl, Deutschland seit Mitte 2001 entwickelt. Das Ziel war es, eine komfortabel zu bedienende, aber freie Oberfläche für die mittlerweile sehr zahlreichen und starken Schachmotoren (englisch: "Engines") zu entwickeln. Nahezu alle Winboard- und UCI-kompatiblen Schachmotoren laufen unter dieser Oberfläche.

Betriebssystem-Voraussetzungen: Windows 95/98/ME oder Windows NT 4.0/2000/XP oder höher.

Kostenlose Schachmotoren können Sie natürlich im Internet finden.

Gute Startseiten sind:

  • WBEC
  • http://www.uciengines.de/index.html
  • http://www.tim-mann.org

Arena © von Martin Blume, 2006

Wenn Arena auf irgendeine Weise verbreitet oder angeboten wird, z.B. im Internet oder auf einer kostenpflichtigen CD, ist eine schriftliche Zustimmung des Autors erforderlich. Urheberrechtliche Bestimmungen von Arena finden Sie im Verzeichnis "Readme" in der Datei "copyright.txt".


Arena - Hilfe -Basisfunktionen

Basisfunktionen

Die grundlegenden Funktionen sind einfach über die Navigationsleiste oder die Werkzeugleiste aufzurufen.


Arena - Hilfe -Basisfunktionen - Eine Partie spielen

Eine Partie spielen

1.Stellen Sie die gewünschte Spielstufe ein.

2.Wählen Sie im Menü Datei / Neu, um eine neue Partei zu beginnen.

3. Falls Sie mit schwarz spielen wollen, klicken Sie auf das Chip-Symbol [image] auf der Navigationsleiste oder drücken Sie einfach die Leertaste. Der Motor wird jetzt mit weiß ziehen.

4. Figur mit der Maus anklicken.

5. Das Zielfeld mit der Maus anklicken.

Sie können auch die Figur mit der Maus ‚anfassen' und vom Start zum Zielfeld ziehen.

Weiterhin können sie die Züge auch über die Tastatur eingeben. Für den Zug e2e4 einfach z.B. nacheinander die Tasten e,2,e,4 eingeben.

6. Der Schachmotor wird jetzt mit seiner Berechnung anfangen und einen Zug machen.

7. weiter mit Punkt 4!

  • Die Funktionen "Aufgeben" und "Remis anbieten" finden Sie im Hauptmenü unter "Partie".


Arena - Hilfe -Basisfunktionen - Eine Partie eingeben

Eine Partie eingeben

Wenn Sie eine Partie manuell eingeben wollen, würde im Normalfall folgendes passieren: Sie geben einen Zug ein und dieser wird sofort beantwortet durch einen Gegenzug des Motors. Dies würde die Eingabe einer ganzen Partie doch sehr umständlich machen.

Abhlife: Klicken Sie auf den Knopf 'Bearbeiten' in der Navigationsleiste.

Der Bearbeiten-Knopf bleibt jetzt gedrückt. Der Motor rechnet jetzt nicht mehr einfach los, nachdem Sie einen Zug eingegeben haben.

Der Bearbeiten-Knopf kann durch erneutes Klicken wieder in den ursprünglichen Zustand versetzt werden.


Arena - Hilfe -Basisfunktionen - Eine Stellung eingeben

Aufstellen, eine Stellung eingeben

Den Aufstellen- Dialog erreichen Sie im Hauptmenü unter Stellung / Figuren aufstellen oder durch Klick auf das Symbol { [image]} in der Werkzeugleiste.

So geben Sie eine neue Stellung ein:

1. Falls nötig, klicken Sie 'Räumen'. Das Brett wird komplett geräumt.
2. Klicken Sie die Figur an, die Sie aufstellen wollen.
3. Klicken Sie das Feld auf dem Schachbrett an, auf dem Sie die Figur aufstellen wollen. Dabei gilt:

  • Linke Maustaste stellt eine weiße Figur auf,
  • rechte Maustaste stellt eine schwarze Figur auf,
  • Doppelklick oder linke Maustaste mit Umschalt-Taste: Feld löschen.

4. Wiederholen Sie Punkt 2-3 für alle Figuren, die Sie aufstellen wollen.
5. Setzen Sie schwarz oder weiß am Zug, wie Sie mögen.
6. Wenn nicht alle Rochaderechte erlaubt sein sollen, können Sie diese einschränken.
7. Wenn die Partie nicht mit Zug Nummer eins anfangen soll, dann können die unter Optionen/1.Zug hat NR. eine andere Nummer für den ersten Zug eingeben.
8. Falls Sie festlegen möchten, dass im Moment ein en passant- Zug möglich ist, können Sie ein Zielfeld für den ep- Schlagzug eingeben unter Optionen/ep- Feld. Dieses Feld muss sich in der 3. oder 6. Reihe befinden.
9. Wenn Sie nicht normales Schach spielen möchten, dann können Sie auch Fischer Schach oder Shuffle Chess wählen.
10. Drücken Sie OK.
11. Speichern Sie die neue Partie.

Verschieben:

Sie können ebenfalls in diesem Dialog Figuren nach oben, unten, rechts oder links verschieben, sowie an der Horizontalen und Vertikalen spiegeln, ausserdem schwarze und weiße Figuren vertauschen.

Beim Verschieben nach oben gehen Figuren in der 8.Reihe verloren, analog bei anderen Verschiebungen.

Spiegeln:

Spiegeln an der Horizontalen erfolgt an einer gedachten Linie zwischen 4. und 5. Reihe. Spiegelungen an der Vertikalen erfolgt an einer gedachten Linie zwischen der d- und e- Linie.


Arena - Hilfe -Basisfunktionen - Spielstufe einstellen

Spielstufe einstellen

Den Dialog zum Verändern der Spielstufe finden Sie im Hauptmenü unter Spielstufen / Einstellen.

Wählen Sie dann zunächst den Spielmodus, für den Sie die Spielstufe verstellen wollen. Abhängig vom Modus erhalten Sie rechts ein Dialogfeld, in dem Sie die entsprechenden Einstellungen machen können.

Hier ein Überblick über die verschiedenen Modi:

Feste Suchtiefe

Der Motor sucht jeden Zug nur bis zu einer bestimmten Suchtiefe in Halbzügen. Zum Testen sinnvoll, für eine reguläre Partie aber unsinnig, da die Rechenzeiten z.T. erheblich variieren können. Von Winboard-Motoren wird diese Funktion häufig nicht unterstützt.

Zeit pro Zug

Der Motor rechnet eine bestimmte Dauer und bricht die Suche dann ab. Dabei wird zuerst ein Halbzug tief gesucht, dann zwei, dann drei etc.. Nicht empfehlenswert für Winboard-Motoren, da häufig nicht oder nur unzulänglich unterstützt. Auf keinen Fall sollte dieser Modus für Motoren-Wettkämpfe Verwendung finden. In diesem Modus sollten die Motoren nämlich die Zeit für jeden Zug so genau wie möglich einhalten, ohne Rücksicht auf die Stellung. Die Zeit-Verwaltung der Motoren ist in diesem Modus normalerweise ausgeschaltet, was zu einer Schwächung der Motoren führt.

Blitz (=Fischer-Uhr)

In diesem Modus hat jeder Spieler eine bestimmte Zeit als Basis, die für die gesamte Partie zur Verfügung steht. Zusätzlich wird für jeden erfolgten Zug ein Bonus gutgeschrieben. Dies hat vor allem den Vorteil, dass ein Spieler, der positionell und/oder materiell besser steht, nicht so leicht aus Zeitnot verliert, da ihm ja für jeden Zug wieder Zeit gutgeschrieben wird. Bitte beachten Sie, dass die Basiszeit in Minuten und Sekunden, die Bonuszeit aber in Sekunden und Millisekunden (tausendstel Sekunden) eingegeben wird. Dieser Modus wird auch beim Spiel über das Internet (ICS) verwendet. Dieser Modus wurde von Exweltmeister Bobby Fischer erdacht, daher häufig auch "Fischer Uhr" genannt.

Mattsuche

Der Motor sucht nur Matts bis zu einer bestimmten Tiefe in Zügen. Manche Motoren laufen nun deutlich schneller, weil die zeitaufwendige positionelle Bewertung wegfällt. Winboard-Motoren können das nicht, da dieser Modus in der Winboard- Spezifikation nicht vorgesehen ist. Stattdessen stellt Arena für Winboard Motoren die feste Suchtiefe mit 2 x Mattsuchetiefe ein. Damit sollten alle Matts gefunden werden.

Unendlich

Es wird so lange an der Stellung gerechnet, bis die maximale Suchtiefe des jeweiligen Motors erreicht wird. UCI-Motoren können das ohne Einschränkung, bei Winboard-Motoren muß diese Spielstufe simuliert werden. Dazu wird einfach eine sehr lange Rechenzeit dem Motor vorgegeben. Es wird die Einstellung unter 'Motoren / Installieren und Auswählen / Optionen ' verwendet (eine Blitz-Spielstufe mit sehr langer Bedenkzeit).

Turnier

Es gibt 3 mögliche Zeitkontrollen. Sie können angeben, in wie viel Minuten die angegebene Zahl von Zügen ausgeführt werden soll. Falls Sie bei 'Züge' den Wert "Alle" eingeben, gilt die eingegebene Zeit für den kompletten Rest der Partie.

Wenn Sie also z. B. nur eine Zeitkontrolle haben möchten und die Partie nach einer Stunde beendet sein soll geben Sie z.B. ein:

Zeitkontrolle 1 : Züge : Alle Minuten: 30 (Die Zeit gilt ja pro Spieler!)

Sie können jede Zeitkontrolle als 'wiederholend' kennzeichnen. Dann wird die Anzeige der folgenden Zeitkontrollen natürlich ausgeblendet. Wenn eine Zeitkontrolle für den Rest der Partie gelten soll (also für alle verbleibenden Züge), dann wählen Sie in dem Feld für die Anzahl der Züge den Wert 'Rest' aus.

Zeitüberschreitungen werden von Arena überwacht, wenn Sie dies unter 'Motorenverwaltung / Optionen' eingestellt haben.

Normalerweise kennen Winboard Motoren nur eine Zeitkontroll- Stufe. Falls Sie "Erweiterter 'Level' Befehl für Winboard" markiert haben, wird in Erweiterung des Winboard Protokolls ein erweiterter 'Level' (Spielstufe-) Befehl an die Motoren gesendet. Eine Turnier Spielstufe mit 40 Zügen in 15 Minuten, danach wiederum 40 Züge in 15 Minuten, danach Rest in 15 wird folgendermaßen an die Winboard Motoren gesendet:

level 40 15 0 40 15 0 0 15 0

Knoten

Es wird nur eine bestimmte Anzahl Knoten gerechnet. Dies ist ein nur für Testzwecke sinnvoller Modus. UCI Motoren unterstützen diesen Modus immer. Winboard-Motoren können das i.d.R. nicht, es sei denn Sie unterstützen wie z.B. der Schachmotor "Crafty" den Befehl 'sn <n>'. Der Befehl 'sn 0' bedeutet, dass keine Begrenzung der Knotenzahl besteht. Arena verwendet diesen Befehl für Winboard Motoren.

Speichern der Lieblings-Spielstufen

Falls Sie einige Spielstufen häufiger benötigen, können Sie diese direkt in das Hauptmenü einfügen:

1. Sie wählen in der Klappbox den zu speichernden Menüpunkt (1-8) aus.
2. Die bisherige Belegung wird angezeigt.
3. Sie verändern den Modus und die jeweiligen Einstellungen auf z.B. '5 Sekunden pro Zug'.
4. Sie drücken die Schltfläche 'Speichern'.
5. Sie drücken OK zum Beenden des Dialogs.
6. Jetzt können Sie im Hauptmenü unter "Spielstufen" ihren Eintrag finden. Der erste Eintrag befindet sich an oberster Stelle, die Lieblings-Spielstufe 2 an zweiter Stelle etc..

Handicap

Falls Sie einem Motor nicht mit voller Stärke, sondern mit einem Handicap laufen lassen, wird die Zeit Kontrolle für diesen Motor entsprechend geringer. Statt 10 Minuten für die Partie wird dem Motor nur 5 Minuten als Zeitkontrolle mitgeteilt. Dies stellen Sie in der Motoren Verwaltung ein, siehe besonders Motoren abschwächen.

Unter Spielstufen im Hauptmenü finden Sie folgende voreingestellte (aber änderbare) Spielstufen:

  • Blitz 2/6
  • Blitz 2/12
  • Blitz 5/20
  • Blitz 20/30
  • Turnier Partie in 5
  • Turnier Partie in 15
  • Turnier 40/30 40/30 Rest:30
  • Turnier 40/120 40/120 Rest:120

Diese können Sie als ihre persönlichen Lieblings-Spielstufen umdefinieren, siehe weiter oben, die Beschreibung zum Spielstufen-Dialog.

Die folgenden Spielstufen im Hauptmenü

  • 40 Züge in 5 Minuten
  • 40 Züge in 10 Minuten
  • 40 Züge in 20 Minuten
  • 40 Züge in 40 Minuten
  • 40 Züge in 60 Minuten
  • 40 Züge in 120 Minuten
  • 40 Züge in 150 Minuten

sind als häufig benötigte Spielstufen fest eingestellt und nicht zu ändern


Arena - Hilfe -Basisfunktionen - Laden und Speichern

Laden und Speichern

Arena kann Dateien mit den Erweiterungen EPD, PGN und FCH laden und Dateien mit den Erweiterungen EPD und FCH speichern.

Das Format 'FCH' kann nur von Arena geladen und geschrieben werden:

  • F3 oder im Hauptmenü Datei / Partie laden
  • F2 oder im Hauptmenü Datei / Partie speichern
  • Strg-F2 oder im Hauptmenü Datei / Partie speichern als

Es werden gespeichert:

  • Alle Züge mit allen Suchinformationen wie z.B. Suchtiefen, Zeiten etc.
  • Alle Daten wie Spielernamen etc.

Dateien mit den Erweiterungen EPD, PGN und FCH können auch über den Explorer, Dateimanager etc. durch Doppelklick gestartet werden. Dafür müssen jedoch diese Dateierweiterungen mit Arena verknüpft werden. Arena erledigt dieses für Sie unter Optionen / Oberfläche / Sonstiges.

Weiterhin können Sie EPD, PGN und FCH- Dateien vom Explorer oder Arbeitsoberfläche auf die Arena-Oberfläche fallen lassen. Dies funktioniert auch mit noch nicht gestarteter Arena (also die Datei einfach auf die Arena-Ikone fallen lassen).

PGN- Dateien speichern

PGN- Dateien laden


Arena - Hilfe -Basisfunktionen - Aufgeben und Remis anbieten

Aufgeben

Erreichbar unter Partie / Aufgeben [Alt+F8].

Damit können Sie die Partie gegen ein Programm aufgeben.

gemeinsameParameterfüralleUCIMotoren

Remis anbieten:

Diese Funktion erreichen Sie mit Partie / Remis anbieten [Alt+R].

Wenn Sie einen Winboard- Motor als Gegner haben, können Sie ihm Remis anbieten. Bitte beachten sie, dass manche Winboard Motoren diese Funktion nicht unterstützen.

UCI Motoren unterstützen diese Funktion nicht, und in Arena ist im Moment auch keine Möglichkeit dafür vorgesehen.

Falls der Motor ihrem Remisangebot zustimmt, wird die Partie sofort Remis gegeben.


Arena - Hilfe -Basisfunktionen - Hilfen

Übersicht über Hilfen

Kurzhilfen:

Kurze Hilfen finden Sie im Menü Hilfe / Tooltip Hilfen. Dies aktiviert die kleinen gelben Hilfekästen, die erscheinen, wenn man mit dem Mauszeiger über einem Steuerelement (Schaltflächen etc.) verweilt. Haben Sie das Hauptmenü geöffnet, wird in der Statuszeile eine Hilfe zum gerade aktiven Menüpunkt angezeigt.

Deaktivieren lässt sich diese Funktionen genauso, wie sie aktiviert wurde. Ist die Funktion aktiviert, erscheint ein kleiner Haken im Hauptmenü neben der Funktion.

Diese Hilfe im HTML-Format:

Wählen Sie Hilfe / Hilfe im Hauptmenü um zur Startseite dieser Hilfedatei zu gelangen.

Klicken Sie den 'Hilfe'' Knopf in einem beliebigen Dialog um zu einer kontextsensitiven Hilfeseite in dieser Hilfedatei zu gelangen.

Weitere Hilfen im Internet:

Die beste Möglichkeit, Hilfestellung zu bekommen, ist im Arena-Unterstützungs-Forum. Die Adresse des Forums finden Sie immer unter unserer Internetseite . Hier finden Sie auch aktuelle Fehlerlisten, weitere Hilfestellung zu bekannten Problemen etc..


Arena - Hilfe -Bildschirm

Die Bereiche des Arena - Hauptfensters:

Die Oberfläche von Arena gliedert sich in 5 Hauptbereiche:

1. Das Schachbrett Fenster
2. Die Motoren Analyseausgaben
3. Die Schachuhr / das Logo Fenster
4. Die Zugliste / das Notations Fenster
5. Das Zuginfo / Statistik Fenster

Des weiteren gibt es 3 kleinere Bereiche:

a. Die Werkzeugleiste
b. Die Navigationsleiste
c. Die Statusleiste

Natürlich hat Arena auch eine Titelzeile (ganz oben, meistens in blau) und ein Hauptmenü (direkt darunter, meistens in hellgrau).


Arena - Hilfe -Bildschirm - Das Schachbrett-Fenster

Das Schachbrett-Fenster

Hier wird ihr Hauptwerkzeug, das Schachbrett angezeigt. Sie können unter Optionen / Oberfläche / Schachbrett eine Reihe von Optionen einstellen, z.B. eine Beschriftung mit Koordinaten wählen, die am Zug Anzeige einschalten, ob Sie Gitterlinien oder eine dünne Umrandung des Schachbrettes wünschen.

Die Schachfiguren können Sie unter Optionen / Oberfläche / Schachbrett / Figuren ändern. Empfehlenswert ist z.B. die TrueType Schriftart "Chess Merida", die Sie frei verfügbar im Internet herunterladen können.

Unter Optionen / Oberfläche / Schachbrett / Farben+Grafiken können Sie Farben für weiße und schwarze Felder, die Umrandung, die Farbe der Feldmarkierung und die Kennzeichnung des letzten Zuges wählen.

Die Schriftart der Koordinaten können Sie mit Optionen / Oberfläche / Zusätze / Schriften wählen.

Unter und rechts neben dem Schachbrettbereich finden Sie die Trenner, mittels denen Sie das Schachbrett größer oder kleiner ziehen können. Dementsprechend vergrößern und verkleinern sich alle anderen Bereiche. Die Trenner sehen sie, wenn Sie mit der Maus über die Trenner fahren, dann ändert sich der Mauszeiger.

Mit Optionen / Schachbrett Umdrehen, dem Symbol in der Werkzeugleiste [image] oder F12 können Sie das Schachbrett umdrehen.


Arena - Hilfe -Bildschirm - Die Schachuhren

Die Schachuhren

Sie können die gerade laufende Schachuhr anhalten unter "Optionen / Uhr angehalten".

Automatisch wird die Uhr angehalten, wenn Sie das Arena- Fenster minimieren und Sie selbst am Zug sind, also kein Motor gerade rechnet.

Die Schachuhr / das Logo Fenster

Dieser Bereich besteht für jeden Spieler aus 5 Unterbereichen:

  • (a) Dem Namen oder dem Logo,
  • (b) der Uhr für die Gesamtzeit,
  • (c) der Uhr für den aktuellen Zug,
  • (d) der Flagge und
  • (e) dem Namen oder Autor.

(a) Hier wird zunächst der Name des Spielers angezeigt, sei es nun ein Motor, Sie selbst oder bei einer geladenen Partie (z.B. aus einer PGN- Datei) andere Spieler.

(b) Diese Uhr zeigt die zur Verfügung stehende Zeit an, wenn Sie sich im Blitz oder Turniermodus befinden. Die Zeit läuft also rückwärts. Bei allen anderen Modi wird die gesamte verbrauchte Zeit angezeigt. Es werden also die Zeiten, die der Spieler für seine Züge gemacht hat, addiert. Die Uhr läuft dementsprechend vorwärts.

(c) Die darunter befindliche Uhr zeigt die Zeit, die für den aktuellen Zug verbraucht wurde, an.

(d) Die Flagge wird angezeigt, wenn Sie für den Motor ein Land eingegeben haben. Wenn Sie selbst spielen, sollten Sie für sich unter Optionen/ Benutzerdaten ein Land eingeben. Sie müssen für diese Option natürlich die Flaggen im Arena- Unterverzeichnis "Flags" installiert haben. Die Flaggen lassen sich abschalten mit Optionen / Oberfläche / Anzeige / Flaggen anzeigen.

(e) Im verbleibenden unteren Bereich wird normalerweise der Name des Autors des Motors angezeigt, bei Menschen der Name. Falls Sie bei einem Motor den Namen des Motors anzeigen lassen wollen, sollten Sie unter Optionen / Oberfläche / Anzeige "Statt Autor Namen anzeigen" anhaken.

Unter Optionen / Oberfläche / Anzeige/ können Sie sowohl die Flaggen (d) als auch den Namen/Autor (e) deaktivieren.

Dieses Gesamte Fenster können Sie auch unter Optionen / Oberfläche / Anzeige "Uhren und Logos anzeigen" komplett verbergen.

Das Kontextmenü erreichen Sie mit der rechten Maustaste : Wenn "Uhr angehalten" markiert ist, dann läuft die Uhr im Moment nicht weiter. Dies ist für kurze Pausen anzuraten. Dies ist dieselbe Funktion wie unter Oberfläche im Hauptmenü. Die Uhr wird automatisch angehalten, wenn Sie das Arena Hauptfenster verkleinern. Wenn Sie das Hauptfenster danach wieder vergrössern, läuft die Uhr dann weiter. Hier können Sie auch die Position des Bereiches verändern, nach oben oder unten verschieben oder den Spielstufen-Auswahl Dialog aufrufen.


Arena - Hilfe -Bildschirm - Die Notation

Die Zugliste / das Notations- Fenster

In diesem Fenster können Sie die Notation der aktuellen Partie sehen. Es gibt 2 Ansichten, das freie und das feste Format, einstellbar unter Optionen/Ansicht/Anzeige oder im Kontextmenü der Zugliste.

Das feste Format: im Moment ausser Funktion

Sie sehen die Zugnummer, den Zug die Tiefe, die Dauer und evtl. die Bewertung und die letzte Hauptvariante, die der Motor für diesen Zug angegeben hat. Falls es sich um einen "Ponderhit" gehandelt hat, wird ein kleiner Kreis vor diesen Angaben angezeigt. Ein "Ponderhit" ist, wenn der Gegner den erwarteten Zug gespielt hat, den der Motor während des Ponderns für den richtigen gehalten hat.

Das freie Format:

Hier sehen Sie nur Zugnummern und die Züge selbst.

Für beide Formate gilt:

Mit einem Klick mit der linken Maustaste auf die Zugliste wird zum entsprechenden Zug gesprungen.

Mit einem Klick mit der rechten Maustaste erscheint ein Kontextmenü. Unter Kurzkommentar können Sie eines von folgenden Zeichen für den angewählten Zug angeben: +-,-+,!,?,!?,?! oder ein Zeichen wieder löschen. Unter ausführlicher Kommentar können Sie einen längeren Kommentar für das Zuginfo-Fenster eingeben. Mit Druckdiagramm können Sie diesen Zug markieren. Bei einem Ausdruck wird dann nach diesem Zug dann ein Diagramm eingefügt. Sie können die Partie vom aktuellen Zug vor- oder zurückspielen und hier auch die permanente Statistik ein- oder ausblenden.


Arena - Hilfe -Bildschirm - Zuginfo- und Statistik-Fenster

Das Zuginformationen- und Statistik-Fenster

Das Zuginfo Fenster ist relativ selbsterklärend:

Die Zeit wird in Minuten, Sekunden und Millisekunden angezeigt. Wenn Sie innerhalb der Partie zu einem anderen Zug gehen, werden die entsprechenden Zuginformationen angezeigt. In diesem Fenster werden auch Kommentare zu dem Zug angezeigt. Vor dem ersten Zug werden die Partie Daten angezeigt.

Das Statistik Fenster:

Hier können Sie sich eine Statistik über den Verlauf der Werte in der gesamten Schachpartie anzeigen lassen. Gute Werte für weiß werden positiv, gute Werte für schwarz negativ dargestellt. Jeweils ein Strich auf der vertikalen Achse entspricht einer Bauerneinheit.

Mit einem Doppelklick auf einen Balken können Sie zu dem entsprechenden Zug springen.

Sie können mit einem Klick mit der linken Maustaste auf das Zuginfo Fenster das Statistikfenster sichtbar oder wieder unsichtbar machen. Alternativ mit Optionen/Permanente Statistik.

Die Farbe der Balken können Sie unter Optionen/Oberfläche/Hauptfenster mit "Statistik Balken weiß" und "Statistik Balken schwarz" ändern.

Die Balken werden in einer Wertungspartie nicht angezeigt


Arena - Hilfe -Bildschirm - Die Werkzeugleiste

Die Werkzeugleiste

Sie wird direkt unter dem Hauptmenü angezeigt. Sie kann über Optionen / Oberfläche / Hauptfenster / Anzeige komplett ausgeschaltet werden.

Sie besteht aus folgenden Elementen:

Neu, Datei öffnen, Datei speichern, Unendlich ein/aus, Spielstufe +/-, Variante, Umdrehen, Aufstellen, Oberfläche, Schachbrett größer/kleiner, nächste/vorige PGN- Partie laden, ICS Modus starten/verlassen, DGT Modus starten/verlassen, die Speicheranzeige, die EPD +/- Knöpfe, die Arena- Versionsanzeige.

Zusätzlich können Sie auch kleine Navigationsknöpfe in die Werkzeugleiste einblenden.

Unendlich ein/aus:

Mit der umgedrehten "8" (das mathematische "Unendlich" Zeichen) können Sie den unendlich- Modus ein/ und ausschalten. Durch einen Klick mit der rechten Maustaste können Sie den Spielmodus wählen (Feste Suchtiefe, Zeit pro Zug, Blitz, Mattsuche, Unendlich, Turnier, Knoten)

+/- Lev (Spielstufe+/-):

Mit der linken Maustaste können Sie die Spielstufe erhöhen oder erniedrigen. Im Turniermodus können Sie mit der linken Maustaste die Minuten, mit der rechten Maustaste die Anzahl der Züge ändern. Im Blitzmodus können Sie linken Maustaste die Basiszeit (Minuten) und mit der rechten Maustaste den Bonus je Zug in Sekunden erhöhen oder erniedrigen.

Variante:

Hiermit können Sie eine Variante starten oder beenden.

Umdrehen:

Die Darstellung des Schachbrettes kann hier umgedreht werden.

Aufstellen:

So starten Sie den Aufstelldialog.

Oberfläche:

Damit starten Sie den Oberfläche Dialog. Die meisten Einstellungen für die Darstellung der Oberfläche, wie Farben, Schriftarten etc. können hier eingestellt werden.

Schachbrett größer/kleiner:

Hier können Sie das Schachbrett größer oder kleiner darstellen lassen. Relativ dazu verändern sich alle anderen Bestandteile der Oberfläche.

Nächste/vorige PGN- Partie laden:

Mit der linken Maustaste können Sie die nächste oder vorige PGN- Partie laden. Mit der rechten Maustaste können Sie zu einer Partie springen, von 10 bis 10.000 vorwärts oder rückwärts falls ein Sprung zu weit wäre, wird zum Anfang oder Ende gesprungen. Bitte beachten sie, dass die aktuelle Sortierreihenfolge der PGN- Liste hier beachtet wird. Wenn Sie also alle Partien nach dem Spielernamen sortiert haben sind hier auch alle Partien eines Spielers hintereinander.

ICS Modus starten/verlassen:

Sie starten hiermit den ICS-Modus, die Anzeige verändert sich und Sie können ein ICS- Profil auswählen. Falls Sie schon in diesem Modus sind, verlassen Sie den ICS-Modus auch über diesen Schaltknopf. (Identisch mit Strg+I)

DGT Modus starten/verlassen:

Mit einem Klick mit der linken Maustaste starten oder beenden Sie den DGT- Modus mit den Parametern, die Sie eingestellt haben. Falls Sie noch Parameter einstellen möchten, klicken Sie mit der rechten Maustaste. (Identisch mit Optionen/Konfiguriere DGT Schachbrett, STRG-F11)

Die Speicheranzeige:

Arena zeigt ihnen hier den verfügbaren Speicher auf ihrem Rechnersystem an. Sie können also immer beobachten, ob Sie evtl. einem Motor zuviel Hashtabellen zugeteilt haben. Bei einem Klick auf die Anzeige wechselt die Darstellung von kB auf MB oder umgekehrt. Wenn Sie weniger als 10% freien Speicherplatz haben, wird die Schrift rot dargestellt. Der Wert wird gerundet, beachten sie, dass 1MB = 1024kB sind.

Wenn Sie die Werkzeugleiste ausgeschaltet haben, erscheint eine entsprechende Speicheranzeige links in der Statuszeile.

Die EPD +/- Knöpfe:

Hiermit können Sie zur nächsten oder vorigen Stellung in der gerade geladenen EPD Datei gehen. Das ist vor allem dann nützlich, wenn Sie die EPD Liste über das Hauptmenü/EPD ausgeschaltet haben.

Die Arena - Versionsanzeige:

Sie dient nicht nur der Information über die aktuelle Versionsnummer, sondern man kann mit der linken Maustaste auch die Hilfedatei aufrufen und mit der rechten Maustaste das Informationsfenster.

Werkzeugleisten-Konfiguration:

Unter Optionen / Werkzeugleiste konfigurieren oder im Kontextmenü der Werkzeugleiste erreichen Sie diesen Dialog.

Alle Elemente der Werkzeugleiste können Sie hier ein- und ausschalten. Verschieben einzelner Elemente ist auch möglich.


Arena - Hilfe -Bildschirm - Die Navigationsleiste

Die Navigationsleiste

Mit dieser Leiste unter dem Schachbrett oder unter der Zugliste können Sie verschiedene Grundfunktionen ausführen:

Mit den ersten vier Tasten von links können Sie in der Partie hin- und herspringen, mit dem Demo-Knopf ein Spiel des Motors oder der 2 Motoren gegen sich selbst starten, oder in den Analyse- oder den Bearbeiten- Modus umschalten.

1.Anfang-Knopf: Springt an den Anfang der Partie, wie nicht anders zu erwarten. Wenn Sie jedoch mit der rechten Maustaste klicken, wird 10 Züge zurückgesprungen.

2. Nach links-Knopf: Springt einen Zug zurück. Bei einem Rechtsklick wird 5 Züge zurückgesprungen.

3. Nach rechts-Knopf: Geht einen Zug vor. Bei einem Rechtsklick wird 5 Züge vorgesprungen.

4. Ende-Knopf: Springt an das Ende der Partie, wie nicht anders zu erwarten. Wenn Sie jedoch mit der rechten Maustaste klicken, wird 10 Züge vorgesprungen.

5. Chip-Knopf: Startet die Rechnung des aktuellen Motors. Der Motor wird nach seiner Rechenzeit dann auch einen Zug ausführen.

6. Demo-Knopf: Startet den Demo(strations)-Modus, wo der Motor oder die 2 Motoren gegen sich selbst spielt oder spielen. Kann auch mit Strg-D aufgerufen werden. Geeignet vor allem für kurze Tests. Für Testserien empfiehlt sich allerdings vor allem ein Motoren-Turnier , erreichbar im Hauptmenü unter Optionen.

7. Analyse-Knopf: Lässt den Motor oder die Motoren analysieren oder beendet die Analyse. Dabei können die Motoren keine Züge selbst ausführen. Sie können in der Partie hin- und herspringen mittels der Navigations- Knöpfe oder in der Zugliste den gewünschten Zug auswählen, ohne den Analyse Modus zwischenzeitig zu beenden. Sie können auch in der EPD- Liste die Stellung auswählen, ohne den Analyse Modus zu verlassen. Bedenken Sie aber, dass im Analyse Modus die Motoren stark beschäftigt sind und nur langsam auf ihre Kommandos reagieren. Daher es ist im Analysemodus am wahrscheinlichsten, dass Arena und die Motoren außer Takt geraten. Falls dieses einmal passieren sollte, ist es ratsam, den entsprechenden Motor neu zu starten.

8. Bearbeiten-Knopf: Falls dieser Knopf gedrückt ist, können Sie in Ruhe eine Partie eingeben oder sonstwie bearbeiten und kein Motor kann jetzt losrechnen, wie das ja normalerweise der Fall wäre, nachdem Sie einen Zug gemacht haben.


Arena - Hilfe -Bildschirm - Die Statusleiste

Die Statusleiste

Die Statusleiste am unteren Fensterrand enthält zwei Bereiche. Im ICS- Modus erscheint noch ein dritter Bereich. Links steht die aktuelle Spielstufe. Daneben ist die Datei, unter der Sie zuletzt gespeichert haben, angegeben.

Wenn Sie die Werkzeugleiste ausgeschaltet haben, erscheint in der linken Ecke zusätzlich als erstes die Anzeige des freien Speicherplatzes.

Im ICS- Modus wird hier auch der Name des Benutzers und der Server angegeben in der Form Benutzer@Server. Evtl. wird auch auf einen Computer-Account hingewiesen.

Mit einem Kick auf die Spielstufen- Anzeige mit der linken Maustaste wird der Dialog zum Einstellen der Spielstufe aufgerufen. Mit der rechten Maustaste erscheint das Kontextmenü, um den Spielmodus zu wählen, wie bei einem Klick auf das Unendlich Symbol in der Werkzeugleiste (Feste Suchtiefe, Zeit pro Zug, Blitz, Mattsuche, Unendlich, Turnier, Knoten).

Wenn Sie auf die Datei Anzeige klicken, können Sie eine andere Datei laden.

Die Schriftart der Statusleiste können Sie unter Optionen / Oberfläche / Hauptfenster / Weitere einstellen.


Arena - Hilfe -Bildschirm - Oberfläche konfigurieren

Die Oberfläche von Arena konfigurieren

Mit einem Klick mit der rechten Maustaste auf das Schachbrett, Auswahl 'Oberfläche' im Kontextmenü oder im Hauptmenü unter Optionen / Oberfläche erreichen Sie den Oberfläche-Dialog. Zusätzliche Kurzhilfen ('Tooltips') sind auch über das Menü Hilfe /Tooltip Hilfen zu erreichen.

Der Dialog besteht aus mehreren Hauptseiten, die Sie auf der linken Leiste auswählen können:

Hauptseite "Schachbrett":

Registerkarte Farben+Grafiken:

Sie haben folgende Bereiche zur Auswahl: Helles und dunkles Feld erklären sich von selbst. Der Schachbrettrand ist der Rand zwischen den Schachfeldern und den äußeren Grenzen des Schachbrettes. "Umrandung und Gitter" sind die kleinen Linien, die jedes Schachfeld umranden können.

Die Farbe für die Markierung des letzten Zuges auf dem Schachbrett können Sie mit der Einstellung für "Letzter Zug" festlegen.

Die Feldmarkierung ist die Markierung für das Feld, welches Sie angeklickt haben,
z.B. um die Figur zu wählen, mit der Sie ziehen wollen.

"Gitterlinien anzeigen" aktiviert die kleinen Linien zwischen den Schachfledern. "Schachbrett umranden" aktiviert eine Umrandung für das ganze Brett. "Zeige letzten Zug" markiert den zuletzt ausgeführten Zug. Dies ist in verschiedenen Stilen möglich. Bei den Umrandungsstilen ist ausserdem eine Angabe der Dicke der Umrandung möglich.

Auch können Sie Grafiken für die Schachfelder und den Rand angeben. Die Farbangabe werden dann natürlich ignoriert.

Registerkarte Figuren

Sie haben die Auswahl zwischen 3 verschiedenen Figurentypen:

1. Mitgelieferte Figuren (in Arena bereits eingebaut)
2. Figuren von TrueType- Schriftarten, die normale Felder als Hintergrund verwenden
3. Figuren von TrueType-Schriftarten in Originalversion mit Schraffierung für schwarze Felder

Verwenden von TrueType Schriftarten unter Arena

Im Internet (z.B.chessvariants.com oder enpassant.dk ) finden Sie sicherlich die Schriftarten, die Ihnen gefallen. Laden Sie diese herunter und speichern Sie sie in einem beliebigen Ordner (z.B. c:\temp). Entpacken Sie sie ggf. mit einem Entpack-Programm.

Um TrueType- Schriftarten nutzen zu können, müssen diese natürlich unter Windows installiert sein. Gehen Sie dazu wie folgt vor: Unter Start / Einstellungen / Systemsteuerung / Schriftarten / Datei / 'Neue Schriftart installieren' kommen Sie zu dem Dialog, in dem Sie die Schriftartdatei angeben können. Suchen Sie sich dazu den Ordner, in dem Sie Ihren Schriftartdateien zuvor gespeichert haben (hier also z.B. c:\temp). Beenden Sie diesen Dialog mit 'Ok'.

Jetzt brauchen Sie nur noch unter Arena die Schriftart anzugeben: Also im Oberfächen Dialog, Schachbrett, Figuren, 'Figuren von TrueType- Schriftarten' anklicken und dann auf den Knopf 'Andere Schriftart auswählen' klicken. Suchen Sie sich dann die gerade installierte Schriftart aus.

Arena erkennt einige Schriftarten und stellt die Parameter wie Skalierung, Zentrierung etc. automatisch ein. Wenn ihre Figuren etwa so

aussehen, haben Sie gewonnen und können den folgenden Abschnitt überspringen.

Weitere Schriftarten können Sie über die Editierfelder auf dieser [image] Registerkarte anpassen. So muss z.B. die Skalierung stimmen und natürlich die Buchstaben für die Schachfiguren. Leider hat sich hier kein Standard eingebürgert, so dass man dieses für unbekannte oder neue Schriftarten einstellen muss.

Beliebte Figurenschemata sind z.B. 'rnbqkp' und 'tmvwlo' für Chess Merida. Statt dieser Buchstaben enthält die Schriftart dann einfach die Figurensymbole.

Arena unterstützt standardmässig die frei verfügbaren Schriftarten von Armando Hernandez Marroquin und Eric Bentzen. Die Schriftarten von Marroquin beinhalten: Chess Kingdom, Chess Leipzig, Chess Magnetic, Chess Mark, Chess Marroquin, Chess Medieval, Chess Merida, Chess Millenia, Chess Motif, Chess Utrecht. Von Bentzen stammen die Fonts Chess Alpha und Chess Berlin.

Die Schriftart 'Chess Merida' ist eine für die meisten Zwecke gut verwendbare Standardschrift für Schachfiguren. Er wird beim ersten Arena - Programmstart installiert, falls Sie Arena von einem Setup-Programm aus installiert haben.

Falls Sie Probleme mit den TrueType- Schriftarten haben wie etwa Figuren, die nicht ausgefüllt erscheinen, so haben Sie unter Windows 95 evtl. kein Windows 95 - Plus-Paket installiert. Ohne dieses Paket haben Sie keine Kantenglättung für Schriftarten. Die Kantenglättung muss nicht mehr unter 'Start / Einstellungen / Systemsteuerung / Anzeige / Plus! / Bildschirmschriftarten glätten' (Puh!) eingeschaltet sein, wie dies unter früheren Arena Versionen der Fall war. Kantenglättung funktioniert unter dem Betriebssystem Windows leider nur mit minimal 32768 Farben, also "HiColor" oder häufig "mittlere Aufläsung" genannt. Sie müssen dafür evtl. also noch unter 'Start / Einstellungen / Systemsteuerung / Anzeige / Einstellungen / Farbqualität' die Farbtiefe erhöhen. Ideal und heutzutage meist ohne Probleme ist natürlich "Höchste Farbteife", "True Color" oder 32 oder 24 Bits.

Falls Sie Figuren von TrueType- Schriftarten, also Punkt 2 oder 3 ausgewählt haben, kann die Berechnung der neuen Grafiken bei einer Größenänderung des Schachbrettes einige Zeit in Anspruch nehmen. Schneller geht es, wenn eine Maske definiert ist, wie sie die Schachriftart "Chess Merida Arena" oder einige andere Schriftarten von anderen Schachprogrammherstellern haben. Diese Maske beschleunigt nur den Grafikaufbau, sie ist nicht zwingend notwendig.

Schatten werden rechts und unter einer Figur angezeigt, wenn Sie den entsprechenden Punkt anwählen. Ein Helligkeitsverlauf kann hinzugefügt werden. Dadurch werden die Figuren links etwas heller als rechts dargestellt.

Gleitende Figuren

Auf dieser [image] Registerkarte können Sie auch einstellen, ob Figuren gleiten (animiert dargestellt) sollen oder nicht. Der Wert dafür sollte durch Ausprobieren ermittelt werden, da unterschiedliche Rechner und Grafikkarten mittlerweile sehr unterschiedlich schnell sein können. Bei Turnieren oder im Demo Modus kann ein kleinerer Wert eingestellt werden ('Geschwindigkeit Wettkampf'), damit dabei nicht sinnlos Zeit mit animierter Zugdarstellung verplempert wird.

Registerkarte Zusätze

Ob und an welcher Stelle (oben, unten, rechts, links) die Brettkoordinaten a-h und 1-8 eingeblendet werden, können Sie hier bestimmen. Die Schriftart für die Koordinaten nebst Farbe der Buchstaben und Zahlen ist weiterhin einstellbar.

Mit "ABCDEFGH" können Sie Großbuchstaben für die Brettkoordinaten auswählen.

"Innerhalb des Schachbrettes" stellt die Koordinaten platzsparend auf den Randfeldern dar, sonst sind die Koordinaten neben den Randfeldern.

Wenn Sie eine Figur von einem Feld auf das andere ziehen, kann der Mauszeiger entweder unverändert bleiben, ein spezielles Symbol bekommen oder ganz ausgeblendet werden.

Unter Einstellungen/ "Am Zug Anzeige" können Sie festlegen, ob die Seite am Zug mit einem Punkt neben den Felder auf dem Schachbrett gezeigt werden soll.

"Zusätzlicher Brettrand" vergrößert den Brettrand auf Kosten der Felder.

"Brettrand an allen Seiten gleich breit" gleicht evtl. ungleiche Ränder (aufgrund von unterschiedlichen Breiten und Höhen der Koordinaten) oben, rechts, unten und links aus und vergrößert alle Bereiche.

Die Option "Spielernamen über/unter Brett anzeigen" blendet eine kleine Zeile mit den Spielernamen oberhalb und unterhalb des Brettes ein:

Wenn Sie diese Option gewählt haben, haben Sie einige weitere Optionen: Sie können die Farbe für das Feld mit dem aktiven Spieler ändern, die Flaggen in diesem Bereich einblenden, die aktuellen Bewertungen des Motors, die Wertungszahlen sowie die Uhren. Für die Uhren können Sie noch die Schriftgröße angeben, im Übrigen wird die Schrift wie unter "Schriften" angegeben, verwendet.

Registerkarte Pfeile

Pfeile zur Kennzeichnung des besten Zuges können Sie für Analysen, Berechnungen und Berechnungen beim Pondern anzeigen lassen. Bei Analysen werden Pfeile angezeigt, wenn Sie den Analyseknopf in der Werkzeugleiste drücken.

Für jeden Motor (1., 2. und 3.) können Sie eine eigene Farbe zur Unterscheidung auswählen.

Wenn Sie den Stil "durchsichtig" auswählen, bedenken Sie bitte, daß diese Auswahl mehr Rechenzeit benötigt, Stil "einfach" ist schneller.

Registerkarte Zugeingabe

"Reihenfolge-erst Zielfeld erlauben" bedeutet, daß Sie auch Züge eingeben können, indem Sie zuerst das Zielfeld und dann erst das Ausgangsfeld anklicken.

"Ein-Klick-Eingabe erlauben" prüft bei jedem Klick auf ein Feld, ob die angeklickte Figur nur einen Zug hat und führt diesen dann sofort aus. Auch wenn nur eine Figur auf ein Zielfeld ziehen kann, wird der Zug sofort ausgeführt.

"Zugeingabe mit der Tastatur erlauben" ermöglicht ihnen, einen Zug mit der Tastatur zu machen. Für den Zug e2e4 einfach z.B. nacheinander die Tasten "e","2","e" und "4" eingeben.

Wenn Sie "vervollständigen" wählen, sucht Arena den Zug, auch wenn Sie nur Teile des Zuges angegeben haben, z.B. in Kurznotation "e" und "4" eingegeben haben. Bei "nur komplette Zugeingaben auswerten" wird diese Funktion ausgeschaltet und Sie müssen den Zug in Langnotation angeben.

Hauptseite "Zugliste"

"Kurznotation" verwendet Kurznotation in der Zugliste, sonst wird Langnotation verwendet.

"Zeige Buchnamen bei Buchzügen" blendet den Namen des Arena-Buches ein, aus dem der Zug gespielt wurde, wenn der Zug aus einem Arena-Buch gespielt wurde.

"Zeige Bewertungen/Zeiten" blendet die Basisdaten (Zugwert/ Suchtiefe und Zeit) eines Zuges ein oder aus.

"Zeige Kommentare in der Zugliste" schaltet evtl. vorhandene Kommentare ein oder aus. Häufig werden Komentare in PGN Dateien eingebettet. Arena kann diese auch in Varianten lesen und speichern.

Wenn Sie "Hauptlinie in Fettschrift bei Varianten" anhaken, dann wird die Schriftart für die Notoation der Hauptpartie automatisch auf fett eingestellt. Varianten werden nicht fett dargestellt. Dadurch wird die Lesbarkeit verbessert. Sie sollten dann im folgenden Schritt nicht sowieso eine Fettschrift auswählen.

Züge, Bewertungen und Kommentare können eigene Schriftarten und Schriftfarben in der Zugliste bekommen.

Wählen Sie eine figurine Schriftart (Name der Schriftart enthält die Zeichenkette "figurine") aus, werden Figursymbole statt der üblichen Buchstaben für die Figuren (D=Dame etc) angezeigt:

Folgende Schriftarten können Sie z.B. verwenden: Arena Chess Figurine, Figurine CB Aries, Figurine CB Letter, Figurine CB Time. Nicht funktionieren FigurineSymbol S1-S3 und FigurineSymbol T1-T3.

"Markierter Zug Farbe" definiert die Farbe für die Schrift des aktuellen Zuge in der Zugliste, "Markierter Zug Hintergrund" die Farbe für den Hintergrund (nur beim freien Format).

Das allgemeine Format der Zugliste kann eingestellt werden. Das "feste Format" (im Moment deaktiviert) zeigt immer den Zug und darauf folgend die vom Motor berechnete Hauptvariante in einer Zeile. Das "freie Format" zeigt alle Züge fortlaufend mit nur den Basisdaten (Zugwert/ Suchtiefe, Zeit und evtl. Kommentaren) an. Die formatierten Darstellungen zeigen die gleichen Daten wie das freie Format, nur daß lediglich ein Zug pro Zeile angezeigt wird.

Hauptseite "Hauptfenster":

Registerkarte Farben

Die Trenner und Programmrand-Farbe können Sie angeben. Dadurch werden die für die Grössenveränderung der Elemente des Hauptfensters wichtigen Trenner farblich hervorgehoben oder auch nicht, so wie Sie das wünschen.

Die Uhr für die Seite, die am Zug ist, können Sie anders anzeigen lassen als die Uhr für die Seite, die nicht am Zug ist.

Die Farben für die Permanente Statistik können Sie mit 'Statistik Balken weiß' bzw. 'Statistik Balken schwarz' einstellen. Der Motor, der weiß spielt, erhält also einen andersfarbigen Balken in dieser Statistik.

Registerkarte Anzeige

Hier können Sie die Uhren und Logos ganz abschalten oder um 10% vergrößern. Wenn Sie Flaggen installiert haben, können Sie diese unter den Logos oder Namen anzeigen lassen. Die unterste Zeile des Logobereichs kann gar nichts, den Autor des Motors oder den Motorennamen oder beides anzeigen.

Die Werkzeugleiste können Sie ganz abschalten, sowie die Anzeige der kleinen Königsfiguren neben den Uhren, die die Seite am Zug kennzeichnen.

Wenn Sie "Brettfenster immer quadratisch" einschalten, passt Arena die übrigen Fenster immer dem Brettfenster an. Schalten Sie diese Funktion aus, können größere Ränder rechts und links oder ober- und unterhalb der Schachbrettes entstehen, die Darstellung der übrigen Fenster ist aber evtl. für Sie angenehmer.

Die Statistik können Sie skalieren, d.h. den Bereich in Bauerneinheiten, den Sie angezeigt haben möchten, größer oder kleiner machen.

Registerkarte Weitere

Für den Hintergrund, auf dem das Schachbrett sich befindet, die Werkzeugleiste, und den Uhren/Logo-Bereich können Sie Grafiken hinterlegen. Wenn Sie keine Grafiken verwenden, werden die eingestellten Farben unter der [image] Registerkarte "Farben" für diese Elemente verwendet.

Für Zuginformationen, Statuszeile, Spielernamen, Eröffnungsklassifikation, Buchzüge, PGN/EPD-Listen, Uhr der Seite nicht am Zug, Uhr der Seite am Zug können Sie die Schriftart auswählen. Dazu zählt auch die Farbe, Größe und der Schriftschnitt (z.B. kursiv).

Trenner und Randbreite bestimmen die Breite der entsprechenden Elemente in Pixeln. Der Rand ist der Rand des Hauptfensters. Trenner befinden sich z.B. zwischen Schachbrett und Analyseausgaben.

Mit 3D Stil und Breite können Sie viele verschiedene Effekte für die Bereiche des Arena Hauptfensters einstellen. So können z.B. die Bereiche wie Schachbrett, Zugliste, Analysen herausgehoben erscheinen, fein umrandet oder vertieft.

Hauptseite "PGN"

Hier können Sie PGN-Optionen einstellen. Sie können bestimmen, was passiert, wenn Sie eine Partie aus einer PGN-Datei laden. Danach kann das PGN Fenster geschlossen oder verkleinert werden. Auch kann automatisch zu einem bestimmten Zug gesprungen werden. Wenn Sie immer ans Ende möchten, geben Sie einfach einen hohen Wert ein.

Wenn Sie die aktuelle Partie im PGN Format speichern möchten, können Sie hier festlegen, ob dabei auch Hauptvariante, Wert und Tiefe und Dauer jedes Zuges (soweit die Informationen vorhanden sind) gespeichert werden.

Das automatische Speichern eröffnet Ihnen weitere Möglichkeiten. Damit kann die laufende Partie im PGN Format nach jedem Zug gespeichert werden. Nützlich z.B. als Sicherheitskopie.

Auch können alle Partien im PGN Format automatisch mitgeloggt werden. Bei dieser Funktion wird eine Partie gespeichert, bevor eine neue Partie begonnen wird. So geht Ihnen keine Partie mehr verloren, falls Sie einmal vergessen haben, Sie zu speichern.

Hauptseite "Klänge"

Registerkarte Allgemein:

In bestimmten Situationen können Klänge in Form von Wav- oder Midi-Dateien abgespielt werden:

  • Bei einem Schachgebot
  • Während eines normalen Zuges
  • Während eines Schlagzuges
  • Figuren aufstellen (wenn eine neue Stellung aufgebaut wird)
  • Gewonnen
  • Verloren
  • Bei Remis
  • Beim Start von Arena

Registerkarte Zugansage:

Wenn Sie Züge akustisch ansagen lassen möchten, dann können Sie hier ein Verzeichnis angeben, wo sich die Zugdateien befinden. 'Kurze Ansage' sagt die Züge in Kurznotation an, als z.B. 'Sg3'. Wenn der Text 'Bauer' angesagt werden soll, dann klicken Sie '''Bauer'' ansagen' an. Sehr gute Zugansagen in deutsch und englisch von Jörg Borchardt sind auf unserer Internetseite verfügbar.

Zugansagen-Dateiliste

"Kurze Ansage" sagt die Züge in Kurznotation an, "'Bauer' ansagen" sagt das Wort "Bauer" mit an.

Falls bei Ihnen die Zugansagen z.B. abgeschnitten werden, können Sie die Verzögerung, die bei jedem Buchstaben erfolgt, heraufsetzen,
z.B. auf 120 %.

Hauptseite Sonstiges

'Spielstufe auf 'unendlich' beim EPD-Laden' stellt die Spielstufe gleich auf 'unendlich' ein, wenn Sie eine EPD Datei laden, z.B. wenn Sie Stellungen aus einer solchen Datei analysieren möchten.

'Eigener Lade-Dialog' bewirkt (im Moment nicht aktiv), dass nicht der Windows-Lade-Dialog angezeigt wird, wenn Sie eine Datei laden möchten, sondern ein Arena- eigener Dialog mit Vorschau etc.

"Bestätigen ... wenn Partie nicht gespeichert" bewirkt eine Sicherheitsabfrage, falls Sie eine Partie überschreiben möchten und die aktuelle Partie noch nicht gesichert wurde.

"Bestätigen ...Wettkampf abbrechen" bewirkt, daß ein Wettkampf (Turnier) erst nach einer Sicherheitsabfrage abgebrochen werden kann.

Unter "Externes Textverarbeitungsprogramm" können Sie Ihr bevorzugtes Textverarbeitungsprogramm oder Editor auswählen. In allen Funktionen, in denen eine Datei angezeigt werden soll, wird dann dieser Editor verwendet.

Unter "Zusätzlich eingefügter Text beim Kopieren der Analysen in die Zwischenablage" können Sie Text eingeben. Dieser Text wird bei der Funktion "Stellung/ Analysen in die Zwischenablage kopieren" zusätzlich in die Zwischanablage kopiert, um z.B. immer wiederkehrende Daten über die Testkonfiguration hinzuzufügen. Ein "^n" fügt eine neue Zeile ein.

Mit 'Geschwindigkeit beim Durchgehen der Züge' können Sie einstellen, wie schnell Arena beim Vor- oder Zurückspielen der Partie bei dauerhaftem Druck auf die entsprechenden Schaltflächen in der Navigationsleiste durchläuft.

Die 'Geschwindigkeit beim Vorspielen' bestimmt die Verzögerung beim Automatischen Vorspielen mittels Partie / Vorspielen / Vorwärts bzw. Rückwärts.

"Züge auf Legalität prüfen" erlaubt, wenn gesetzt, keine Eingabe illegaler Züge.

"Weiterspielen nach Partieende erlaubt" gestattet es Ihnen und Schachmotoren, die Partie fortzusetzen, obwohl Sie eigentlich nach den Regeln schon beendet wäre, z.B. durch die 50-Züge Regel oder durch Stellungswiederholung.

Mit 'Bedienerzeit' können Sie eine Zeit in Sekunden einstellen, die dem menschlichen Spieler pro Zug gutgeschrieben wird. Dies dient zum Ausgleich für die Zeit, die der Mensch im Vergleich zum Rechner benötigt, um einen Zug auszuführen.

Wenn das Häkchen von 'Werte immer aus Sicht von Weiß' gesetzt ist, werden die Werte, die Motoren bei ihren Bewertungen ausgeben, konvertiert in Werte aus der Sicht von Weiß, d.h. positive Werte= Weiß im Vorteil, negative Werte= Schwarz im Vorteil. Ist der Haken nicht gesetzt, erfolgt die Bewertung immer aus der Sicht des gerade rechnenden Motors. Positive Werte bedeuten dann, dass der Motor meint, er wäre im Vorteil, negative Werte bedeuten, er "denkt", er wäre im Nachteil.

Arena mit Dateiendungen verknüpfen:

Falls Sie Arena als Ihre bevorzugtes EPD- oder PGN- Betrachtungsprogramm verwenden möchten, können Sie dieses hier einstellen.Wenn also bei einem Doppelklick auf eine Datei mit der Erweiterung 'PGN', 'EPD','FEN' oder 'FCH' Arena starten soll und die Datei laden soll, müssen diese Erweiterungen (Dateitypen) im Windows System registriert werden. Klicken Sie auf die entsprechende die Schaltfläche für den jeweiligen Dateityp. Falls ein anderes Programm diese Erweiterung schon benutzt, wird eine Sicherheitsabfrage durchgeführt und Sie können die Aktion noch abbechen. Arena reisst diese Dateitypen also nicht einfach an sich.


Arena - Hilfe -Bedienung

Bedienung

Die Handhabung von Arena ist intuitiv. Die Konfigurationsdialoge sind mit sinnvollen Einstellungen vorbelegt. Nahezu alle Funktionen sind über das Hauptmenü aufzurufen.

Die Menüs enthalten teilweise Untermenüs mit weiteren Funktionen.

Mit einem Maus-Rechtsklick auf ein Bildschirmelement erscheint fast immer ein Kontextmenü, über das Sie viele Funktionen aufrufen können.

Mit dem Mausrad rollen Sie in der Partieliste hin- und her, außer wenn Sie in der PGN- oder EPD-Liste sind.


Arena - Hilfe -Bedienung - Visitenkarte

Visitenkarte

Hier können Sie Ihren Namen, eine Bilddatei von ihnen sowie einen Ort angeben. Diese Angaben werden bei Erstellung einer neuen Partie (also bei Datei / Neu) in die Partie eingetragen.

Sie können ihre Wertungszahl angeben. Dies dient allerdings im Moment nur dazu, das Gladiator Logo zu bestimmen, wenn "Gladiator Logo entsprechend Rating laden" gesetzt ist.

Dabei gelten folgende Abstufungen:

  • unter 800 ELO = Stufe1
  • > 0800 - 1000 ElO = Stufe 2
  • > 1000 - 1200 ELO = Stufe 3
  • > 1200 - 1400 ELO = Stufe 4
  • > 1400 - 1600 ELO = Stufe 5
  • > 1600 - 1800 ELO = Stufe 6
  • > 1800 - 2000 ELO = Stufe 7
  • > 2000 - 2200 ELO = Stufe 8
  • > 2200 - 2400 ELO = Stufe 9
  • > 2400 - 2600 ELO = Stufe 10
  • > über 2600 ELO = Stufe 11

Je nach ihrer Spielstärke wird für Sie also ein anderes Logo geladen (statt der Bilddatei, wenn keine angegeben).

Die Daten für Hardware, Betriebssystem, Webseite und e-Post Adresse werden bei der Turnierfunktion verwendet. Beachten Sie bei der Angabe der e-Post Adresse, daß bei einer Veröffentlichung die Gefahr besteht, verstärkt Spam-Mails zu bekommen!


Arena - Hilfe -Bedienung - Wertungspartie spielen

Wertungspartie spielen

Wenn Sie es wagen möchten, eine Wertungspartie gegen einen Motor zu spielen, erreichen Sie mit Datei / Neu - Wertungspartie diesen Dialog.

Sie können Ihre Spielfarbe selbst wählen oder eine Zufallsauswahl durchführen lassen.

Sie sehen keine Analysezeilen der Motoren in diesem Modus, können keine Züge zurücknehmen.

Falls Sie gegen einen UCI-Motor spielen, können Sie die Partie nur durch Aufgeben vorzeitig beenden.

Wenn Sie einen Winboard- Motor als Gegner haben, können Sie auch Remis anbieten. Bitte beachten sie, dass manche Winboard Motoren diese Funktion nicht unterstützen und ihr Remisangebot nicht auswerten können.

Falls der Motor ihrem Remisangebot zustimmt, wird die Partie sofort Remis gegeben.


Arena - Hilfe -Bedienung - Tastenkürzel

Tastenkürzel

Einige Tastenkürzel, die die Arbeit mit Arena beschleunigen können und nicht im Hauptmenü zu finden sind:

[Leertaste] oder STRG+Z Computer zieht sofort

Strg+[Leertaste] Motoren fangen an zu analysieren

ESC Beendet die Rechnung oder das Analysieren

Rollen spielt die Partie vorwärts ab.

Pause spielt die Partie rückwärts ab.

-- > (Pfeiltaste) Ein Zug vor

< -- (Pfeiltaste) Ein Zug zurück

Pos1 geht an den Anfang der Partie

Ende geht ans Ende der Partie

Bild ab geht ans Ende der sichtbaren Zugliste

Bild auf geht an den Anfang der sichtbaren Zugliste

+ (Ziffernblock) Vergrössert das Schachbrett

- (Ziffernblock) Verkleinert das Schachbrett

F10 Haupmenü aktivieren

Alle weiteren Tastenkürzel sehen Sie im Hauptmenü neben dem Menüpunkt!


Arena - Hilfe -Bedienung - Wertungszahl Berechnung mit ELOStat

Wertungszahl Berechnung mit ELOStat

Sie können nun das fantastische Programm ELOStat von Dr. Frank Schubert innerhalb von Arena verwenden. Die Berechnung von Wertungszahlen ist nun eine einfache Sache für jedermann.

Starten Sie ELOStat im Hauptmenü unter 'Extras / Wertungszahl Berechnung mit ELOStat', und schon können Sie diese Parameter komfortabel in einem grafischen Arena - Dialog einstellen. Wenn Sie das gemacht haben, brauchen Sie nur noch den Knopf "Start ELOStat" zu drücken, und schon startet Arena ELOStat mit diesen Parametern. Sie können auf der [image] Registerkarte "ELOStat Arbeitsbereich" sehen, was passiert.

ELOStat benötigt nur drei Einstellungen:

  • Die PGN Datei, woraus die Wertungszahlen berechnet werden sollen
  • Die Start ELO - Zahl
  • Die minimale Anzahl Partien, ab der ein Spieler in die Berechnung einbezogen werden soll.

ELOStat generiert 4 Dateien: Rating.dat, programs.dat,general.dat, cluster.dat. Diese Dateien werden in vier getrennten [image] Registerkarten angezeigt. Vorsicht: ELOStat überschreibt diese vier Dateien bei jedem Lauf.

  • Die Datei rating.dat enthält die Wertungszahlen aller Programme (oder Menschen!) in einer Datei.
  • Die Datei programs.dat zeigt individuelle Statistiken der Spieler in der PGN Datei.
  • Die Datei general.dat gibt ihnen allgemeine Statistiken über die schwarz/weiß Leistung und die benutzten Eröffnungen.
  • Die Datei cluster.dat enthält eine Zusammenfassung der festgestellten Cluster der Motoren, die gegeneinander gespielt haben, aber nicht gegen Motoren aus anderen Clustern.

Wenn Sie ihre vier ELOStat Ausgabedateien und die PGN Datei an einen sicheren Ort kopieren möchten (da ELOStat die Dateien ja jedes Mal überschreibt), können Sie "Dateien kopieren nach" wählen. Im folgenden Dialog können Sie ein Zielverzeichnis für ihre Dateien auswählen oder erstellen. Wenn Dateien im Zielverzeichnis schon existieren, werden sie überschrieben.

Wenn es nicht funktionieren sollte:

Die Datei "ELOStat._exe" muss im Verzeichnis "ELOStat" unterhalb des Arena Ordners liegen, d.h. ein korrekter Pfad wäre z.B.: C:\Arena\ELOStat\ELOStat._exe.

ELOStat Versionen vor Version 1.2 funktionieren nicht. Sie können die neuste Version von ELOStat auf der Arena Webseite herunterladen. Das Programm ist selbstverständlich frei verfügbar! Vielen Dank an Frank Schubert!


Arena - Hilfe -Bedienung - Schachbrett umdrehen

Schachbrett umdrehen

Mit Optionen / Umdrehen, dem Symbol in der Werkzeugleiste [image] oder F12 können Sie das Schachbrett umdrehen.

Nur die Darstellung wird umgedreht, sonst ändert sich nichts.


Arena - Hilfe -Bedienung - Partie vorspielen

Partie vorspielen - Rückwärts/Vorwärts

Erreichbar mit Partie / Vorspielen Vorwärts oder Partie / Vorspielen / Rückwärts oder mit einem Klick mit der rechten Maustaste auf die Partieliste, dann im Kontextmenü Vorspielen Vorwärts oder Rückwärts wählen. Tastenkombinationen: Strg-Y/Strg-R.

Spielt die Partie automatisch vor oder zurück.

Vorzeitig beenden können Sie den Vorspielmodus mit der Esc- Taste, einem Klick mit der linken Maustaste auf das Schachbrett oder die Zugliste.

Im Optionen/Oberfläche Dialog unter der Hauptseite Sonstiges, im Eingabefeld Verzögerung/beim Vorspielen, können Sie bestimmen, wie lang die Verzögerung zwischen den Zügen sein soll.


Arena - Hilfe -Bedienung - Gehe nach Zug

Gehe nach Zug

Erreichbar über Partie / Gehe nach Zug oder Strg-G.

Ein kleiner Dialog, wo Sie die Nummer des Zuges, zu dem Sie gehen wollen, direkt eingeben können oder auch mit den Pfeiltasten neben dem Eingabefeld den Zug sich heraussuchen können.


Arena - Hilfe -Bedienung - Export

Export einer Stellung

Unter Stellung / Exportieren finden Sie diese Funktion.

Sie können eine Grafik in die Zwischenablage, als JPG oder BMP-Grafikdatei exportieren. Wählen Sie dafür unter "Typ" " Grafik".

Auch können Sie eine Stellung als Zeichenkette zur Weiterverarbeitung mit einer Textverarbeitung in die Zwischenablage kopieren. Wählen Sie dafür unter "Typ" " TrueType-Notation". Sie können dann in einer Textverarbeitung diese Zeichenkette einfügen und mit einer Schach-Schrift formatieren, z.B. mit "Chess Merida". Auf diese Weise können Sie einfach Diagramme in eine Textverarbeitung einfügen.

Beispiel, links die gleiche Zeichenkette in Wordpad, rechts unten im Editor:


Arena - Hilfe -Motoren

Das Arena - Motoren - System

Arena wurde als Mehrfach-Motor-System konzipiert.

Dies bedeutet, dass die grafische Oberfläche und das eigentliche Schachprogramm strikt voneinander getrennt sind und über eine vordefinierte Schnittstelle miteinander kommunizieren. In Arena ist es möglich, maximal 3 Schachmotoren parallel - z.B. zur Analyse - zu betreiben.

Damit bietet das System ideale Voraussetzungen, mit möglichst vielen Schachprogrammen unter einer einheitlichen Schnittstelle zu arbeiten.

Arena unterstützt zwei unterschiedliche Standards von Schachmotoren:

  • UCI-Motoren

  • Winboard-Motoren


Arena - Hilfe -Motoren - Motor konfigurieren

Motor konfigurieren

Sie erreichen diesen Dialog im Hauptmenü unter Motoren/ Motor 1(oder 2)/ Konfigurieren oder durch Klick mit der rechten Maustaste auf die Analysezeilen, danach "Motor konfigurieren" wählen. Kurztasten: Strg+1 für den ersten Motor oder Strg+2 für den 2. Motor. Je nach Motortyp (UCI oder Winboard) ist das Verhalten dann unterschiedlich:

UCI Motoren:

In der folgenden Dialogbox können Sie für UCI-Motoren Parameter einstellen.

Welche Parameter für den entsprechenden UCI-Schachmotor einstellbar sind, wird ausschließlich vom Programmierer des entsprechenden Motors festgelegt. Arena erledigt lediglich die Darstellung des Dialoges auf dem Bildschirm und die Übermittlung der Parameter an den Schachmotor.

Falls Sie Standards für einige Parameter, z.B. die Hashtabellengröße festgelegt haben, werden die entsprechenden Parameter in diesem Dialog nicht dargestellt, sondern hier:

Gemeinsame Parameter für alle UCI-Motoren , im Kapitel Motorenverwaltung .

Mit der Schachtfläche "Speichern als neuen Motor" können Sie einen neuen Motor anlegen, der die gerade konfigurierten Eigenschaften bekommt.

Winboard Motoren:

Bei einem Winboard Motor wird die entsprechende Konfigurationsdatei mit dem Textverarbeitungsprogramm geöffnet, wenn Sie unter Motoren / Verwalten [image] Registerkarte 'Details' eine Konfigurationsdatei für diesen Motor angegeben haben.

Einen Winboard Motor müssen Sie i.d.R. neu starten, damit die Änderungen in der Konfigurationsdatei wirksam werden. Mit einem Klick mit der rechten Maustaste auf die Analysezeilen, Motor (neu)starten erreichen Sie das bequem.

Motorenverwaltung


Arena - Hilfe -Motoren - Analysezeilen

Analysezeilen

Unterhalb des Schachbrettes und der Navigationsleiste befinden sich die Analysezeilen.

Die Bereiche in der ersten Zeile:

Sie enthalten grundlegende Suchinformationen, die immer dann aktualisiert werden, wenn der Motor diese Information an Arena sendet.

  • Der Motorname (gelb): Der Name des Motors, und unter Windows NT/2000/XP der Speicherverbrauch des Motors (hier 13MB). Dies ist nicht die Größe der Hashtabellen, sondern der gesamte physikalische Speicher, den der Motor verbraucht hat.
  • Der Typ des Motors (hier in violett):UCI, UCI-2, WB1 oder WB2
  • Den Füllstand der Hashtabellen (blau) (H52%)
  • Die Prozessorzeit (orange), die der Motor für sich verbraucht hat (hier 93%)
  • Die aktuelle Tiefe (weiß): Vollständig untersuchte Tiefe und selektive Tiefe
  • Der aktuell untersuchte Zug (hellblau): Informationen, der wievielte Zug von wie vielen wird gerade durchsucht (1/49) und der gerade untersuchte Zug selbst (Te6).
  • Die Gesamtzahl der untersuchten Knoten (rot): Alle untersuchten Züge in dieser Suche
  • Die Knoten pro Sekunde (schwarz).
  • Hashtabellen-Nutzung (blau): Der Prozentsatz von Einträgen in der Hashtabelle, der belegt ist.
  • Prozessorauslastung (orange): Der Prozentanteil der Prozessorzeit, der von dem Motor verbraucht wird.
  • Die Statistik(grün): Hier werden Informationen zu dem Zug angezeigt, der aktuell der beste ist, mit Informationen, seit wann und mit welcher Tiefe mit welcher Bewertung. Die Suchtiefe (T11), die Zeit, seit wann dieser Zug der beste ist (=die Lösungszeit bei Stellungstests, hier 11 Sekunden), die Bewertung (+0,83) und der Zug selbst (Te6).

Weiterhin können hier Informationen zugeschaltet werden, die im Moment nicht in der Grafik angezeigt werden:

  • Statistiken über die Nutzung der Endspieldatenbanken (Tablebase Hits).
  • Der aktuelle Ponderzug (wenn Pondern eingeschaltet ist)

Die Hauptvarianten in den folgenden Zeilen:

  • Die erste Zeile (Bester Zug...) enthält eine Zusammenfassung der Suche, nachdem der Suchvorgang beendet ist.
  • Die folgenden Zeilen enthalten die Hauptvarianten mit Tiefe, Zeit, Knotenzahl, Knoten pro Sekunde und Bewertung.

Zusatzliche Informationen von UCI-2 Schachmotoren:

  • Es kann eine Textzeile im Hauptvariantenbereich geben, die Informationen über die aktuell untersuchte Variante enthält.
  • Statt der Hauptvarianten können Wiederlegungen angezeigt werden.
  • Beide Informationen können über das Kontextmenü der Analysezeilen unter "Anzeige" eingeschaltet werden. Dafür muß der Motor die Erweiterungen des UCI-Protokolls (hier UCI-2 genannt) unterstützen.

Hinweis: die Farben können konfiguriert werden, daher stimmen sie nicht unbedingt mit ihren Farben überein.

Das Kontextmenü:

Wie üblich, erscheint bei einem Klick mit der rechten Maustaste ein Kontextmenü. Darüber können Sie hier schnell spezifische Funktionen für den gewählten Motor starten:

a) Motor konfigurieren: Ruft für UCI Motoren den UCI Konfigurationsdialog auf. Bei Winboard Motoren wird -falls in der Motorenkonfiguration angegeben- die ini-Datei mittels des Editors angezeigt. Sie können so auch für Winboard Motoren jetzt schnell und einfach Parameter ändern. Bitte bedenken Sie, dass Winboard Motoren die Konfigurationsdatei meist nur einmal lesen und neu gestartet werden müssen, damit die Einstellungen wirksam werden. Siehe dazu auch unten: Motor (neu) starten.

b) Begrenze die Spielstärke auf ELO...: Ruft den Dialog zur Spielstärkebegrenzung auf, nur für UCI-2 Motoren.

c) Pondern: Schaltet das Pondern für diesen Motor ein oder aus. Ein evtl. geladener anderer Motor wird nicht beeinflusst. Man kann also hiermit einen Motor Pondern lassen, den anderen jedoch nicht.

d) Anzeige:

  • Hauptvarianten: Zeigt Hauptvarianten im Fenster an
  • Wiederlegungen: Zeigt Wiederlegungen im Fenster an
  • Wiederlegungen im Hintergrund berechnen: Bewirkt,daß Wiederlegungen berechnet werden, auch wenn die Anzeige auf "Hauptvarianten" eingestellt ist.
  • Position: Sie können die Position des Analyse Bereiches nach unten oder oben verschieben.
  • Aktuelle Variante: Schaltet die Zeile mit den Informationen über die aktuell untersuchte Variante ein oder aus.
  • Konfigurieren: Geht zum Konfigurationsdialog für die Analysezeilen.

e) Befehle:

  • Hashtabelle löschen: löscht die Informationen, die das UCI- Programm in den Hashtabellen gespeichert hat.
  • Hash Booster: wenn eingeschaltet, verdoppeln sich die Hashtabellen, nur für UCI Motoren
  • Debug Modus (UCI): Schaltet den UCI-Debug Modus ein, normalerweise nur für Programmierer und Tester interessant.
  • Analyse nur mit Motor ...: Startet die Analyse. Entspricht dem Druck auf den Analyse Knopf in der Navigationszeile, nur dass nur der 1. oder der 2. Motor alleine analysiert. Der Druck auf den Analyse Knopf beendet die Analyse wieder.
  • Hash Booster : Verdoppelt die Hashtabellen. Z.B. für Analysen sinnvoll.
  • Fenster löschen: Löscht die Analyseausgaben.
  • Dokumentation lesen: Zeigt die Datei "Readme.txt" des Motors an.

f) Multivariantenmodus: Schaltet den Multivariantenmodus ein oder aus. Dabei analysiert der Schachmotor dann mehrere Züge gleichzeitig und gibt ihnen Informationen über mögliche Alternativzüge.

g) Variantenbrett: ruft das Variantenbrett auf. Damit können Sie die Hauptvarianten auf einem separatem Brett analysieren.

h) Analysierten Zug ausführen: Falls Sie gerade den Motor analysieren ließen, können Sie den analysierten Zug mit dieser Funktion ausführen lassen.

i) Analysen in Zwischenablage kopieren: Kopiert die von den Motoren produzierten Hauptvarianten in die Zwischenablage, z.B.:

5/18 00:00,421 55.114 123.081 +0,27 1.b4 Db4: 2.Le5 Tae8 3.Te2
6/18 00:00,551 70.766 123.081 +0,16 1.b4 Db4: 2.Le5 Tae8 3.Te4 Dc5

j) Rechnung beenden: Stoppt die Berechnung oder Analyse des Motors. Dies ist dieselbe Funktion wie beim Stop-Symbol (wenn beim Rechnen) oder des Analyse-Knopfes (wenn beim Analysieren) in der Navigationsleiste, wirkt aber nur auf den aktuellen Motor. Ein zweiter, evtl. analysierender Motor analysiert also weiter.

k) Motor schließen: Beendet den Motor und entfernt ihn aus dem Speicher.

l) Motor (neu) starten: Beendet den Motor und startet ihn neu.

m) Details: Geht zur Detail-Anzeige des Motors. Dieselbe Funktion wie Motoren/Verwalten/Details und dann zu dem Motor gehen.


Arena - Hilfe -Motoren - Analysezeilen konfigurieren

Analysezeilen konfigurieren

Diesen Dialog erreichen Sie im Hauptmenü über Motoren/ Analysezeilen konfigurieren.

Hier können Sie einstellen, welche der Analysefelder sie auf dem Bildschirm sehen möchten.

Registerkarte "Aussehen der Informationsfelder"

Folgende Anzeigeelemente können Sie in der ersten Zeile darstellen lassen:

  • Bewertungs-Symbol (Computersymbol oder Pfeil, hier gerade ausgeblendet)
  • Motorname und Speicherverbrauch
  • Motortyp (UCI oder Winboard)
  • Aktuelle Suchtiefe
  • Aktueller Zug
  • Knoten Gesamt
  • Knoten pro Sekunde
  • Endspieldatenbanken-Nutzung
  • Hash-Nutzung
  • Prozessorlast
  • Ponderzug
  • Bestzug-Statistik

Weiterhin können Sie folgende Elemente konfigurieren (aber nicht ausschalten, daher ist das Häkchen nicht wegzumachen):

  • Hauptvarianten
  • Hauptvarianten 2.Farbe
  • Aktuelle Variante
  • Widerlegungen

Versehen Sie alle Elemente mit einem Häkchen, die sie anzeigen lassen wollen. Wenn ein Element ausgewählt ist, können Sie im Feld daneben (unter "Konfigurieren") die Schriftart und die Hintergrundfarbe für dieses Element einstellen.

Darunter können Sie auch alle Elemente gleich konfigurieren und eine einheitliche Schriftart und Hintergrundfarbe wählen. Mit "Schrift +" vergößern Sie die Schriftart für alle Elemente um einen Punkt, mit "Schrift -" verkleinen Sie alle Elemente um einen Punkt.

small arrow Im Dialog zur Schriftartauswahl können Sie auch die Farbe der Schrift einstellen sowie z.B. Fettschrift.

Registerkarte "Hauptvarianten"

In den Zeilen unterhalb der obersten Zeile finden Sie die Hauptvarianten. Auch ihr Aussehen können Sie weitgehend bestimmen.

Folgende Anzeigeelemente können Sie darstellen lassen:

  • Suchtiefe
  • Zeit
  • Knoten
  • Knoten/Sekunde
  • Bewertung
  • Hauptvariante

Hier konfigurieren Sie die Art und Weise, wie jede vom Motor gefundene Hauptvariante angezeigt wird. Suchtiefe, Zeit, Knoten, Knoten/Sekunde, Bewertung und die Hauptvariante selbst stehen zur Auswahl. Versehen Sie diejenigen Elemente mit einem Haken, die angezeigt werden sollen.

Notation der Züge:

  • Falls Sie 'Kurznotation' in den Hauptvarianten haben möchten,
    • klicken Sie bitte hier.
  • Der 'Bindestrich' ("-") kann bei Langnotation angezeigt oder
    • weggelassen werden.
  • Der 'Doppelpunkt' (":") kann bei Kurznotation als Zeichen
    • für einen Schlagzug verwendet werden. Andernfalls wird das 'x' verwendet.

Sie können Zugnummern in den Hauptvarianten einfügen lassen, wenn Sie möchten. Dabei können Sie auswählen, ob Sie die Zugnummern der Partie fortlaufend einfügen lassen möchten oder die Zählung einfach bei eins beginnt.

Bei Winboard Motoren:

  • Analyse Anzeigen periodisch bedeutet, dass Arena periodisch
    • die Informationen über den aktuell untersuchten Zug abfragt.
  • 'Hauptvariante verschönern' bedeutet, dass die manchmal etwas
    • unleserlichen Ausgaben von Winboard-Motoren in eine lesbarere Form gebracht werden. Es werden deutsche Figurenbezeichnungen verwendet (siehe nächster Punkt), Zeichen für Schlagen eingefügt, evtl. Kurznotation verwendet. Ausgaben von UCI-Motoren werden unabhängig von dieser Einstellung immer verschönert.
  • 'Deutsche Figurenbezeichnungen': Falls Sie den vorigen Punkt
    • nicht angewählt haben, können auch nur einfach die englischen Figurbezeichnungen durch deutsche ausgetauscht werden.

"Zeit mit Millisekunden anzeigen" bewirkt, daß die Zeit, zu der die Hauptvariante gefunden wurde, mit Millisekunden angezeigt wird.

Registerkarte "Optionen"

"Figurine Notation" zeigt statt der Figurenbezeichner (z.B. "T" für Turm) ein entsprechendes Symbol. Voraussetzung ist, daß Sie auch eine passende Schriftart für die Elemente mit Figurenbezeichnern ausgewählt haben, z.B. die Schrift "CA Chess".

"Erklärungen bei neuer Partie zeigen" bewirkt, daß ohne Werte, also am Anfang der Partie, in jedem Feld eine Erkärung angezeigt wird, also z.B. "Aktueller Zug" steht im Feld für den aktuellen Zug.

"Am Ende der Suche Zusammenfassung anzeigen" zeigt den besten Zug, Wert, Tiefe, Dauer und Knotenzahl in den Analysezeilen an. Sinnvoll, wenn man z.B. einige dieser Informationen ausgeschaltet hat. Damit können Sie evtl. auf die ständige Einblendung einiger Informationen in anderen Bereichen verzichten.

"Am Zug Kennzeichnung" zeigt ein "w" oder ein "s" (für weiß oder schwarz) vor dem Motorennamen an, wenn er am Zug ist. Dies gilt nur, wenn mindestens zwei Motoren geladen sind.

"Bewertungs-Symbol-Farbe (in 1/100 Bauern)" bestimmt die Grenzen für die Einfärbung des Bewertungssysmbols (siehe oben). Sie können also bestimmen, wann z.B. eine gute Bewertung mit einem grünen Symbol angezeigt wird.

"Hauptvarianten oben einfügen" bewirkt, daß die aktuellsten Hauptvarianten immer oben in der Liste zu finden sind. "Hauptvarianten unten anhängen" zeigt die neuesten Hauptvarianten immer ganz unten an.

"Ausrichtung der Anzeigeelemente" stellt ein, ob der Text innerhalb der Anzeigeelemente linksbündig, mittig oder rechtsbündig dargestellt wird.

"Randbreite in Punkten" stellt die Größe des Randes der einzelnen Informationsbereiche ein.


Arena - Hilfe -Motoren - Motorenverwaltung

Motorenverwaltung

Über das Hauptmenü "Motoren / Verwalten" erreichen Sie diesen Dialog.

In diesem Dialog können Sie:

  • Die Schachmotoren auswählen, die Sie aktuell verwenden möchten. Dies sind maximal drei gleichzeitig.
  • Schachmotoren (max. 1500) für Arena installieren und z.B. Kommandozeilenparameter mit auf den Weg geben.
  • Optionen für den Betrieb von Winboard und UCI-Motoren einstellen.

Es folgt eine Beschreibung der [image] Registerkarten:

Registerkarte "Auswählen"

Die 'Aktiven Motoren' sind diejenigen, mit denen Sie spielen und analysieren können. Sie zeigen ihre Analysezeilen an und machen evtl. ihre Züge.

Die 'Lieblings Motoren' sind von Ihnen besonders bevorzugte.

Die Liste, die den größten Platz in diesem Dialog verbraucht, zeigt Ihnen Informationen über die installierten Motoren. Sie können die Liste nach jeder Spalte sortieren, indem Sie auf die oberste Zeile der Liste klicken.

Die Spalten dieser Liste enhalten den Namen des Motors, den Typ (UCI oder Winboard), the Winboard-Features (A=Analyze mode,E=Edit mode,M=Move now,P=Ponder, O=Opening book, T=Tablebases), das Land, den Kommentar zu dem Motor, die Wertungszahl des Motors, das Datum der ausführbaren Datei und das verwendete Arena Buch. Die angezeigten Eigenschaften können unter den Motoren Details verändert werden, siehe nächstes Kapitel.

Die 'Verfügbaren Motoren' sind diejenigen, die Sie installiert haben und evtl. später mal als aktive Motoren verwenden möchten.

Die 'Zuletzt benutzten Motoren' sind die, die Sie als letztes ausgewählt und gestartet haben. Die allerletzte steht oben. Wenn Sie in dieser Liste einen Eintrag nicht mehr benötigen, wählen Sie ihn aus und drücken die "Entf" (Entfernen) Taste.

Registerkarte "Details"

Hier können Sie Motoren installieren oder ändern. Links sehen Sie eine Liste aller installierter Motoren. Davon ist einer ausgewählt, dessen Daten Sie im rechten Bereich sehen.

Einen neuen Motor erstellen Sie, indem Sie auf 'Neu' klicken. Es wird ein neuer Eintrag erstellt. Dann klicken Sie auf das 'Öffnen'-Symbol { [image] } und geben dann an, welche Art von Motor Sie möchten, Winboard oder UCI. Jetzt erscheint der bekannte Windows-Dateiauswahl-Dialog und Sie müssen angeben, wo sich Ihr schöner Winboard oder UCI Motor befindet (bitte die exe-Datei auswählen). Arena macht jetzt ein paar Analysen, schaut z.B. nach einer init-Datei nach Fritz- Standard und versucht daraus Informationen zu gewinnen. In vielen Fällen ist Ihr Motor nun bereits fertig installiert. Evtl. können Sie noch den Namen ändern oder den Autor, und das war's. Machen Sie den gerade installierten Motor zum aktiven und testen Sie ihn. Falls Probleme auftreten, müssen Sie wohl oder übel nach einer Textdatei suchen, die Aufschluss über die Konfigurationsparameter des Motors gibt. Sie finden diese im Programmverzeichnis des Motors. Sie heißt 'Liesmich.txt', 'Readme.txt', 'Supermotor.txt' oder ähnliches.

Häufig benötigt man den Kommandozeilenparameter '-xboard' für Winboard-Motoren.

UCI-Motoren sollten immer als 'UCI' installiert werden, nicht als 'Automatische Erkennung', da manche auch Winboard unterstützen, was natürlich zu Problemen führen kann.

Falls Ihnen das zu umständlich ist oder Sie bereits über eine erkleckliche Motoren-Sammlung verfügen, empfehle ich Ihnen den Installations-Assistenten , den Sie von dieser [image] Registerkarte aufrufen. Er versucht selbständig, Motoren zu erkennen und zu konfigurieren. Er durchsucht ein Verzeichnis mit allen Unterverzeichnissen nach exe-Dateien und listet sie dann auf. Sie müssen dann nur noch Häkchen setzen bei den Motoren, die Sie dann auch wirklich installieren wollen. Es sollten natürlich nur Schachmotoren hier angewählt werden, da das Starten von unbekannten exe-Dateien unvorhergesehene Folgen haben kann.

Für die Konfiguration eines Motors haben Sie die Möglichkeit, unter den folgenden kleinen Unterregisterkarten Einstellungen vorzunehmen:

Unterregisterkarte "Allgemein"

Name: Der Name des Motors unter Arena

Autor: Der Programmierer des Motors

Befehlszeile: Die ausführbare Datei (. exe) des Motors inklusive komplettem Pfad.

Kommandozeilen Parameter: Optionen, die der Motor benötigt. Sehr vom verwendeten Motor abhängig. Manchmal gar nicht verwendet, machmal eine lange Kette von Parametern.

Automatisch auswerten: Liest in der Datei "engines.ini" nach, welche Daten zu diesem Motor vorhanden sind und setzt Autor, Kommandozeilen Optionen, Land und Typ ein. Die Datei "engines.ini" wird vom Arena-Team regelmäßig aktualisiert.

Land: Land, aus dem der Programmierer kommt.

Typ: Verwendetes Protokoll, Winboard oder UCI.

Logodatei: Datei mit einem Logo des Motors inklusive komplettem Pfad. Benötigen Sie nur, wenn das Logo nicht automatisch angezeigt wird. Das gültige Logo sehen Sie ja rechts oben.

Unterregisterkarte "Spezial"

Inidatei: Konfigurationsdatei des Motors. Findet nur bei Winboard Verwendung. Die Datei, die Sie hier angeben, wird bei der Motoren-Konfiguration (Rechtsklick mit der Maus auf die Analysezeilen, dann "Konfiguriere [Motor]" wählen) angezeigt.

Startbefehle: Die Befehle, die nach dem Start des Motors an ihn gesendet werden, um z.B. einige Einstellungen zu setzen.

Stärke in %: Hier können Sie den Motor abschwächen. Er verwendet dann nur noch den angegebenen Prozentsatz der eigentlich zur Verfügung stehenden Rechenzeit. Genauere Beschreibung.

Werte absolut (immer aus der Sicht von Weiß): Die Werte werden vom Motor immer aus der Sicht von Weiß übermittelt, d.h. eine gute Stellung für Weiß hat einen positiven Wert, eine schlechte einen negativen Wert. Wenn nicht angekreuzt, werden die Werte immer aus Sicht des Motors selbst übermittelt, d.h. eine für sich gute Stellung sieht der Motor immer als einen hohen positiven Wert, eine schlechte Stellung als einen stark negativen Wert.

Internetseite des Autors: Information für Sie.

Datei Readme.txt anzeigen: Zeigt diese Datei an, falls sie sich im Verzeichnis des Motors befindet.

Unterregisterkarte "Bücher"

Arena Motorenbuch: Hier können Sie angeben, welches Buch im Arena-Format (abk) der Motor verwenden soll.

Verwende Arena Hauptbuch mit diesem Motor: Wenn gesetzt, wird das gerade aktive Hauptbuch vom Motor verwendet.

Unterregisterkarte "Information"

Unterstützte Winboard Möglichkeiten: Hier können Sie die Optionen, die der Motor unterstützt, ankreuzen. Die Informationen werden in der Liste, siehe voriges Kapitel, angezeigt.

Automatisch auswerten: Liest in der Datei "engines.ini" nach, welche Daten zu diesem Motor vorhanden sind und setzt die "Unterstützten Winboard Möglichkeiten" ein. Die Datei "engines.ini" wird von der Arena-Mannschaft regelmäßig aktualisiert.

Wertungszahl: Jeder Motor kann eine von Ihnen gesetzte Wertungszahl erhalten. Die Wertungszahl wird angezeigt in der Arena Titelzeile und in den Zeilen über und unter dem Schachbrett (wenn ausgewählt), hat aber sonst keine Funktion.

Kommentar: Hier können Sie sich zu Informationszwecken Daten zu dem Motor notieren.

Registerkarte "Optionen"

Motoren starten mit Fehlersuche-Fenster bedeutet, dass immer dann wenn ein Motor gestartet wird, das Fehlersuch-Fenster aufgeht. Hilfreich beim Testen, sonst eher hinderlich.

Wenn Motornamen ersetzen Spielernamen gesetzt ist, kann der am Zug befindliche Motor den Spielernamen ersetzen durch seinen eigenen Namen.

Verwende internen Namen bewirkt, daß Arena den Namen, den der Motor selbst meldet, verwendet. Ist diese Option nicht aktiviert, verwendet Arena den von Ihnen vergebenen Namen.

Zeitüberschreitung beachten, heißt, dass die Partie entschieden ist, sobald Sie oder ein Motor oder Sie selbst die Zeit überschritten haben. Während eines Turniers gilt nicht diese, sondern die entsprechende Einstellung im Turnierdialog.

Die Spielstufe 'Unendlich' muss für Winboard-Motoren emuliert werden. Es werden die Motoren dann mit den hier angegebenen Einstellungen im Fischer-Modus ('level 0 9999 9999') gefahren.

Erweiterter 'Level' Befehl für WB Motoren bedeutet, daß Winboard Motoren auch mehrere Turnierstufen mit unterschiedlichen Zeitkontrollen verwenden können. Kein Winboard-Standard, wird aber von einigen Motoren unterstützt.

'UCI Filter' bewirkt, daß unwichtige Informationen, die die Motoren während der ersten 5 Sekunden senden, von Arena ignoriert werden. Wichtige Informationen wie Hauptvarianten oder der beste Zug werden natürlich immer durchgelassen. Während der ersten Sekunden senden Motoren oft sehr viele Informationen an Arena, dadurch können sie oft sehr langsam werden. Dies wirkt sich natürlich bei kurzen Zeitkontrollen besonders deutlich aus. Sie können 'UCI Filter' auf den Turniermodus beschränken, wenn Sie diese Option auswählen.

Motoren können Sie mit normaler oder niedriger Windows-Priorität starten. Bei niedriger Priorität ist die Oberfläche und Windows insgesamt besser zu bedienen, wenn die Motoren rechnen. Empfehlenswert ist dieser Modus auch für Wettkämpfe mit Ponder eingeschaltet. Windows kann die Rechenzeit dann gleichmäßiger verteilen.

'Hymnen beim Laden spielen' bedeutet, dass eine wav, mid oder midi Datei mit gleichem Namen wie der Motor bei dessen Start abgespielt wird.

'Hymnen beim Partiestart spielen' gilt analog für jeden (!) Start einer neuen Partie.

Registerkarte "UCI"

Hier können Sie gemeinsame Parameter für alle UCI-Motoren setzen.

Sie können hier eine einheitliche Größe für Hashtabellen und Endspieldatenbank Cache und einen gemeinsamen Pfad für die Endspieldatenbanken angeben. Dies erspart ihnen Arbeit, da Sie das dann nicht für jeden Motor einzeln eingeben müssen. Auch ist es empfehlenswert hier 'Motoren benutzen eigenes Buch' (UCI Parameter 'Own Book') anzuwählen.

Falls Sie hier das entsprechende Kontrollfeld nicht mit einem Häkchen versehen, werden die Werte verwendet, die Sie für jeden Motor individuell einstellen mittels: Rechter Mausklick auf die Analysezeilen des Motors (der dafür geladen sein muss), Motor konfigurieren oder Strg+1 oder Strg+2 für den ersten oder zweiten Motor.

'Aufgeben' solten Sie anklicken, wenn Arena anhand der übermittelten Werte für einen Schachmotor aufgeben soll. UCI-Motoren können ja nicht selbständig aufgeben. Dies geschieht dann, wenn die Bewertung unterhalb des angegebenen Wertes sinkt. Dieses muß jedoch für eine gewisse Anzahl von Zügen der Fall sein. Der Wert für "Aufgabe ab ... hundertstel Bauern" sollte selbstverständlich negativ sein, da nur bei schlechten Werten aufgegeben werden soll.

small arrow Einen Motor konfigurieren .


Arena - Hilfe -Motoren - Installations-Assistent

Installations-Assistent für Schachmotoren

Dieser Assistent unterstützt Sie beim Installieren von Winboard- und UCI-Motoren. Sie können Ihn aus der Motorenverwaltung unter der [image] Registerkarte "Details" starten.

Als erstes wählen Sie bitte ein Verzeichnis aus, unter dem die Winboard- und UCI-Motoren gesucht werden sollen. Dieses Verzeichnis wird dann komplett mit allen Unterverzeichnissen durchsucht.

Alle gefundenen Motoren werden ihnen angezeigt. Sie können jetzt alle zu installierenden Motoren mit einem Häkchen versehen.

Falls Motoren schon in Arena installiert sind, meldet Ihnen das folgende Fenster dies.

Dann können Sie auswählen, mit welchem Protokoll die Motoren laufen. Die intelligente Methode benutzt die Datei 'engines.ini', um den Typ des Motors zu bestimmen. Dies ist empfehlenswert.

Bei einem Klick auf "Fertigstellen", werden die Motoren nun installiert.


Arena - Hilfe -Motoren - Stärke des Motors begrenzen

Stärke des Motors begrenzen

Für UCI-2 Motoren:

Unter Spielstufen / Begrenze die Spielstärke auf ELO... können Sie die Stärke von Motoren begrenzen. Diese Funktion ist nur für UCI-2 Motoren verfügbar.

Hinweis: Die Spielstärkebegrenzung wird vom Motor selbst durchgeführt, Arena übermittelt hier nur Ihre Einstellungen.

Eine weitere Möglichkeit, Motoren schwächer zu machen (für alle Motortypen):

Unter der Motoren Verwaltung haben Sie die Möglichkeit, Motoren, die zu stark für Ihr Spiel sind, abzuschwächen. Also: Sie gehen unter Motoren / Verwalten / Details zu dem Motor, den Sie schwächen möchten. Unter der Karteikarte 'Spezial' finden Sie den Punkt 'Stärke'. Dort können Sie den Motor auf bis zu 1 % abschwächen.

Wie funktioniert's?

Dem Motor wird ein entsprechend geringer Zeitanteil zugeteilt. Er 'denkt' also, er würde unter einer geringeren Spielstufe spielen, mit weniger Zeit zur Verfügung. Bei Stärke 50% gaukelt Arena ihm vor, er müsse mit der halben Zeit als die eingestellte Spielstufe auskommen.

Beispiel:

Sie stellen die Spielstufe '40 Züge in einer Stunde' ein. Bei einer Stärke von 50% spielt er dann so wie bei '40 Züge in 30 Minuten'.

Motorenverwaltung


Arena - Hilfe -Motoren - Rechnen auf Gegnerzeit

Rechnen auf Gegnerzeit

Zu dieser Funktion gelangen Sie über Motoren / Rechnen auf Gegnerzeit.

Schaltet das Rechnen während der Gegner am Zug ist für alle Motoren ein oder aus. Sie sehen an dem Häkchen im Menüpunkt, ob diese Funktion eingeschaltet ist.

Auch bekannt ist diese Funktion unter dem Namen "Pondern" oder "Permanent Brain".

Falls Sie gezielt nur einen Motor pondern lassen möchten ,den 2. aber nicht:

Im Hauptmenü unter Motoren / Motor 1 / Rechnen auf Gegnerzeit oder durch Klick mit der rechten Maustaste auf die Analysezeilen des
1. ,oberen Motors, dann im Kontextmenü Rechnen auf Gegnerzeit wählen.

Schaltet das Pondern (Rechnen während der Gegner am Zug ist) für Motor 1 ein.

Analog gilt für Motor 2:

Erreichbar im Hauptmenü unter Motoren / Motor 2 / Rechnen auf Gegnerzeit oder durch Klick mit der rechten Maustaste auf die Analysezeilen des
2., unteren Motors, dann im Kontextmenü Rechnen auf Gegnerzeit wählen.


Arena - Hilfe -Motoren - Manuell starten

Motor manuell starten

Erreichbar im Hauptmenü unter Motoren / Motor1(oder 2 oder 3) / Starten oder durch Klick mit der rechten Maustaste auf die Analysezeilen des 1., oberen Motors, dann im Kontextmenü Motor (neu)starten wählen. Tastenkombination: Umsch+F11.

Startet den Motor 1 manuell. Normalerweise ist das nicht notwendig, da die Motoren immer automatisch starten, wenn nötig.

Sinnvoll ist diese Funktion allerdings, wenn Sie Änderungen in der Konfigurationsdatei von Winboard Motoren gemacht haben. Diese Änderungen treten fast immer nur nach einem Neustart des Motors in Kraft.


Arena - Hilfe -Motoren - Fehlersuche - Fenster

Fehlersuche - Fenster

Das Fenster 'Motoren Fehlersuche' erreichen Sie im Menü unter Motoren / Fehlersuche - Fenster oder das Tastenküzel F4.

Probleme mit einem Schachmotor? Ein Motor will nicht richtig laufen? Dieses Fenster kann Ihnen helfen, Fehler, die z.B. bei der Konfiguration von Motoren auftreten, zu finden. Auch sehen Sie hier am besten, ob ein Motor überhaupt irgendwelche Lebenszeichen von sich gibt. Das Fenster ist natürlich auch eine unschätzbare Hilfe für die Programmierer der Motoren!

Im diesem Fenster werden alle Ein- und Ausgaben der Motoren angezeigt. Des weiteren können Sie direkt Eingaben an den ersten Motor senden.

Ein/Ausgabebereich:

Die erste Zahl in jeder Zeile ist die Zeit in Millisekunden seit dem Start von Arena. In den nächsten Spalten einer jeden Zeile wird angezeigt, von wem die Information kommt:

  • <1: = Ausgabe des ersten Motors an Arena
  • <2: = Ausgabe des zweiten Motors an Arena
  • >1: = Arena an ersten Motor
  • >2: = Arena an zweiten Motor
  • ** = Kommentare
  • 1* = Kommentare zum 1.Motor
  • 2* = Kommentare zum 2.Motor

Eingabezeile und Knöpfe:

Sie können mit den Knöpfen unter dem Ein/Ausgabebereich direkt Kommandos von Arena nach den Motoren schicken.

Los! : Schickt den Befehl in der Eingabezeile zum Motor. ?: Schickt den Befehl '?' zum Motor. go: Schickt den Befehl 'go' zum Motor. .: Schickt den Befehl ' .' zum Motor. Clear löscht den Ein/Ausgabebereich. - >Zwischenablage kopiert den Inhalt des Ein/Ausgabebereich in die Zwischenablage. Hilfe führt Sie zu dieser Hilfeseite.

Kontrollfelder (Checkboxen):

2: Bestimmt, ob die Befehle nach Motor 2 geschickt werden. Wenn gesetzt, dann an Motor 2, sonst an Motor 1.

Arena.debug: Bestimmt, ob die Befehle an die Motoren und die Ausgaben der Motoren auch in der Datei Arena.debug gespeichert werden.

Anzeigen: Wenn nicht markiert, dann erfolgen keine Anzeigen im Ein/Ausgabebereich

Nur Informationen mit Hauptvariante: Es werden im UCI-Modus nur Informationen, die Hauptvarianten (PVs) enthalten, angezeigt, keine anderen Informationen. Gilt nur für UCI-Motoren. Die vielen Informationen, die UCI-Motoren häufig liefern, können so eingeschränkt werden.

Keine Informationen: Es werden im UCI-Modus keine Informationen angezeigt. Gilt nur für UCI-Motoren. Die vielen Informationen von UCI-Motoren werden hiermit komplett unterbunden.


Arena - Hilfe -Analyse

Eine bestehende Partie analysieren

Sie haben 2 Möglichkeiten:

  • Einzelne Züge per Hand analysieren
  • Komplette Partie/ EPD/ PGN Datei automatisch analysieren : Wählen Sie unter 'Partie' den Menüpunkt Analysieren.

1. Einzelne Züge per Hand analysieren:

1) Navigieren Sie mit den Pfeiltasten [image] unter dem Schachbrett zum gewünschten Zug
3) Dann starten Sie die Computer-Berechnung, indem Sie den Analyse-Knopf anklicken. Sie können dann weiterhin in der Partie mit den Pfeiltasten navigieren. Verwenden Sie zur Analyse nicht den Chip-Knopf. Falls Sie sich nicht am Ende der Partie befinden, wird sonst der aktuelle Zug und alle folgenden Züge gelöscht! Der Chip-Knopf führt dazu, dass der Motor rechnet und dann der beste Zug ausgeführt wird.
4) Sie stoppen die Berechnung mit einem erneutem Klick auf den Analyse-Knopf.

2. Dialogbox Automatische Partie Analyse:

Automatische Analyse


Arena - Hilfe -Analyse - Automatische Analyse

Automatische Analyse von Partien, EPD und PGN Dateien

Sie gelangen über Motoren / Automatische Analyse zu diesem Dialog.

Hier können Sie automatisiert Züge einer Partie, mehrerer Partien oder eines Bereiches von EPD- Stellungen analysieren.

Registerkarte "Quelle"

Als Quelle können Sie die aktuelle Partie, die bereits geladenen Stellungen einer EPD Datei oder eine Liste von EPD und PGN Dateien angeben.

Sie können unter Farben bestimmen, ob Sie nur die Züge für weiß oder für schwarz analysieren lassen möchten.

Die Analyse Richtung, vorwärts oder rückwärts, können Sie bestimmen. Es hat bei der Analyse von Partien manchmal Vorteile, rückwärts analysieren zu lassen, da die Motoren die Berechnungen der späteren Züge in die aktuellen Rechnungen einfliessen lassen können.

Sie können Sie einen Bereich von Stellungen in einer EPD Datei wählen, einen Bereich von Zügen in Partien und einen Bereich von Partien in PGN Dateien.

Wenn Sie z.B. die aktuelle Partie analysieren wollen, können Sie einen Bereich vorgeben, der analysiert wird, so können Sie z.B. uninteressante Standard-Eröffnungszüge weglassen.

Registerkarte "Motoren"

Sie können die aktuell geladenen Motoren zur Analyse verwenden, ebenso eine Liste der Motoren.

Die Spielstufe wird immer in 'Sekunden pro Zug' gemessen.

Registerkarte "Ausgabe"

In der Protokolldatei werden die Hauptvarianten, Lösungszüge und einige andere Informationen, z.B. über Rechenzeiten, detailliert gespeichert.

Arena berechnet eine Gesamt- Lösungszeit (Wertungszeit) für alle Analysen. Wenn bei einer EPD Datei ein Zug gefunden wird, d.h. mit dem in der Datei angegebenen übereinstimmt, dann wird die Zeit der ersten Lösung gespeichert. Wenn der Zug nicht gefunden wird, wird die Maximalzeit, d.h. die Zeit der Spielstufe addiert. Das Ergebnis ist die Wertungszeit. Sie wird in die Protokolldatei gespeichert.

Die Reportdatei enthält eine Übersicht über Züge und Lösungszeiten.

Analysen vorzeitig abbrechen ist ein hilfreiches Feature wenn Sie Testbatterien schnell ablaufen lassen wollen. Es bricht die Analysen unter den folgenden Bedingungen ab: Soviel Halbzüge weiter vertiefen bedeutet, daß der Lösungszug für die angegebene Anzahl Halbzüge gehalten worden sein muß. Ausserdem muß die Minimale Analysetiefe erreicht sein. In der Regel ist es dann sehr wahrscheinlich, daß ein einmal gefundener Zug auch gehalten wird, wenn z.B. Minimale Analysetiefe auf >= 9 und Halbzüge weiter vertiefen auf ca. 2 gestellt wird.

Der Knopf 'Verkleinern in Tray' bewirkt, dass Arena sich in den Info- (Tray) Bereich neben der Uhr zurückzieht.


Arena - Hilfe -Analyse - Variantenbrett

Variantenbrett

Das Variantenbrett starten Sie, indem Sie mit der rechten Maustaste auf den Analyse Knopf in der Navigationsleiste drücken, Strg-F12 drücken oder im Optionen Menü 'Variantenbrett' anwählen.

Hiermit können Sie die Aktuell analysierten Varianten auf einem gesondertem Brett durchspielen und analysieren.

Mit den Navigationsknöpfen können Sie in der aktuellen Variante navigieren. Der aktuelle Zug und der Materialwert relativ zum Anfang der Variante wir in dem kleinen Fenster links daneben angezeigt.

Mit den Knöpfen ÇE1 oder ÇE2 können Sie die neuen Analysen von Motor 1 oder 2 in das Variantenbrett laden.

Wenn ein Winboard Motor oder ein UCI Motor ohne Multivariantenunterstützung (keine MultiPV Einstellmöglichkeit in der Motoren Konfiguration) geladen ist, wird in der Liste unter dem Brett nur eine Variante angezeigt.

Wenn ein UCI Motor mit Multivariantenunterstützung geladen ist, werden so viele Varianten angezeigt wie die aktuelle Einstellung des MultiPV Parameters des Motors.


Arena - Hilfe -Turnier

Motoren Turniere

Unter Motoren / Turnier (oder Taste F9) können Sie ein Turnier mit beliebig vielen Motoren durchführen.

Das Turnier kann als eine ".at" (Arena Turnier)Datei gespeichert werden und später bearbeitet oder fortgeführt werden. Dies gibt Ihnen die Möglichkeit, Ihr bevorzugtes Turnier-Setup, z.B. ein "Best of Winboard" Turnier, zu speichern und auf einfache Weise so einzustellen, daß es ihren Wünschen entspricht.

Registerkarte Einstellungen:

Sie können dem Turnier einen Namen geben und die Motoren können durch Doppelklick ausgewählt oder wieder zurück zu den verfügbaren Motoren geschoben werden.

Wenn Sie nur zwei Motoren auswählen, ist es egal, ob Sie als Turniertyp Rundenturnier oder Spießrutenlauf wählen.

Bei mehr als zwei Motoren ergeben sich aber unterschiedliche Resultate. Bei einem Rundenturnier spielt jeder Motor gegen alle andere Motoren und damit werden viel mehr Partien gespielt als beim Spießrutenlauf, bei dem der erste Motor gegen alle anderen Motoren die angegebene Anzahl Runden spielt.

Rutschsystem ist eine alternative und empfohlene Methode, die Paarungen zu berechnen.

Die Anzahl der Runden ist die Anzahl der Partien, die pro Paarung gespielt werden. Nach jeder Partie werden die Farben gewechselt. Um für den ersten Motor keinen Vorteil zuzulassen, sollte eine gerade Anzahl von Runden gewählt werden, da ja weiß stets einen kleinen Anzugsvorteil hat.

Bei drei Motoren (z.B. Chispa, Crafty und Ruffian) ergeben sich demnach folgende Paarungen:

  • Chispa ------ Crafty
  • Ruffian ------ Chispa
  • Crafty ------ Ruffian

Jede Runde besteht hier also aus 3 Partien. Wenn Sie zwei Runden angeben, werden nacheinander folgende Partien gespielt:

1.Runde:

  • Chispa - Crafty
  • Ruffian - Chispa
  • Crafty - Ruffian

2.Runde:

  • Crafty - Chispa
  • Chispa - Ruffian
  • Ruffian - Crafty

Sie sehen, dass in der 2. Runde die Farben gewechselt werden. Das gleiche gilt dann für alle geraden Runden, wenn Sie mehr Runden gewählt haben.

"Spielstufe" wählt die Spielstufe für das Turnier. Empfehlenswert ist hier natürlich, eine Blitz- oder Turnier Spielstufe zu wählen. Feste Zeit-, Knoten oder Suchtiefenvorgaben sind fast immer unsinnig.

"Resultate löschen " bewirkt, dass ein bereits (teilweise) gespieltes Turnier auf Anfang gesetzt wird. Aber Vorsicht: Alle Resultate gehen verloren!

Wenn Sie dem Turnier einen Namen geben, wird dieser für die Speicherung der Partien verwendet, falls nicht, wird die Einstellung unter Optionen / Benutzerdaten / Event verwendet.

Wenn Sie den Knopf "Neu" wählen, wird ein neues Turnier erstellt. Es werden dann die Standard-Dateinamen für die Speicherung der verschiedenen Dateien (s.u.) gleich richtig gesetzt.

Dasselbe gilt für den "Duplizieren" Knopf, nur werden hier im Gegensatz zum "Neu" Knopf die Teilnehmer nicht gelöscht.

Der Knopf "Motor ersetzen mit neuer Version" dient dazu, einen Motor zu ersetzen mit einer neueren Version. Der neue Motor (z.B. Delfi 4.2 statt Delfi 4.1) übernimmt die Resultate des alten. So können Sie Motoren Updates in ein laufendes Turnier einfließen lassen.

Der Knopf "Spieler hinzufügen" fügt einen beliebigen (menschlichen) Spieler zum Turnier hinzu. Wenn Sie also selbst mitspielen wollen, nur zu... Sie werden dann aufgefordert, wenn Sie eine Partie spielen müssen.

Der Knopf "Brettcomputer hinzufügen" fügt einen Brettcomputer-Spieler zum Turnier hinzu. Den Brettcomputer bedienen müssen Sie allerdings immer noch selbst!

Mit dem Knopf "Resultate anzeigen" können Sie die Resultatdateien und -tabellen neu generieren, ohne das Turnier dazu neu starten zu müssen. Arena springt in das Hauptfenster zurück. Dort können Sie dann z.B. die Turniertabelle anschauen. Für die Turniertabelle und die Turnier(einzel)ergebnisse gibt es ja einzelne [image] Registerkarten unter der Zugliste. Auch die HTML-Daten werden neu generiert und Sie können Sie sich ansehen, z.B. im Internet Explorer, Netscape Navigator, Firefox oder Opera Browser.

Registerkarte Optionen:

Ganz oben können Sie die Schachvariante, normales Schach, Schach 960 oder Shuffle Chess, auswählen.

Die Anfangsstellung, mit der jede Partie anfängt, können Sie eingeben. "Standard" bedeutet natürlich der gewohnte Schach-Anfangsstellung. "Aus PGN/EPD Datei laden, sequentiell" bedeutet, dass Arena die Anfangsstellungen aus einer PGN oder EPD Datei lädt. Wenn Sie also ein Turnier mit definierten Anfangsstellungen durchführen wollen, können Sie das so machen. Wenn Sie den Zufall entscheiden lassen wollen, wählen Sie den 3. Punkt, "Aus PGN/EPD Datei laden, zufällig". Dann wählt Arena zufällig eine Anfangsstellung aus, mit der die Partie beginnt und ab der dann die Motoren weiter rechnen müssen. In der Zeile darunter, mit "Datei" beschrieben, können Sie diese Datei angeben. Häufig werden z.B. Turnier mit den bekannten Nunn- Anfangsstellungen durchgeführt.

"Stellung mit vertauschten Farben wiederholen" bedeutet, dass in der nächsten Runde dieselbe Stellung wie in der aktuellen Runde auf das Brett kommt, falls die nächste Rundenzahl gerade ist. Wenn Sie also ein Turnier mit definierten Anfangsstellungen durchführen wollen und die gleiche Anfangsstellung einmal mit schwarz, einmal mit weiß durchkämpfen lassen wollen, dann sollten Sie diesen Punkt anwählen. Die Rundenzahl muss dann bei dieser Option dann natürlich größer als 1 eingestellt sein.

Wenn Sie "Testmodus" gewählt haben, werden keine Partien gespielt und keine Motoren geladen. Das Partieergebnis einer jeden Turnierpartie wird zufällig gesetzt. Mit dieser Funktion können Sie den Ablauf des Turniers simulieren, z.B. können Sie überprüfen, ob die Tabellen so aussehen, wie Sie sich das gewünscht haben etc.

Falls Sie 'Partie abschätzen' angewählt haben, wird bei dem zugehörigen (negativen) Wert in hundertstel Bauerneinheiten die Partie beendet. Wichtig: Dies funktioniert nur dann, wenn beide Motoren Werte unterhalb dieser Schwelle zurückgeben. Wenn z.B. ein Motor falsche Werte liefert, funktioniert das nicht. Der Wert muss weiterhin 6 Halbzüge lang unterschritten worden sein.

Der Wert sollte selbstverständlich genügend weit negativ sein, z.B. -500. Dann wird die Partie für die zurückliegende Seite aufgegeben, wenn die Werte der Motoren für 6 Halbzüge lang unter 5 Bauerneinheiten liegt. Beachten Sie bitte, dass die Lernfunktion mancher Motoren dadurch außer Kraft gesetzt wird und sie dadurch möglicherweise schwächer spielen.

Falls die maximale Partielänge überschritten worden ist, wird die Partie remis gegeben. Dies stellen Sie mittels der Option "Als Remis werten ab XXX Zügen" ein.

Für Turniere können Sie gesondert einstellen, ob die Motoren pondern sollen. Dies beeinflusst die generelle Einstellung, z.B. unter Motoren/Pondern nicht. Ponder ist natürlich nur sinnvoll, falls Sie der glückliche Besitzer eines Rechners mit zwei Prozessoren sind. Wenn ihr Rechner nur einen Prozessor besitzt, ist diese Option nicht sinnvoll, da die Rechenzeit manchmal nicht korrekt (d.h. 50%-50%) zwischen den Motoren aufgeteilt wird. Dies kann leider selbst unter Windows NT oder 2000 vorkommen.

Die Einstellung für das (Nicht-) Beachten von Zeitüberschreitungen im Turniermodus kann hier gesetzt werden. Beachten von Zeitüberschreitungen sollte i.d.R. eingeschaltet sein, da es auch bei den am besten programmierten Motoren manchmal Aussetzer geben kann und das Turnier dann nicht mehr fortgeführt werden würde.

Registerkarte Speichern:

Generell wird empfohlen, alle Turnierdateien im Verzeichnis \Tournaments unterhalb ihres Arena- Verzeichnisses abzulegen.

Sie können jede Partie im PGN Format speichern, wenn Sie das hier angeben. Dabei werden alle Daten gespeichert, die Sie unter Optionen / Oberfläche / PGN angegeben haben, also auch z.B. Bewertung, Zeitverbrauch je Zug und Hauptvariante.

Die Protokolldatei speichert alle Resultate der Partien und etwas Statistik.

Die Suchtiefenstatistik in der Protokolldatei gilt nur für die Eröffnung und das Mittelspiel, nicht für das Endspiel. Eine Stellung wird als Endspielstellung gewertet, wenn höchstens 6 Offiziere (weiße und schwarze zusammengerechnet) auf dem Brett stehen, wobei die Dame doppelt zählt.

K Die Turniertabelle existiert in 2 verschiedenen Formen: Einer einfachen für die Darstellung im entsprechenden Arena Fenster (alternativ zur Zugliste) während eines Turniers und einer HTML Form für die Darstellung mit einem Webbrowser (z.B. im Internet Explorer, Netscape Navigator oder Opera Browser) oder zum Posten in HTML-Form in Newsgroups. Die Turniertabelle im Textmodus (empfohlene Dateierweiterung: .txt)wird auch im Arena Hauptfenster angezeigt.

Für die HTML Tabelle existieren einige Optionen:

  • "Land einfügen": Dies zeigt das Land, aus dem der Teilnehmer kommt, in der Tabelle an.
  • "Flaggen verwenden": Es werden die Flaggen statt der Ländernamen gezeigt.
  • "Flaggen von Webseite": Lädt die Flaggendateien nicht vom lokalen Rechner, sondern von der Arena Webseite. Dies ist wichtig, wenn Sie Turniere im Internet veröffentlichen.
  • "Englische Sprache verwenden": Zeigt Texte in der Tabelle nicht in deutsch, sondern in englisch. Sinnvoll, wenn man für ein internationales Publikum Ergebnisse veröffentlichen möchte.
  • "Kurze Einzelergebnisse" zeigt nicht den Verlauf der Ergebnisse an, z. B.: 100=10, sondern 2-3-1. Dies bedeutet, 2 Siege, 3 Verlustpartien und ein Remis. Platzsparend.
  • "Nur Punkte" bedeutet, das das Format auf die Darstellung "Erzielte Punkte/Gesamtpunkte" hier also z.B. "2,5/6" geändert wird.
  • "Zeige PGN Dateiname": Schreibt den Namen der Ausgabe Datei mit den Partien des Turniers in die HTML-Datei.
  • "PGN-URL": Hier können Sie die Internet Adresse der PGN Datei angeben, wenn Sie z.B. das Turnier und die PGN Datei veröffentlichen möchten.
  • "Autor einfügen": Fügt Ihren Namen in die HTML-Datei ein. Der Name wird aus den Benutzerdaten entnommen.
  • "Axon Benchmark zeigen": Zeigt den Benchmark - Wert des Axon Geschwindigkeits Tests an.
  • "Webseite des Autors eingeben": Fügt Ihre Webseite in die HTML-Datei ein. Der Name wird aus den Benutzerdaten gelesen

K Die Spalte "S-B" entält die Sonneborn-Berger Feinwertung.

Der Knopf "Standard Dateinamen setzen" setzt folgende Dateinamen auf Standardwerte. Dies sind:

  • (Arena Verzeichnis)\Tournaments\(Turniername).pgn für die Partien im PGN Format
  • (Arena Verzeichnis)\Tournaments\(Turniername).log für die Protokolldatei
  • (Arena Verzeichnis)\Tournaments\(Turniername).txt für die Turniertabelle im Textformat
  • (Arena Verzeichnis)\Tournaments\ für die Turniertabelle im HTML Format
  • (Arena Verzeichnis)\Tournaments\(Turniername).res für die Einzelergebnisse der Motoren im Textformat, so wie sie auch unter dem Reiter “Ergebnisse” angezeigt werden.

Diese Namen werden standardmäßig eingesetzt bei Einstellungen/Neu oder Einstellungen/Duplizieren.

Falls Sie die Partien im Arena- eigenen Format "FCH" speichern möchten, können Sie hier ein Verzeichnis eingeben und den Anfang der Dateinamen. Diese werden dann ergänzt mit der Nummer der Partie, also z.B. "Partie0009".

Registerkarte Paarungen:

Hier werden ihnen in der Liste alle Paarungen angezeigt. Die Anzahl der noch zu spielenden Partien wird oben angezeigt. Hinter den Paarungen wird der Verlauf der Ergebnisse dieser Paarung dokumentiert: 1 bedeutet Sieg des ersten Motors, 0 Sieg des zweiten, 1/2 ein Remis, ? steht für eine nicht beendete Partie. Nicht beendete Partien werden wiederholt.

Mit dem Knopf "Resultat bearbeiten" können Sie das Resultat einer Paarung ändern, weil z.B. eine Partie nicht richtig gestartet worden ist oder ein anderer Fehler aufgetreten ist. In einem solchen Fall merken Sie sich einfach die Rundennummer der Partie und setzen dann das Resultat an dieser Stelle auf "?" (ohne die Anführungszeichen).

Wenn Sie ein bereits (teilweise) gespieltes Turnier laden, bedenken Sie bitte, dass ohne Änderung der Einstellungen nur noch die ausstehenden Partien gespielt werden, also eventuell auch gar keine.

Registerkarte Starten/Beenden:

Wenn der Rechner heruntergefahren werden soll, nachdem das Turnier beendet wurde, können Sie "Rechner herunterfahren nach Ende des Turniers" anwählen.

Den Rechner können Sie auch nach einer bestimmten Anzahl von Partien herunterfahren lassen. Das ist hilfreich, wenn Sie ein Turnier in Teilstücken durchführen lassen wollen. Das Turnier wird dadurch natürlich evtl. nicht komplett bis zum Ende durchgeführt, aber Sie können das Turnier ja jederzeit neu aufnehmen und weiterführen.

Wenn Sie "Arena beenden nach Turnier" ausgewählt haben, wird Arena nach Ende des Turniers beendet.

"Arena Neustart nach so vielen Partien": hier können Sie einstellen, dass Arena sich nach dieser Anzahl von Partien beendet, neu startet und das Turnier fortsetzt. Dies kann helfen, Probleme bei langer Turnierlaufzeit zu verhindern.

"Arena Neustart zu dieser Stunde": hier können Sie einstellen, dass zu dieser Tageszeit Arena sich beendet und neu startet. Auch so können Sie die Langzeit-Stabilität von Turnieren verbessern. Falls zu der eingestellten Uhrzeit eine Partie läuft, wird solange gewartet, bis die Partie zu Ende ist und dann Arena neu gestartet.

Motoren werden vor jeder neuen Paarung neu gestartet, das lässt sich nicht beeinflussen. Wenn Sie möchten, dass die Motoren auch nach jeder Partie neu gestartet werden, können Sie das auch hier einstellen.

Registerkarte Fehler-Überwachung:

Diese Funktion ermöglicht ihnen, kritische Stellungen, in denen ein Motor einen Fehler gemacht hat, in einer EPD- Stellungsdatei zu sammeln. Diese Datei können Sie dann nachher auswerten und z.B. feststellen, ob sich eine neue Version dieses Motors verbessert hat und weniger Fehlzüge macht.

Tipp: Sehen Sie sich das Fenster Permanente Statistik an und stellen Sie sich vor, woran Sie einen Fehler erkennen. In der Regel sind das Bewertungssprünge.

Wenn Sie Aktiviere Motoren Fehler-Überwachung ausgewählt haben, wird die Funktion aktiviert.

Wenn die Bedingungen unter Trigger erfüllt sind, wird die Stellung in die EPD Datei gespeichert. Sie können angeben, wie stark die Verschlechterung der Stellung vom Motor aus bewertet werden soll und in welchem Zeitraum (innerhalb von X Zügen) diese Verschlechterung eingetreten sein kann. Wählen Sie z.B. hier einen hohen Wert für die Verschlechterung (z.B. 500), werden nur sehr grobe Fehler in die EPD Datei gespeichert, stärker als ein Turmverlust in diesem Beispiel. Ein kleiner Wert bedeutet, daß auch kleine Fehler gespeichert werden. Wenn Sie einen langen Zeitraum (z.B. 10 Züge) wählen, dann werden auch allmähliche Verschlechterungen der Stellung als Fehler des Motors gewertet und in die EPD Datei gespeichert. Die Einstellung Kein Fehler wenn schon X hundertstel Bauern zurück schließt Züge aus, die schon von einer schlechten Stellung aus die Bewertung noch weiter verschlechtert haben. Solche weiteren Verschlechterungen einer Stellung sind oft unvermeidlich. Wenn man einmal zurückliegt, verschlechtert sich oft zwangsläufig die eigene Stellung weiter.

Unter Speichere kritische Stellung(en) in EPD Datei... können Sie einstellen von welcher Stellung rückwärts gehend die Partiestellungen gespeichert werden. Es können also dabei mehrere Stellungen gespeichert werden, immer einen vollen Zug zurück, soweit Sie das wünschen. Meistens passierte der Fehler ja nicht in dem gerade gemachten Zug sondern meistens ein bis zwei Züge vorher. Es empfiehlt sich also, mindestens die Stellung einen Zug vorher mitzuspeichern.

Die kritischen Stellungen werden in einer Datei gespeichert, deren Name sich durch den Namen des Motors und einem angehängten "_white" bzw. "_black" bestimmt. Die Datei befindet sich im Verzeichnis "(Arena-Verzeichnis)\Tournaments\Epd\", z.B. also

C:\Arena\Tournaments\Epd\Ruffian 2.0_white.epd und C:\Arena\Tournaments\Epd\Ruffian 2.0_black.epd.


Arena - Hilfe -Turnier - Ablauf

Ablauf eines Turniers

Arena fängt mit der Abarbeitung des Turnier immer mit der Paarung mit der geringsten Partiezahl an. Falls in allen Paarungen gleich viele Partien gespielt wurden, wird mit der obersten Paarung in der Liste weitergemacht.

Also wird von jeder Paarung erst die erste Partie gespielt (Runde 1). Dann die 2. Partie von jeder Paarung (Runde 2), etc.. Eine Runde entspricht einer Spalte in der Paarungsliste.

Sie können problemlos die Anzahl der Runden erhöhen, wenn Sie
z.B. ein Turnier fortführen möchten.

Ebenso problemlos ist das nachträgliche Einfügen von zusätzlichen Motoren. Wenn im vorhandenen Turnier z.B. schon 2 Runden gespielt sind, wird dort weitergemacht, wo die wenigsten Partien sind, also mit den Partien des hinzugefügten Motors, denn der hat ja noch keine gespielt. Erst wenn alle Paarungen die gleiche Anzahl von Partien haben, wird mit der nächsten Runde gestartet, also hier z.B. mit der dritten.


Arena - Hilfe -Turnier - Infofenster

Das Turnier-Infofenster

Dieses Fenster zeigt ihnen während eines Turniers einige nützliche Informationen.

Es ist alternativ zum Zugliste-Fenster zu sehen, wenn Sie auf die "Turnier" [image] Registerkarte unterhalb der Zugliste klicken. Bei der Einstellung "Mix 2" können Sie die Züge der Partie und die Turnierinfos sehen.

Das Ergebnis der aktuellen Paarung sehen Sie in der Titelleiste das Arena- Hauptfensters. Aus Sicht des mit weiß spielenden Motors wird es in der Form: "Siege- Niederlagen- Remis" angezeigt.

Die Turnier- [image] Registerkarte

{ [image]}

Zeigt ihnen den Ablauf des Turniers: Motoren werden gestartet, Partien angefangen und beendet etc..

Die Schaltknöpfe auf der Turnier- [image] Registerkarte:

  • Abbrechen bricht nach einer Sicherheitsabfrage das Turnier ab.
  • Fehlersuche schaltet das Fehlersuch - Fenster ein.
  • Letzte Partie bricht das Turnier nach Ende der laufenden Partie ab.
  • Turnier... startet den Turnierdialog.
  • Letzte Runde bricht das Turnier nach Ende der laufenden Runde ab.

Registerkarte Tabelle

Zeigt eine einfache TurnierTabelle im Textformat mit den aktuellen Turnierergebnissen.

Registerkarte Resultate

Zeigt eine Liste mit den Einzelergebnissen der Motoren gegen andere Motoren.

Registerkarte HTML

Zeigt den HTML Code der aktuellen Turniertabelle

Die Schaltknöpfe auf der HTML- [image] Registerkarte:

  • Vorschau startet ihren Internet Browser mit der von Arena generierten Turniertabelle.
  • Zwischenablage kopiert die Turniertabelle im HTML Format in die Zwischenablage.
  • Zwischenablage nur Tab. kopiert die Turniertabelle im HTML Format in die Zwischenablage und lässt dabei die Informationen unterhalb der Tabelle weg.
  • Clip+Post! Kopiert die Turniertabelle in die Zwischenablage und startet dann ihren Internet Browser mit unserem Forum für Turnierergebnisse


Arena - Hilfe -Turnier - Rutschsystem

Rutschsystem

Das Rutschsystem hat 2 Vorteile:

1) Bei jeder neuen Paarung werden i.d.R. beide Motoren gewechselt.
2) Die Verteilung der Motoren auf die Anfangsfarben weiß und schwarz ist gleichmäßiger.

Bei der Durchführung des Systems gibt es zwei Varianten, wobei maßgebend ist, ob am Turnier eine gerade oder ungerade Anzahl von Spielern teilnimmt.

Gerade Spieleranzahl:

Nach Auslosung der ersten Runden setzen sich die Spieler an eine Tischreihe mit der nötigen Anzahl von Brettern, wobei sich die Figuren in weiß und schwarz abwechseln. Ist die erste Runde beendet, nehmen die Spieler jeweils im Uhrzeigersinn an der Tischreihe einen Stuhl weiter Platz. Hierbei ist jetzt wichtig, dass ein Spieler auf seinem Platz an einem Ende der Tischreihe sitzen bleibt und dass dieser nach jeder Spielrunde das Brett dreht, um somit abwechselnd mit weiß und schwarz zu spielen. Der von jenem Spieler rechts Sitzende muss dabei seinen Platz überspringen.

{bmc [image]}

Ungerade Spieleranzahl:

Die Regeln dieser Version ähneln der zuvor beschriebenen sehr, jedoch gibt es hier keinen Spieler, der auf seinen Platz bleibt.

Dafür muss jedoch jeweils ein Spieler an einem Ende der Tischreihe aussetzen, bevor dieser in der nächsten Runde auf der anderen Seite der Tischreihe wieder einsteigt.

{bmc [image]}


Arena - Hilfe -Turnier - Tipps

Tipps zur Durchführung eines Turniers

Bitte vergewissern Sie sich, ob die verwendeten Motoren korrekt konfiguriert sind. Z.B. sollte kein Motor zuviel Hash zugewiesen bekommen, da sonst Windows keinen schnellen Hauptspeicher (RAM) mehr zur Verfügung hat und auf sehr langsamen Festplattenspeicher ausweichen muss.

Damit das Turnier auch dann weitergeführt wird, wenn einer der Motoren mal nicht mehr weiterspielt, sollten Sie "Zeitüberschreitungen beachten" einschalten. Dann verliert der Motor irgendwann auf Zeit und zumindest wird die nächste Partie dann gestartet.

Wenn das Turnier aktiv ist, können Sie den Verlauf im Hauptfenster verfolgen, und zwar auf den [image] Registerkarten "Turnier" oder "Mix 2" und den weiteren [image] Registerkarten "Tabelle" und "Resultate".

Wenn Sie "Turnier wiederholen wenn beendet" anwählen, wird das Turnier nach Beendigung neu gestartet. Dies können Sie dazu verwenden, ein Turnier immer und immer wieder durchzuführen, um möglichst viele Partien zu bekommen. In dem Fall beendet sich das Turnier nicht selbst, Sie müssen es per Hand abbrechen.


Arena - Hilfe -Dateiformate

Dateiformate

Arena kann folgende Dateitypen laden und speichern:

  • EPD
  • PGN
  • FCH

Im PGN-Dateiformat können einzelne Partien ersetzt oder angehängt werden. Aufgrund der Größe von PGN-Dateien werden diese nicht komplett geschreiben.

Das FCH-Format ist spezifisch für Arena und sollte in Zukunft nicht mehr verwendet werden, da dort keine Varianten gespeichert werden können.


Arena - Hilfe -Dateiformate - PGN

Das PGN - Format

Das PGN-Format ist ein besonders im Internet weit verbreitetes Dateiformat für Schachpartien. Dabei können sich mehrere Partien in einer Datei befinden.

Beispiel:

[White 'Deep Blue']
[Black 'Kasparov, Garry']
[Result '1-0']

1.e4 c6 2.d4 d5 3.Nc3 dxe4 4.Nxe4 Nd7 5.Ng5 Ngf6
6.Bd3 e6 7.N1f3 h6 8.Nxe6 Qe7 9.O-O fxe6
10.Bg6+ Kd8 11.Bf4 b5 12.a4 Bb7 13.Re1 Nd5 14.Bg3 Kc8
15.axb5 cxb5 16.Qd3 Bc6 17.Bf5 exf5 18.Rxe7 Bxe7
19.c4 1-0

Arena kann Schach 960 (Fischer Random) Partien im PGN Format lesen.


Arena - Hilfe -Dateiformate - PGN - Datei laden

PGN - Datei laden

Unter PGN / Laden können Sie eine Datei im PGN-Format laden. Zuerst wählen Sie die Datei aus dem bekannten Dialog aus.

Dann wird ihnen eine Liste mit den Partien in dieser Datei angezeigt. Durch Doppelklick auf die entsprechende Zeile können Sie die Partei laden.

Durch einen Klick auf die Spaltenüberschrift sortieren Sie die Liste nach der entsprechenden Spalte.

Falls Sie einen Spieler suchen, können Sie seinen Namen in der Suchzeile eingeben. Die Liste springt dann auf die erste Partie dieses Spielers.

Falls Sie die Liste einmal geschlossen haben, können Sie sie wieder mit PGN / Liste anzeigen lassen.

Sie können auch mit den PGN+ und PGN-- -Schaltflächen in der Werkzeugleiste zwischen den Partien hin- und herspringen. Den gleichen Effekt erzielen Sie mit der Tastenkombination Umsch+Strg+F11 und Umsch+Strg+F12 oder mittels der Einträge im Hauptmenü unter 'PGN'.

Im Hauptmenü PGN/Zeige mit Editor können Sie sich die PGN Datei mittels des eingestellten Textverarbeitungsprogrammes anzeigen lassen.

Der 'Laden' Knopf lädt die angewählte Stellung.

Der 'Abbrechen' Knopf schliesst die Liste, nicht die Datei.

Der Knopf 'Schließen'' schließt die PGN Datei und macht verbrauchten Speicherplatz wieder frei.

Mit 'Lade andere Datei' können Sie eine andere PGN zur Ansicht auswählen.

Der Knopf 'EloStat' führt eine Berechnung der ELO Werte mittels ELOstat anhand der aktuellen PGN Datei aus.

Der 'Optionen' Knopf führt Sie direkt zum Konfigurationsfenster für die Einstellungen für PGN Dateien.

Dort (im Optionen / Oberfläche Dialog unter der [image] Registerkarte PGN) können Sie bestimmen, was passiert, wenn Sie eine Partie laden. Danach kann das PGN Fenster geschlossen oder verkleinert werden. Auch kann automatisch zu einem bestimmten Zug gesprungen werden. Wenn Sie immer ans Ende möchten, geben Sie einfach einen hohen Wert ein. Ferner können Sie bestimmen, ob das PGN Fenster immer vor andereren Fenstern sichtbar bleiben soll, auch z.B. vor dem Arena- Hauptfenster.

Die PGN Datei wird beim nächsten Arena- Start wieder geladen, es sei denn Sie schließen Sie mit dem Knopf "Schließen" in der Liste oder im PGN- Menü mit "Schließen".


Arena - Hilfe -Dateiformate - Partie speichern im PGN Format

Partie speichern im PGN Format

Die aktuell geladene Partie können Sie einer PGN Datei hinzufügen oder in eine neue speichern unter PGN / "Partei speichern als PGN". Falls die Datei schon existiert, wird die Partie am Ende angehängt.

Welche Informationen zusätzlich zu den Zügen und den Grunddaten (Spielernamen, Datum etc.) gespeichert werden, können Sie im Optionen / Oberfläche Dialog unter der [image] Registerkarte PGN einstellen.

Es stehen Hauptvariante, Bewertung/Tiefe und Dauer zur Wahl. Diese Informationen werden dann, falls vorhanden, für jeden Zug in die PGN Datei gespeichert.


Arena - Hilfe -Dateiformate - Im PGN- Format zurückspeichern

Im PGN- Format zurückspeichern

Diese Funktion finden Sie unter PGN / Partie zurückspeichern.

Eine Partie, die aus einer PGN- Datei geladen wurde, kann mit dieser Funktion (z.B. in geänderter Form) zurückgespeichert werden.

Die Partei wird an die gleiche Position wie vorher zurückgeschrieben.


Arena - Hilfe -Dateiformate - PGN - Liste filtern

PGN - Liste filtern

Über das Filtern-Symbol in der PGN-Liste

können Sie Partien aus der Datenbank filtern. Sie kommen zu folgendem Dialog:

Alle Kriterien, die Sie dort angeben, werden UND-verknüpft und bei einem Klick auf "Suchen!" angewandt. In der PGN-Liste werden entsprechend der Suchkriterien die passenden Partien angezeigt.

In der PGN-Liste wird in der Titelzeile nun die Anzahl der gefundenen Partien angezeigt:


Arena - Hilfe -Dateiformate - EPD

Das EPD-Format

Das EPD-Format ist ein Format für Stellungsdateien, nicht für komplette Partien. Häufig wird hinter 'bm' (englisch für: 'best move') der beste Zug angegeben, weiterhin optionale Kommentare. Im Internet lassen sich einige Dateien mit Stellungstests etc. finden.

Beispiel:

rq2r1k1/5pp1/p7/4bNP1/1p2P2P/5Q2/PP4K1/5R1R w - - 0 1 bm Nxg7 ;1 wins
6k1/2b2p1p/ppP3p1/4p3/PP1B4/5PP1/7P/7K w - - 0 1 bm Bxb6 ;2 wins
5r1k/p1q2pp1/1pb4p/n3R1NQ/7P/3B1P2/2P3P1/7K w - - 0 1 bm Re6 ;3 wins
5r1k/1P4pp/3P1p2/4p3/1P5P/3q2P1/Q2b2K1/B3R3 w - - 0 1 bm Qf7 ;4 wins
3B4/8/2B5/1K6/8/8/3p4/3k4 w - - 0 1 bm Ka6 ;5 wins


Arena - Hilfe -Dateiformate - EPD- Datei laden

EPD-Datei laden

Hier können Sie eine Datei im EPD-Format laden (Menü EPD / Laden oder Strg-E). Die EPD-Liste erreichen Sie mit Strg-Alt-E oder Menü EPD / Liste.

Eine Datei im EPD-Format laden Sie mit Menü EPD / Laden oder Strg-E. Es wird die Liste der EPD Stellungen links im Arena Hauptfenster eingeblendet. Diese Liste enthält 3 Spalten: Stellungsnummer, Bester Zug und Stellung. Bester Zug bedeutet, dass dort der in der Datei angegebene beste Zug angezeigt wird, der sog. "bm" Opcode. Unter Stellung ist die gesamte Zeichenkette, die zu dieser Stellung gehört, angezeigt (im Bild gerade ausgeblendet).

Sie können die Liste durch einen Klick auf die oberste Zeile der Liste nach der entsprechenden Spalte sortieren.

Im Hauptmenü EPD / Zeige mit Editor können Sie sich die Datei mittels Ihres Editors anzeigen lassen.

Die EPD-Liste erreichen Sie mit Strg-Alt-E oder Menü EPD / Liste.

Sie können eine neue EPD Datei mittels EPD / Neu erstellen.

Mit der Tastenkombination Alt+Strg+F11 und Alt+Strg+F12 oder mittels der Einträge im Hauptmenü unter EPD können Sie schnell zur vorigen oder nächsten Stellung wechseln.

Sie können die Reihenfolge der Stellungen mittels Ziehen und Ablegen verändern, d.h. eine Stellung anwählen und zu einem anderen Platz verschieben. Beispiel:

Sie können die aktuelle Brettstellung der bestehenden EPD Datei hinzufügen, indem Sie mit einem Rechtsklick auf die EPD Liste das Kontextmenü aufrufen und "Aktuelle Brettstellung hinzufügen” wählen.

Sie können auch der bestehenden EPD Datei eine Stellung hinzufügen, die sich als EPD Zeichenkette in der Zwischenablage befindet. Dazu wählen Sie nach einem Rechtsklick auf die EPD Liste im Kontextmenü "Aus Zwischenablage hinzufügen".

Die aktuelle EPD Datei speichern Sie mit EPD / Speichern. Wenn Sie die Datei unter einem anderen Namen speichern möchte, wählen Sie “EPD / Speichern als”.

Die EPD Datei wird beim nächsten Arena-Start wieder geladen, es sei denn Sie schließen sie mit dem Menüpunkt "Schließen" im Kontextmenü der Liste oder im EPD-Menü mit "Schließen".

Falls Sie sich gerade im Analyse Modus befinden, also der Analyseknopf in der Navigationsleiste gedrückt ist, können Sie einfach zur nächsten Stellung weiterklicken, ohne die Motoren vorher zu unterbrechen, indem Sie den Analysemodus beenden. Die Analyse der Motoren wird von Arena beendet und mit der neuen Stellung fortgesetzt.

EPD-Format

PGN-Dateien laden


Arena - Hilfe -Dateiformate - EPD- Datei speichern

EPD-Datei speichern

Mit einem Rechtsklick auf die EPD Liste und der Auswahl von ''Aktuelle Brettstellung hinzufügen'' aus dem Kontextmenü können Sie die aktuelle Stellung der EPD-Datei hinzufügen. Falls Sie noch keine EPD-Datei haben, wählen Sie vorher im Menü EPD 'Neu'.

Mit der Auswahl 'Stellung löschen' im Kontextmenü können Sie die aktuelle Stellung aus der EPD-Datei entfernen.

Um die Datei zu speichern, wählen Sie im Hauptmenü EPD / Speichern oder EPD / Speichern als.

Hinweis: Sie können die EPD-Datei auch im PGN - Format speichern, also nach PGN exportieren.


Arena - Hilfe -Dateiformate - Weitere Dateien

Weitere Dateien

Unter Datei / Neu Laden / Weitere Dateien finden Sie eine Liste jemals geladener Dateien. Die zuletzt geladene steht oben.

Diese Dateiliste befindet sich in der Datei "WeitereDateien.txt" im Arena Verzeichnis. Sie können diese Datei gefahrlos löschen oder mit einem Editor bearbeiten, evtl. kürzen.


Arena - Hilfe -Drucken

Drucken

(In der Version 1.99beta3 noch nicht verfügbar.)

Über Datei / Drucken erreichen Sie den Druckdialog mit den unten beschriebenen [image] Registerkarten.

Das allgemeine Prinzip:

Es wird die Partienotation mit ausgewählten Diagrammen gedruckt. Diagramme wählen Sie für das Drucken aus, indem Sie in der Partienotation mit der rechten Maustaste auf den ausgewählten Zug klicken und dann 'Druckdiagramm' anwählen. Auf die gleiche Weise können Sie 'Druckdiagramm' auch wieder abwählen.

Für Diagramme ist die Installation der TrueType- Schriftart 'Chess Merida' in ihrem Windows- System notwendig!

Schrifteninstallation

Registerkarte Drucken:

Hier können Sie die Druckerkonfiguration ihres Druckers aufrufen und die Kopf und Fußzeile definieren.

Die Kopf und Fußzeile besteht aus jeweils drei Bereichen: einem linken, einem mittleren und einem rechten. In jeden Bereich können Sie beliebigen Text schreiben. Bestimmte Platzhalter können Sie benutzen, um andere Dinge anzeigen zu lassen:

  • /f : Der aktuelle Dateiname wird eingeblendet
  • /n : Die Seitennummerierung wird eingeblendet
  • /d : Das aktuelle Datum wird eingeblendet
  • /t : Die aktuelle Zeit wird eingeblendet
  • /p : Partieinformationen werden eingeblendet

Registerkarte Darstellung:

Unter der [image] Registerkarte "Darstellung" kann die Formatierung des Textes eingegeben werden. Sie können bestimmen, ob die Hauptvarianten angezeigt werden sollen. Auch die Schriftart- und Größe können Sie hier einstellen.

Registerkarte Ränder/Spalten:

Hier können Sie die Ränder, die Anzahl der Spalten sowie den Abstand der Spalten einstellen. Verwenden Sie für Kommazahlen das Komma, nicht den englischen Punkt als Dezimaltrennzeichen.

Registerkarte Kopf/Fußzeile:

Kopf- und Fußzeile werden auf jede Seite gedruckt. Noch nicht implementiert.

Registerkarte Vorspann:

Hier können Sie die Felder wählen, die vor der eigentlichen Partie(notation) gedruckt werden.

Registerkarte Diagramme:

Die Größe der Diagramme sowie ob diese mit Koordinaten ausgedruckt werden sollen, können Sie hier festlegen.

An welcher Stelle Diagramme gedruckt werden, müssen Sie vorher durch einen Klick mit der rechten Maustaste auf den entsprechenden Zug festlegen. Im dann erscheinenden Kontextmenü wählen Sie 'Druckdiagramm' aus. Auf die gleiche Art und Weise können Sie das Diagramm wieder ausschalten.


Arena - Hilfe -DGT Schachbrett

Das Elektronische DGT - Schachbrett

Mit dem elektronischen Schachbrett von DGT können Sie Partien mit richtigen Figuren an einem richtigen Schachbrett spielen und trotzdem brauchen Sie auf die Vielfalt der heutigen Computerschachprogramme und Motoren nicht zu verzichten. Das elektronische Schachbrett von DGT überträgt alle Züge, die Sie per Hand ausführen, an den PC.

Um die DGT- Unterstützung zu aktivieren, wählen Sie 'Extras / Konfiguriere DGT - Schachbrett' und vergewissern Sie sich unter Optionen, dass Sie den seriellen Anschluß ausgewählt haben, mit dem Ihr DGT- Schachbrett verbunden ist. Sie benötigen keinen Treiber für das DGT- Schachbrett, aber Sie können den von DGT mitgelieferten-Treiber verwenden, wenn Sie möchten. Wählen Sie "Arena DGT-Direktsupport" oder "Treiber von DGT verwenden", wie Sie wünschen. Wenn Sie die DGT-XL Uhr verwenden, müssen Sie den DGT-Treiber verwenden, sehen Sie auch unten.

Dann starten Sie mit 'Extras / DGT - Schachbrett' die DGT - Unterstützung. Oder Sie klicken mit der linken Maustaste auf das DGT Symbol auf der Werkzeugleiste.

Die Stellung, die auf Ihrem DGT- Schachbrett angezeigt wird, erscheint jetzt auch in Arena.

Arena unterstützt folgende Funktionen:

1. Sie können Züge machen
2. Wenn Sie in Arena den 'bearbeiten' Modus gewählt haben, können Sie Züge eingeben, ohne das ein Schachmotor anfängt zu rechnen.
3. Wenn Sie nicht im 'bearbeiten' Modus sind, rechnet der ausgewählte Motor, nachdem Sie einen Zug gemacht haben.
4. Die Züge können Sie zurück- und wieder vorspielen.
5. Sie können eine Stellung aufbauen
6. Arena kann die Züge ansagen, falls Sie die Klangdateien von DGT installiert haben und die entsprechende Option gesetzt ist.

Züge machen:

Wenn Sie Züge machen, braucht Arena einen kleinen Augenblick, um festzustellen, dass Sie z.B. nicht nur den Turm auf der langen Geraden herziehen, sondern der Zugvorgang beendet ist. Diese Zeit ist einstellbar in Millisekunden unter Optionen im DGT- Dialog (Optionen/Konfiguriere DGT - Schachbrett'). Standard ist 350 Millisekunden. Falls Sie lieber langsamer ziehen, können Sie den Wert vergrößern. Falls Sie möchten, dass die Erkennung eines Zuges mit einem Klang signalisiert wird, können Sie dort auch eine entsprechende Klangdatei angeben.

Eine Stellung aufbauen:

Bitte speichern Sie eine evtl. vorher gespielte Partie. Wenn Sie eine Stellung aufbauen wollen, entfernen Sie bitte die beiden Könige. Dann ist Arena im Aufbau-Modus und erkennt keine Züge. Sie können jetzt die Stellung aufbauen, natürlich auch die Grundstellung.

Zuletzt stellen Sie die Könige auf das DGT- Schachbrett. Dabei stellen Sie den König als letztes auf, dessen Seite am Zug sein soll. Wenn schwarz am Zug ist, stellen Sie also erst den weißen, dann den schwarzen König auf das DGT- Brett.

Zugansage:

Wenn ein Motor einen Zug gemacht hat, ist es sinnvoll, diesen durch Arena ansagen zu lassen, um nicht immer wieder auf den Monitor schauen zu müssen. Auf der Arena Startseite, dem Abschnitt "User Files", können Sie Zugansagen Jörg Borchardt in deutsch und englisch, sowie russische und spanische Ansagen herunterladen. Die DGT XL Schachuhr kann Züge allerdings sogar anzeigen, siehe unten.

Sie können auch von der Internetseite von DGT deutsche, englische und andere Zugansagen herunterladen. Gehen Sie auf DGTProjects und wählen Sie 'Download'. Dort gibt es die Dateien mit dem Namen 'MoveAnnouncements_German'. Laden Sie diese herunter und installieren Sie sie.

In Arena müssen Sie jetzt nur noch das Verzeichnis angeben, wo diese Dateien zu finden sind: Gehen Sie unter 'Optionen/Oberfläche' zu der [image] Registerkarte 'Klänge' und geben Sie dort unter 'Zugansage' den entsprechenden Pfad an. Falls Sie immer eine Zugansage wünschen, aktivieren Sie dort das entsprechende Kontrollkästchen. Falls Sie nur die Züge ansagen lassen möchten, wenn Sie mit den DGT- Schachbrett spielen, wählen Sie die entsprechende Option im DGT- Konfigurationsdialog.

Hinweis zum Drehen des DGT-Brettes:

Falls Sie einmal das DGT- PC- Brett drehen und die weißen und schwarzen Steine nun umgekehrt aufgebaut sind, bauen Sie einmal die Grundstellung auf, damit Arena erkennt, dass das Brett gedreht worden ist. Für weitere Partien merkt sich Arena die Orientierung der Brettes, auch nach Beenden von Arena.

Verlassen des DGT-Modus:

Sie verlassen den DGT- Modus genauso, wie Sie ihn gestartet haben: 'Optionen/ DGT - Schachbrett' oder Sie klicken mit der linken Maustaste auf das DGT Symbol auf der Werkzeugleiste.

DGT 2000 Schachuhr:

Arena unterstützt die DGT Schachuhr. Die Zeiten der Uhr werden durch Arena umgerechnet in Zeiten, die für den entsprechenden Zug benötigt wurden.

DGT XL Schachuhr:

Arena unterstützt die DGT XL Schachuhr, wenn Sie den Treiber von DGT verwenden. Züge und Bewertungen können auf der Uhr angezeigt werden. Wenn sie 'Bewertung anzeigen' setzen, dann zeigt Arena konstant die Bewertung des Motors an.


Arena - Hilfe -Eröffnungsbuch

Eröffnungsbuch

Konzept:

In Arena können Sie ein Hauptbuch laden. Das Hauptbuch wird Ihnen neben oder alternativ zur Zugliste angezeigt. In dieser Liste sehen Sie alle Züge, Prioritäten, Ausspielwahrscheinlichkeiten etc. Dieses Buch wird hier "Arena Hauptbuch" genannt.

Zusätzlich können Sie ein Arena Buch für jeden Motor definieren. Dieses Buch wird dann von Arena vor jedem Zug abgefragt, wenn der Motor am Zug ist. Dieses Buch wird hier "Arena Motorenbuch" genannt. Das Motorenbuch hat Vorrang vor dem Hauptbuch .

Die vorigen Aussagen betrafen die Arena - eigene Buchverwaltung. Davon zu unterscheiden ist die Möglichkeit, daß viele Motoren ein eigenes, internes Buch verwenden. Dieses Buch wird hier "internes Motorenbuch" genannt. Dieses Buch können Sie für UCI Motoren meistens im Konfigurationsdialog des Motors angeben, bei Winboard Motoren in einer Konfigurationsdatei.


Arena - Hilfe -Eröffnungsbuch - Buchverwaltung

Buchverwaltung

Unter Buch / Verwalten kommen Sie zu dem folgenden Dialog:

Registerkarte Daten:

Hinter Arena Hauptbuch: sehen Sie das aktuelle Arena Hauptbuch. Sie können zur Information hier auch einen Kommentar und den Autor des Buches angeben. Danach bitte Speichern nicht vergessen.

Mit "Arena Hauptbuch verwenden" kann das Hauptbuch komplett abgeschaltet werden.

Mit "Arena Motorenbücher verwenden" können Sie alle Arena Motorenbücher abschalten.

Arena Motorenbücher können Sie übrigens unter Motoren / Verwalten / Details / Bücher den einzelnen Motoren zuordnen.

Registerkarte Ausspielen:

Hier legen Sie die Einstellungen für das Ausspielen von Zügen fest.

Unter "Minimalbedingungen für Zug Ausspiel" legen Sie fest, welche Bedingungen unbedingt erfüllt werden müssen, damit ein Zug ausgespielt wird.

  • Minimale Partienzahl: Es müssen im Buch mindestens soviele Partien mit diesem Zug vorhanden sein.
  • Gewinnpartien Minimum: Es müssen im Buch mindestens soviele Gewinn Partien mit diesem Zug vorhanden sein.
  • GewinnquoteGewinnquote weiß/schwarz: Mit dem Zug müssen die angegebene Prozentzahl Partien gewonnen worden sein.

Wenn eine dieser drei Bedingungen nicht erfüllt sind, wird der Zug nicht gespielt.

Mit Wahrscheinlichkeit bestimmt durch.. legen Sie die Gewichtung der Faktoren fest.

Die Priorität können Sie für jeden Zug angeben. Ein Zug mit höherer Priorität wird häufiger gespielt als einer mit niedriger Priorität. Wenn Sie die Priorität höher gewichten, hat dieser Faktor einen höheren Einfluß als die anderen. Die Priorität dient vorwiegend dazu, ihnen die Möglichkeit zu geben, die Ausspielpräferenzen einfach zu verändern, ohne andere Daten, wie etwa die Partienzahl verändern zu müssen.

Wie wichtig die Partieanzahl für die Ausspielwahrscheinlichkeit eines Zuges ist, legen Sie auch hier fest, eben so die Gewinnquote.

Diese Einstellungen werden in jede Buchdatei gesondert gespeichert, so dass Sie für jede Buchdatei andere Werte verwenden können.

Registerkarte Import:

In der Zeile Importiere PGN Datei geben Sie eine Datei an, die Sie in ihr Buch importieren möchten. Sie können beliebig viele Dateien importieren, allerdings immer nur eine gleichzeitig.

Drücken Sie auf Start, damit der Import startet. Zuerst wird dann die PGN Datei geladen, danach folgt der eigentliche Importvorgang.

Sie können den Importvorgang jederzeit Abbrechen.

Als Optionen können Sie eingeben, bis zu welchem Halbzug die Partien importiert werden sollen (Importiere bis Halbzug).

Ob Remispartien in den Import eingehen sollen, können Sie hier festlegen (Importiere Remispartien).

Vorgehensweise:

Wenn Sie ein Buch für alle Motoren verwenden möchten, gehen Sie wie folgt vor:

  • Erstellen Sie ein Buch mit dem "Neu" Knopf. Geben Sie einen neuen Namen an.
    • Geben Sie Kommentar und Autor an und Ändern Sie evtl. unter der [image] Registerkarte Ausspielen die Ausspieleinstellungen.
  • Geben Sie Züge per Hand ein und speichern Sie sie im Hauptmenu unter Buch / Variante hinzufügen. Oder importieren Sie Züge mittels der oben beschriebenen Importfunktion.
  • Gehen Sie zu Motoren / Verwalten / Details. Wählen Sie einen Motor aus. Gehen Sie unter die [image] Registerkarte "Bücher". Setzen Sie den Haken für "Verwende Arena Hauptbuch mit diesem Motor". Dieses Verfahren müssen Sie für alle Motoren wiederholen.
  • Wenn die Checkbox "Arena Hauptbuch verwenden" im Buch / Verwalten Dialog gesetzt ist, können Sie und alle Motoren das Buch sofort verwenden.

Wenn Sie ein Buch speziell für einen Motor erstellen möchten, andere Motoren aber dieses Buch nicht verwenden sollen, gehen Sie z.B. wie folgt vor:

  • Erstellen Sie ein Buch mit dem "Neu" Knopf. Geben Sie einen neuen Namen an.
  • Geben Sie Kommentar und Autor an und Ändern Sie evtl. unter der [image] Registerkarte Ausspielen die Ausspieleinstellungen.
  • Geben Sie Züge per Hand ein und speichern Sie sie im Hauptmenu unter Buch / Variante hinzufügen. Oder importieren Sie Züge mittels der oben beschriebenen Importfunktion.
  • Gehen Sie zu Motoren / Verwalten / Details. Wählen Sie den Motor aus. Gehen Sie unter die [image] Registerkarte "Bücher". Geben Sie das Buch unter "Arena Motorenbuch" an.
  • Da andere Motoren das Buch nicht verwenden sollen, wählen Sie in der Buchverwaltung (Buch / Verwalten) ein anderes Arena Hauptbuch oder schalten Sie es mit der Checkbox Arena Hauptbuch verwenden aus (nehmen Sie das Häkchen weg). Vergewissern Sie sich jedoch, daß der Haken bei "Arena Motorenbücher verwenden" gesetzt ist.


Arena - Hilfe -Eröffnungsbuch - Buchinformationen im Hauptfenster

Buchinformationen im Hauptfenster

Alternativ zur Zugliste sehen Sie hier Buchinformationen.

Dabei bedeuten:

  • Zug: Ja, ein Zug, der im Buch gespeichert ist!
  • Prio: Priorität. Diese dient zum einfachen Anpassen der Ausspielwahrscheinlichkeiten durch den Benutzer (das sind Sie!).
    • Wenn ihnen ein Zug gar nicht gefällt, können Sie ihn mit Priorität "0" versehen. Der Zug wird dann in der Zukunft nicht ausgespielt. Standard Priorität ist "5".
  • Partien: Die Anzahl der Partien, die mit diesem Zug gespielt werden. Wird beim Importieren von PGN Dateien gesetzt und auch beim manuellen Importieren einer Variante.
  • Quote: Gewinnquote, berechnet aus der Anzahl der gewonnenen, verlorenen und remisierten Partien.
  • Wahrscheinlichkeit: Ausspielwahrscheinlichkeit für den Zug.
    • Die Ausspielwahrscheinlichkeiten der Züge werden durch die Faktoren Priorität, Partieanzahl, und Gewinnquote bestimmt. Die Gewichtung dieser Faktoren wird in der Buchverwaltung unter der [image] Registerkarte 'Ausspielen' festgelegt.
  • Variante: ECO Code und Bezeichnung der Variante.
  • Buch: Names des Buches

Mit einem Doppelklick auf den Zug können Sie diesen Ausspielen.

Wenn Sie auf einen Zug mit der rechten Maustaste klicken, erscheint ein Kontextmenü mit folgenden Optionen:

  • Priorität: Setzt die Priorität des Zuges.
  • Lösche Zug: Löscht den Zug und alle folgenden Untervarianten.
  • Zug bearbeiten: Startet ein kleines Dialogfeld , in dem Sie die Daten des Zuges manipulieren können.
  • Zug zurück: Geht einen Zug in der Partie zurück.
  • Buch Verwaltung: Geht zum Buchverwaltungsdialog.


Arena - Hilfe -Eröffnungsbuch - Variante hinzufügen

Buch - Variante hinzufügen

Im Hauptmenü unter 'Buch' haben Sie die Möglichkeit, eine Variante der aktuellen Partie zum aktuell ausgewählten Arena Hauptbuch hinzuzufügen. Dabei gibt es 5 Möglichkeiten, je nachdem, ob die Variante gut für weiß, schwarz oder beide ist.

Variante hinzufügen - gut für beide Seiten:

Partie bis zum aktuellen Zug dem Buch hinzufügen

Variante hinzufügen - nur für weiß:

Partie bis zum aktuellen Zug dem Buch hinzufügen, als Sieg für Weiß. Arena zählt die gewonnenen und verlorenen Partien, die Sie aus einer PGN Datei importiert oder über diesen Weg hinzugefügt haben. Diese Zählung können Sie für die Zugauswahl verwenden, wenn das Buch später von den Motoren oder als Arena Hauptbuch verwendet wird.

Variante hinzufügen - nur für weiß + Priorität:

Partie bis zum aktuellen Zug dem Buch hinzufügen, dabei die Priorität nur für weiße Züge ungleich 0 setzen.

Variante hinzufügen - nur für schwarz:

Partie bis zum aktuellen Zug dem Buch hinzufügen, als Sieg für Schwarz.

Variante hinzufügen - nur für schwarz + Priorität:

Partie bis zum aktuellen Zug dem Buch hinzufügen, dabei die Priorität nur für schwarze Züge ungleich 0 setzen.


Arena - Hilfe -Eröffnungsbuch - Buchzug bearbeiten

Buchzug bearbeiten

Klicken Sie mit der rechten Maustaste auf einen Zug in der Liste der Buchzüge, erscheint ein Kontextmenü, in dem Sie "Zug bearbeiten" auswählen.

Im folgenden Dialog können Sie einstellen:

  • Priorität: Von 0=Zug wird nicht gespielt bis 9=Zug hat höchste Priorität
  • Partien: Anzahl der gespielten Partien
  • Gewonnene Partien: Anzahl der gewonnen Partien
  • Verlorene Partien: Anzahl der verlorenen Partien

Alle Einstellungen können sich auf die Ausspielwahrscheinlichkeit auswirken, je nach Einstellungen in der Buchverwaltung , [image] Registerkarte 'Ausspielen'.


Arena - Hilfe -Sonstiges

Sonstige Informationen

Programmgrenzen:

  • Maximale Anzahl gleichzeitig verwendbarer Schachmotoren : 3
  • Maximale Anzahl installierter Schachmotoren : 1500
  • Maximale Anzahl Züge in einer Partie : unbegrenzt
  • Maximale Länge einer Variante in einer Partie : 2000 Züge
  • Maximale Anzahl Partien in einer PGN-Datenbank: unbegrenzt, nur vom verfügbaren Hauptspeicher abhängig
  • Axon Bench läuft nicht unter Windows Vista und 64 bit-Betriebssystemen

Programmdateien:

  • Arena.exe : Die Schachoberfläche, die wichtigste Datei
  • ArenaGUI.cfg : Konfigurationseinstellungen von Arena
  • ArenaENG.cfg : Konfigurationseinstellungen für die Motoren
  • Readme\help\de\willkommen. htm : HTML-Hilfesystem in deutsch oder
  • Readme\help\deutsch. chm : HTML-Hilfesystem in deutsch
  • Readme\help\en\welcome. htm : HTML-Hilfesystem in englisch oder
  • Readme\help\english. chm : HTML-Hilfesystem in englisch
  • Readme\German.hlp : Alte Hilfedatei in deutsch, seit Arena 1.99beta3 nicht mehr unterstützt
  • Readme\English.hlp : Alte Hilfedatei in englisch, seit Arena 1.99beta3 nicht mehr unterstützt
  • Readme\Liesmich.txt : Hinweise in deutsch
  • Readme\Readme.txt : Hinweise in englisch
  • Languages\English.lng : Englische Sprachdatei
  • logo. jpg : Arena-Startbild
  • bundle.ini : Datei für die automatische Installation von in einem Packet mitgelieferten Motoren
  • engines.ini: Datei mit Daten über Motoren, hilft Arena beim installieren derselben
  • ecocodes7.txt : Deutsche Eröffnungsklassifikation
  • ecocodes9.txt : Englische Eröffnungsklassifikation
  • my.txt : Textdatei für ihre Notizen
  • Readme\copyright.txt Urheberrechtliche Bestimmungen von Arena und den Motoren
  • timeseal. exe : Benötigt um Verzögerungen auf den Internet Schachservern zu verringern
  • timestamp. exe : Siehe eine Zeile höher, für andere Schachserver
  • accuclck. exe : Siehe eine Zeile höher, für andere Schachserver

Empfohlene Verzeichnisse:

  • Anthems : Nationalhymnen, die beim Laden der Motoren gespielt werden können
  • Engines : Für Ihre Schachmotoren
  • Flags : Länder-Flaggen
  • Graphics : Grafiken für die Arena Oberfläche
  • Logos : Logos der verschieden Motoren
  • Sounds : Klänge, die Arena zu verschiedenen Anlässen spielen kann, z.B. wenn Sie am Zug sind
  • Readme: Liesmich Dateien, Hilfe Dateien und Urheberrechts-Hinweise
  • Languages: Sprachdateien. Standardmäßig wird deutsch und englisch mitgeliefert.
  • Speedtest: Dateien des Axon Geschwindigkeits Tests.
  • Arlokal: Werkzeug für Übersetzer für die Übertragung von Arena-Dateien in andere Sprachen
  • Tournaments: Empfohlenes Verzeichnis für Turnierdateien.

Windows XP:

Einige Benutzer hatten Probleme, frühere Versionen von Arena unter Windows XP laufen zu lassen. Heutige Versionen sollten diese Probleme nicht mehr haben, der Vollständigkeit halber jedoch dieser Tipp:

So verbessert man die Kompatibilität von Arena unter Windows XP:

1. Klicken Sie im Explorer mit der rechten Maustaste auf die Datei "Arena.exe" und wählen Sie "Verknüpfung erstellen"
2. Klicken Sie mit der rechten Maustaste auf die erstellte Verknüpfung und wählen Sie "Eigenschaften".
3. In der [image] Registerkarte "Kompatibilität" wählen Sie dann "Windows NT 4.0 (Service Pack 5)" aus der Liste aus und speichern ab.


Arena - Hilfe -Sonstiges - Logos, Flaggen und Hymnen

Logos, Flaggen und Hymnen

Sie können auf unserer Internetseite stets aktuelle

  • Logos der verschieden Motoren
  • Länder-Flaggen und
  • Nationalhymnen, die beim Laden der Motoren gespielt werden können

herunterladen. Normalerweise werden alle Flaggen und Logos sofort verwendet, Klänge nur, wenn sie aktiviert wurden. Falls es einmal Probleme geben sollte, beachten Sie die folgenden Beschreibungen.

Logos können sich in mehreren Verzeichnissen befinden. Hier die Reihenfolge, in der nach passenden Logos gesucht wird:

1. Die unter Motoren / Verwalten unter 'Details' angegebene Logodatei
2. Im Verzeichnis Logos: "programmname2.5.7.bmp
3. Im Verzeichnis Logos: "programmname.bmp (ohne Zahlen, Bindestriche, Unterstriche, eckige Klammern und Punkte)
4. Im Programmverzeichnis: "programmname2.5.7.bmp

Flaggen:

1. Im Verzeichnis Flags: "Country.bmp

Hymnen:

1. Im Verzeichnis Anthems: Country.mid
2. Im Programmverzeichnis: programmname2.5.7.wav
3. Im Programmverzeichnis: programmname2.5.7.mid
4. Im Programmverzeichnis: programmname2.5.7.midi

Erkärung:

  • Verzeichnis Logos = Das Verzeichnis 'Logos', das sich unter dem Arena- Verzeichnis befindet
  • Programmverzeichnis = Das Verzeichnis, in dem der Motor sich befindet.
  • "Country.bmp, Country.mid = Wenn in der Motor-Installation 'Country' im Feld 'Land' eingegeben ist, wird diese Datei geladen.
  • Die ausführbare Datei des Motors heißt in unserem Falle '"programmname2.5.7. exe', aber das haben Sie sicherlich schon längst bemerkt

Zusätzlich zu den bmp-Dateien werden auch Dateien vom Typ jpg und gif gesucht. Die Reihenfolge ist bmp, jpg und dann gif.

Wenn Sie immer nur ein Logo für ein Programm verwenden wollen, egal um welche Version des Motors es sich handelt, ist die beste Methode, Sie speichern alle Logos im Verzeichnis \Logos unterhalb des Arena - Verzeichnisses. Dann sind Sie für alle zukünftigen Versions-Aktualisierungen gewappnet, solange die Versionsnummer nur mit Bindestrichen, Unterstrichen, eckigen Klammern und Punkten abgetrennt wird, was aber bei den meisten Programmen der Fall ist.

Neue Logos

Aktuelle Logos können von der Internetseite heruntergeladen werden,


Arena - Hilfe -Sonstiges - Kommandozeilenparameter

Kommandozeilenparameter

Arena kann man mit Kommandozeilenparametern aufrufen. Dadurch kann man z.B. im Stapelbetrieb Turniere durchführen lassen, bestimmte Stellungen laden oder Arena mit bestimmten Farben starten.

Alle Parameter müssen folgende Form haben:

/Parametername Parameterwert oder -Parametername Parameterwert

Parameternamen werden nicht nach Groß- und Kleinbuchstaben unterschieden.

/lp "EPDString" oder /loadposition "epdstring" Lädt die als Zeichenkette angegebene Stellung

/lpf filename oder /loadpositionfile filename Lädt angegebene EPD oder FEN Datei.

/lpi n oder /loadpositionindex n Lädt die angegebene Stellung in der EPD oder FEN Datei.

/lgf filename oder /loadgamefile filename Lädt angegebene PGN Datei.

/lgi n oder /loadgameindex n Lädt angegebene Partie in PGNfile.

/fcp enginename oder /firstchessprogram enginename Lädt angegebenen Motor als ersten Motor

/scp enginename oder /secondchessprogram enginename Lädt angegebenen Motor als zweiten Motor

/ics Geht direkt beim Start in den ICS Modus

/top Macht Arena zu einem immer oben befindlichen Fenster

/flip oder /xflip oder /flipview Zeigt die schwarze Seite unter der weißen

/lsc #rrggbb oder /lightsquarecolor #rrggbb Ändert die Farbe der weißen Felder

/dsc #rrggbb oder /darksquarecolor #rrggbb Ändert die Farbe der schwarzen Felder

/bgc #rrggbb oder /colorBackground #rrggbb Ändert die Farbe des Fensterhintergrundes

/ac #rrggbb oder /analyzecolor #rrggbb Ändert die Farbe der Analysezeilen

/mwh pixels oder /mainwindowheight pixels Setzt die Höhe des Arena Hauptfensters in Punkten

/mww pixels oder /mainwindowwidth pixels Setzt die Breite des Arena Hauptfensters in Punkten

/x pixels oder /mainwindowx pixels Ändert die Horizontale Position des Arena Hauptfensters in Punkten

/y pixels oder /mainwindowy pixels Ändert die Vertikale Position des Arena Hauptfensters in Punkten

/maximized Startet Arena im Vollbildmodus

/ibc mm:ss oder /initialblackclock mm:ss Setzt den Anfangswert der schwarzen Uhr

/iwc mm:ss oder /initialwhiteclock mm:ss Setzt den Anfangswert der weißen Uhr

/dgt Start im DGT-Schachbrett Modus

/match Start im Match Modus, fängt einen Wettkampf mit zuletzt benutzten Parametern an.

/analyze Start im Analysemodus, die geladenen Motoren fangen gleich an zu analysieren nach dem Start von Arena.

/mg oder /matchGames n

Startet einen automatischen Motorenwettkampf zwischen zwei Motoren mit abwechselnden Farben. Wenn loadGameFile angegeben worden ist, startet jede Partie mit den angegebenen Zügen, ansonsten mit der normalen Grundstellung. Wenn dieser Parameter angegeben wird, beendet sich Arena danach.

/runtournament "Turnierdatei"

Startet oder setzt ein Turnier fort. Es muß als Parameter der Name der Turnierdatei (*.at) angegeben werden. Das Turnier muß also einmal von ihnen konfiguriert worden sein.

/shutdown

Fährt den Computer nach einem Turnier herunter, wenn das Turnier mit dem obigen "runtournament" Kommando gestartet wurde.

/tc oder /timeControl mm:ss

Jeder Spieler beginnt mit dieser Zeit auf der Uhr. Die Parameter movesPerSession und timeIncrement schließen einander aus.

/mps oder /movesPerSession n

Wenn beide Spieler n Züge genacht haben, wird eine neue Zeitkontroll-Periode angefangen.

/inc oder /timeIncrement sec

Wenn diese Option angegeben wird, wird movesPerSession ignoriert. Es wird in den Blitz (Fischer) Modus gewechselt. Mit timeIncrement 0 wird die gesamte Partie in einer Zeitkontrolle absolviert. Default: -1, was den movesPerSession Modus angibt.

/nosplash Startet Arena ohne den Startbildschirm anzuzeigen.

/e Lädt Arena mit englischer Sprache
/d Lädt Arena mit deutscher Sprache
/f Lädt Arena mit französischer Sprache
/i Lädt Arena mit italienischer Sprache
/p Lädt Arena mit portugisischer Sprache
/es Lädt Arena mit spanischer Sprache
/c Lädt Arena mit katalanischer Sprache
/t Lädt Arena mit türkischer Sprache
/h Lädt Arena mit ungarischer Sprache
/pol Lädt Arena mit polnischer Sprache

/Zahl = Lädt Arena mit Sprache Nummer (Zahl). Ersetzen Sie dabei Zahl mit einer gültigen Sprachnummer, siehe folgende Tabelle. Vorraussetzung ist natürlich, daß die entsprechende Sprachdatei auch vorhanden ist.

1=Arabisch (Saudi-Arabien) | 16=Italienisch | 31=Türkisch
2=Bulgarisch | 17=Japanisch | 32=Urdu
3=Katalanisch | 18=Koreanisch | 33=Indonesisch
4=Chinesisch | 19=Niederländisch | 34=Ukrainisch
5=Tschechisch | 20=Norwegisch (Bokmal) | 35=Belarussisch
6=Dänisch | 21=Polnisch | 36=Slowenisch
7=Deutsch | 22=Portugiesisch | 37=Estnisch
8=Griechisch | 24=Rumänisch | 38=Lettisch
9=Englisch | 25=Russisch | 39=Litauisch
10=Spanisch | 26=Kroatisch | 41=Farsi
11=Finnisch | 27=Slowakisch | 42=Vietnamesisch
12=Französisch | 28=Albanisch | 43=Armenisch
13=Hebräisch | 29=Schwedisch | 44=Aserbaidschanisch
14=Ungarisch | 30=Thai | 45=Baskisch
15=Isländisch |  |

Beispiele:

  • Arena.exe /fcp SOS /scp Crafty /lpf C:\Arena\123test.EPD /lpi 2 /mg 4 /inc 1 /tc 1:00

Startet Arena mit erstem Motor SOS, zweitem Motor Crafty für einen Wettkampf über 4 Partien mit der 2. Stellung in der spezifizierten EPD-Datei im Fischer-Modus 1/1.

  • Arena.exe /lp "1k1r4/1pp4p/2n5/P6R/2R1p1r1/2P2p2/1PP2B1P/4K3 b - - 0 1 bm ... e3"

Startet Arena mit einer Teststellung im EPD Format.

  • Arena.exe /26

Startet Arena mit kroatischer Sprache (wenn es eine solche Sprachdatei denn gibt)

Abkürzungen:

#rrggbb =Rotwert, Grünwert, Blauwert in Hexadezimaler Schreibweise, d.h. 0-9,A-F
mm:ss = Minuten : Sekunden


Arena - Hilfe -Sonstiges - Partiedaten

Partiedaten

Unter Partie / Partiedaten können Sie wichtige Daten zur aktuellen Partie eingeben.

Die Felder entsprechen den PGN-Tags und werden in eine PGN Datei mitgespeichert, wenn Sie unter PGN / Partie speichern als PGN wählen. "Kommentar" wird als Nicht-Standard-Tag "Comment" gespeichert.

Das Datum sollten Sie im PGN Format speichern, also JJJJ.MM.TT. Der 25.Juli 2002 würde also als 2002.07.25 eingetragen. Dies erledigt normalerweise Arena bei Datei/Neu für Sie mit.

Die Felder ECO, Eröffnung werden von Arena überschrieben, wenn Arena anhand ihrer Eröffnungsklassifikation eine passende Eröffnung findet und ein Zug eingegeben oder von einem Motor gemacht wird.

Auch das Ergebnis wird von Arena automatisch gesetzt, wenn Arena ein Matt, Patt oder ein anderes Partieende findet.

Vergessen Sie nicht, nach der Eingabe die Partie zu speichern.


Arena - Hilfe -Sonstiges - Schach 960

Schach 960 oder Fischer-Schach, Full Chess

Mit Datei / Neu - Fischer-Schach oder mit einem Klick mit der rechten Maustaste auf das Schachbrettsymbol { [image] } in der Werkzeugleiste starten Sie eine neue Schach 960 Partie.

Dies ist eine Schach-Variante, die vom früheren Weltmeister Bobby Fischer vorgeschlagen wurde. Sie wird auch Full Chess oder Fischer-Schach genannt. Der Name 'Schach 960' leitet sich von der Anzahl der möglichen Anfangsstellungen her.

Bie dieser Schachvariante wird die Ausgangsstellung so verändert, daß die Figuren auf einem anderen Anfangsfeld stehen als bisher gewohnt. Die Position der Bauern bleibt unverändert. Auch sind zwei verschiedenfarbige Läufer Bedingung.

Beispiel einer Schach 960-Stellung:

Das Fischer-Schach hat nun den Vorteil, daß spezialisiertes Eröffnungswissen jetzt unwichtig geworden ist und vom ersten Zug an nachgedacht und gerechnet werden muss. Taktische Probleme treten oft schon in den allerersten Zügen auf. Seien Sie also nicht unvorsichtig gegen die Programme!

Die erweiterte Rochade, das Kernstück von Schach 960, wird von Arena unterstützt. Shuffle chess kennt diese Rochade nicht.

Für Schach 960 muss der König zwischen den beiden Türmen stehen, um die erweiterte Rochade zu ermöglichen.

Die Rochade erfolgt folgendermaßen:

Egal wo König und Turm stehen, beide Figuren stehen nach der Rochade auf den selben Feldern wie bei der Rochade im ganz normalen Schach. Bei der kurzen Rochade für weiß also auf f1 und g1, bei der langen auf c1 und d1. Ein Turm, der links vom König steht (egal wo) landet nach der Rochade also immer auf d1. Ein Turm, der rechts vom König steht, landet nach der kurzen Rochade immer auf f1. Für schwarz gilt das analog auf der 8.Reihe. Wie im normalen Schach gilt, daß die Felder, über die rochiert wird, frei sein müssen. Die Felder, die der König überstreicht, dürfen auch nicht angegriffen sein.

Um zu rochieren, führen Sie in Arena einfach den Königszug aus. Der Turmzug erfolgt automatisch.

In bestimmten Situationen muss man einen normalen Königszug von der Rochade unterscheiden können, falls der König nämlich nur ein Feld ziehen muss, um die Rochade auszuführen. In diesen Fällen ist es nicht klar, ob Sie nur mit dem König ziehen wollen oder rochieren. Drücken sie, wenn Sie rochieren wollen, während Sie den Zug mit der Maus ausführen, die Strg-Taste.

Wenn der König für die Rochade nicht ziehen muss, führen Sie den Turmzug aus. Wenn Sie während eines Turmzuges die Strg-Taste gedrückt halten, erfolgt auch die Rochade, wenn der Turmzug dem Zug des Turmes während der Rochade entspricht.

Die Rochade erscheint kompliziert, wird aber in der Praxis intuitiv verstanden. Im Grunde werden nur die Normalschach- Rochade Regeln erweitert auf unterschiedliche Anfangsstellungen. Die Grundprinzipien bleiben allerdings gleich: Die Felder, die der König überstreicht müssen frei und vom Gegner unbeherrscht sein. Auch die Felder, auf denen König und Turm nach der Rochade zu stehen kommen, sind die selben wie beim Normalschach.

Shuffle Chess kennt im Gegensatz zu Fischer Random Schach keine Rochade.

Sie können auch im Aufstell-Dialog bestimmen, ob Sie Fischer Random Schach oder Shuffle Chess spielen möchten.

Arena kann Fischer Random Partien im PGN Format lesen.

Unterstützung durch die Schachmotoren:

Da Fischer-Schach mit einer veränderten Anfangsstellung gespielt wird, müssen Motoren dieses unterstützen. Bei Winboard ist dies der Edit-Mode und bei UCI das Kommando "startpos FEN".

Schachmotoren, die Fischer Random komplett unterstützen, sind mittlerweile verfügbar. Die Arena Partner Motoren Chispa, The Baron und Betsy unterstützen FRC jetzt vollständig!

Das Problem besteht in der korrekten Ausführung der erweiterten Rochade. Daher ein Aufruf an alle Programmier: Implementiert Fischer Random Schach! Arena sendet und empfängt Rochadezüge im Fischer Schach (und nur da!) immer in Form von "O-O“ für kleine und "O-O-O“ für große Rochade (Buchstabe 'O').

Fischer Random Schach wird in der Zukunft sicherlich an Bedeutung zunehmen, wie auch das Turnier, das 2004 in Mainz stattfand, zeigte.


Arena - Hilfe -Sonstiges - Shuffle Chess

Shuffle Chess

Shuffle-Chess ist eine Schachvariante, bei der die Ausgangsstellung so verändert wird, dass die Figuren auf einem andern Startfeld stehen als bisher gewohnt. Die Position der Bauern bleibt unverändert. Auch sind zwei verschiedenfarbige Läufer Bedingung.

Beispiel einer Shuffle Chess-Stellung:

Da bei Shuffle Chess mit einer veränderten Anfangsstellung gespielt wird, müssen Motoren dieses unterstützen. Bei Winboard ist dies der Edit-Mode und bei UCI das "startpos FEN" Kommando

Im Schach 960 muss der König zwischen den beiden Türmen stehen, um die erweiterte Rochade zu ermöglichen. Dies ist bei Shuffle Chess nicht zwingend notwendig. Eine Rochade ist bei Shuffle Chess nicht möglich.

Sie können auch im Aufstell-Dialog bestimmen, ob Sie Fischer Schach oder Shuffle Chess spielen möchten.


Arena - Hilfe -Sonstiges - Im lokalen Netz spielen

Im lokalen Netz spielen

Zu diesem Dialog gelangen Sie über Datei / Netzwerk - Partie.

Zuerst müssen Sie sicherstellen, dass beide Rechner über ein (Netz-)Laufwerk verfügen, auf das beide Rechner Schreib- und Lesezugriff verfügen. Sie können sich z-B. über den Dateimanager mit einem Netzlaufwerk verbinden. Die Kommunikation erfolgt über eine Transfer-Datei auf diesem Netzlaufwerk.

Dann gehen Sie wie folgt vor :

  • Im Hauptmenü Datei / Netzwerk-Partie anwählen.
  • Die Transfer-Datei auf dem gemeinsamen Laufwerk festlegen. Vergessen Sie dabei eventuelle Laufwerksbuchstaben und Pfade nicht!
  • Die gewünschte Farbe festlegen.
  • Spielen!

Wichtig: Weiß darf erst dann anfangen zu ziehen, wenn auch bei Schwarz alle Einstellungen erfolgt sind!

Zum Beenden der Netzpartie nehmen Sie bitte den Haken aus dem Menü Datei / Netz-Partie wieder heraus.


Arena - Hilfe -Sonstiges - Über das Internet spielen (ICS)

Über das Internet spielen (ICS)

Diese Funktion ist im Moment nicht verfügbar.

Mit Arena können Sie sich auf den verschiedenen Internet Chess Servern (ICS) einloggen und dort als Gast oder registrierter Benutzer gegen gleichgesinnte Personen auf der ganzen Welt Schach spielen.

Und so geht's:

  • Verbinden Sie sich mit dem Internet über ihren Internet-Provider.
  • Starten Sie Arena.
  • Über das Weltsymbol der Werkzeugleiste, Extras / Internet oder Strg+I erreichen Sie den Dialog zur Auswahl des Schachservers.
  • Wählen Sie das Profil, mit dem Sie sich einloggen möchten.
  • Loggen Sie sich auf dem gewünschten ICS ein.
  • Nun können Sie auf die gewohnte Weise auf Ihrem Server Schach spielen, Partien beobachten, chatten etc. Falls Sie sich noch nicht so gut auskennen, geben Sie einfach 'help' an der Kommandozeile ein. Auch mit der rechten Maustaste können Sie ein Kontextmenü mit gespeicherten Befehlen abrufen.
  • Über das Weltsymbol der Werkzeugleiste, Optionen / Internet oder Strg+I beenden Sie den ICS Modus wieder.

Die Schachvarianten Bughouse und Crazyhouse werden noch nicht unterstützt. Es wird nur normales Schach unterstützt, ob andere Varianten funktionieren, habe ich nicht getestet.

Bereiche:

Beim Start des ICS-Modus erscheint im Hauptfenster von Arena ein neuer Bereich, der sich wie folgt unterteilt:

1.) Der ICS-Chat Bereich: hier können Sie Ausgaben sehen, die vom ICS kommen
2.) Der Knöpfe Bereich rechts daneben
3.) Der Bereich unten mit Eingabezeile und verschiedenen Knöpfen

1.) Der Chat Bereich:

Sie können hier die Ausgaben sehen, die der ICS für Sie sendet. Besondere Meldungen wie Herausforderungen (Challenges) oder Schreie (Shouts) werden in Signalfarben dargestellt. Mit der rechten Maustaste können Sie auf ein Wort klicken, es wird dieses Wort markiert, ein Kontextmenü erscheint und Sie können nun z.B. den Befehl 'match guest152' direkt im Kontextmenü auswählen. Der Befehl wird dann direkt zum Server gesendet und Sie haben damit 'guest152' zu einer Partie herausgefordert.

2.) Der Knöpfe Bereich:

Beim Klick auf diese Knöpfe werden die zugehörigen Befehle zum ICS gesendet. Sie können diese Knöpfe selbst defnieren .

3.) Der Eingabezeile Bereich:

In der Eingabezeile können Sie die Eingaben, die Sie zum ICS senden möchten, eingeben. Bei einem Klick auf 'Los!' werden diese dann auch tatsächlich gesendet.

Daneben finden Sie dort Knöpfe für Verbinden, Optionen, und Ende. 'Verbinden' ruft den Dialog zum Auswahl eines ICS-Profils und Aufbau einer Verbindung dorthin auf . 'Optionen' ruft den Optionen- Dialog auf. 'Ende' beendet den ICS-Modus von Arena.

Profile:

Sie können in Arena verschiedene Profile für ihre Lieblings-Schachserver erstellen. Dabei können und sollten Sie für jedes Profil folgende Einstellungen machen:

Servername: Klar, den brauchen sie, z.B.: freechess.org oder chess.net Port: Der TCP/IP- Port, über den die Verbindung erfolgt, meistens 5000 Benutzername: können Sie verwenden, wenn Sie sich automatisch einloggen wollen Passwort: auch nur sinnvoll bei automatischem Einloggen Name und Kennwort automatisch senden: Arena sendet Benutzernamen und Kennwort automatisch an den Server

Timeseal,Timestamp, Accuclock: Dies sind Verfahren, mit denen das Problem der zeitlichen Verzögerung der Übertragung von Zügen über das Internet ein wenig gemildert wird. Freechess.org verwendet Timeseal, chessclub.com verwendet Timestamp, chess.net verwendet Accuclock.

Computer Account: Wenn Sie einen Motor mit Arena auf einem Schachserver laufen lassen wollen, müssen Sie dieses Kontrollfeld markieren. Sie sind verpflichtet, diesen Benutzernamen als 'Computer Account' bei den Administratoren des Schachservers zu registrieren. Ansonsten riskieren sie, von der Benutzung des Schachservers ausgeschlossen zu werden. Sie können keine eigenen Züge machen, wenn Sie 'Computer Account' markiert haben.

Spezielle Funktionen:

Wenn eine Partie beendet ist, sendet Arena das Kommando K "gameend" zum ICS. Sie können dises Kommando mit einem Alias versehen, der dann andere Kommando(s) ausführt, z.B. am Ende einer Partie automatisch ein "seek" Kommando ausführt.

Optionen:

ICS-Optionen

Kontextmenü:

Das Kontextmenü für den Eingabezeile Bereich und den Knöpfe Bereich enthält einige gängige ICS-Befehle, die Sie direkt auswählen können.

Knöpfe definieren für den ICS Beriech

Im lokalen Netz spielen

$ #KKnöpfe definieren für den ICS Bereich

Für jeden Knopf im Knöpfe- Bereich im ICS-Bereich im Arena- Hauptfenster haben Sie hier in diesem Dialog eine Zeile mit folgenden Einträgen:

1. Beschriftung
2. Befehl
3. Hilfe

Beschriftung:

Dies ist der Text, der auf dem Knopf steht

Befehl:

Dies ist der Befehl oder die Befehle, der oder die zum ICS geschickt wird. Falls Sie ein 'Return' zum ICS schicken möchten, z.B. als Trennung von 2 Befehlen, die hintereinander zum ICS gesendet werden sollen, geben Sie bitte '^M' ein. Das '^'-Zeichen ereichen sie, indem Sie die '^' Taste ganz oben links auf ihrer Tastatur drücken und danach die Leertaste.

Hilfe:

Ein kleiner Hilfetext, der erscheint, wenn Sie mit der Maus über dem Knopf verweilen

Unter den Knöpfe- Defnitionen sehen Sie noch fünf Schaltflächen:

Hinzufügen: Bewirkt, dass ein neuer, leerer Eintrag (Knopf) erscheint Löschen: Löscht den gerade markierten Eintrag (Knopf)
2 Pfeiltasten: Schieben den markierten Eintrag nach oben oder unten Standard: Fügt die Knöpfe hinzu, die von Arena voreingestellt sind.

Über das Internet spielen

ICS-Optionen

$ #KICS-Optionen

Hier können Sie allgemeine Optionen für das Verhalten im ICS-Modus einstellen.

Unter 'Allgemein' finden Sie folgende Optionen:

Lokales Echo: Gibt an, ob ihre eigenen Eingaben im Chat- Fenster angezeigt werden Menübefehle sofort senden: Bestimmt, ob die Kontextmenü-Einträge sofort gesendet werden oder sie erst in die Eingabezeile geschrieben werden und Sie sie evtl. ergänzen können. Automatisch Umdrehen: Wenn eine Partie beginnt, an der Sie mitspielen, wird das Schachbrett automatisch so gedreht, dass ihre Seite unten erscheint. Am Zug überprüfen: Schaltet die Überprüfung, ob Sie am Zug sind, ein oder aus. Damit kann man die evtl. lästige Anzeige einer Fehlermeldung unterdrücken.

Partieende

Sendet eine Anzahl von gameend Kommandos, wenn eine Partie beendet ist:

Wenn die Zahl null ist, wird kein "gameend" Kommando gesendet. Wenn die Zahl 1 ist, wird "gameend" gesendet. Wenn die Zahl 2 oder größer ist, wird die entsprechende Zahl an Kommandos gesendet, z.B.: "gameend", "gameend2", "gameend3".

Computerspiel:

Herausforderungen automatisch annehmen: Hier werden alle Herausforderungen (challenges) automatisch angenommen. Dies gilt nur, wenn Sie einen Motor mittels Arena auf einem Schachserver betreiben, Sie also 'Computer Account' in den Verbindungs-Optionen für das aktuelle Profil markiert haben.

Fernsteuerung

Sie können ihren Motor von einer anderen Benutzerkennung fernsteuern, indem Sie den befehl 'tell' an Ihren Motor senden. Z.B.:

tell [IhrMotor] [Kennwort] [tue etwas]

Bitte ersetzen Sie: [IhrMotor] mit dem Namen ihres Motors [Kennwort] mit dem Passwort, das Sie in diesem Dialog eingegeben haben [tue etwas] dem Kommando, das Sie an ihren Motor senden möchten.

Bitte nicht die Klammern [] benutzen.

Speichern

Protokoll:

Falls Sie alle Ein- und Ausgaben an und zum Internet Chess Server protokollieren möchten, können Sie hier eine Datei angeben. Diese Datei kann später als Simulation wieder eingelesen werden.

Automatisches Speichern:

Alle Partien, die Sie beobachten oder spielen, können Sie hier im PGN Format speichern lassen.


Arena - Hilfe -Sonstiges - Technische Informationen

Technische Informationen

Die Programmierung eines Schachprogrammes ist eine aufwendige und komplizierte Angelegenheit. Damit sich Schachprogrammierer nicht mit den Details der Oberflächengestaltung beschäftigen müssen, hat man das sog. 'Motoren- Konzept' erfunden: Die Trennung von Motor und Oberfläche in 2 separate Module. Der Programmierer eines Motors (englisch: 'Engine') kann sich nun vollständig um die Verbesserung der Spielstärke seines Schachmotors kümmern. Die Darstellung des Schachbrettes, der Figuren und der sonstigen Informationen übernimmt die graphische Oberfläche (englisch: 'GUI= Graphical User Interface', etwa 'Graphische Benutzeroberfläche').

Die erste Oberfläche war das Winboard, programmiert von Tim Mann. Es wurde ursprünglich als Schnittstelle für GNUchess geschrieben und passte sich dementsprechend diesem textorientiertem Programm an. Das resultierte in dem relativ kompliziertem Winboard-Protokoll zur Verständigung von Schachmotor und Benutzeroberfläche. Trotzdem hat es sich rasant verbreitet und es stehen heute über 200 Schachmotoren zu Verfügung, viele mit beachtlicher Spielstärke, manche in der absoluten Spitzenklasse.

Ein neues Protokoll wurde von Rudolf Huber und Stefan Meyer-Kahlen ins Leben gerufen: das UCI-Protokoll. Es vereinfacht die Programmierung für sowohl die Motoren- Entwickler wie für die Oberflächen-Programmierer. Es fehlen allerdings einige Dinge, z.B. bekommen die Motoren das Ergebnis einer Partie nicht mit und können nicht selbst aufgeben oder Remis anbieten.

Schachprogramme funktionieren prinzipiell folgendermaßen:

Alle Schachprogramme benutzen eine sogenannte Baumsuche um den besten Zug herauszufinden. Der Schachmotor führt also zunächst z.B. einen weißen Zug, dann einen schwarzen Zug etc. auf einem internen "Brett" aus. Da dies nicht endlos so weitergehen kann, wird die Suche irgendwann beendet und die entstandene Stellung bewertet. Die Werte der Endstellungen werden verglichen und der beste Zug ausgewählt.

Vorschläge für Motoren-Programmierer:

Einige Dinge sind mir beim Umgang mit Winboard-Engines aufgefallen. Sie könnten das Leben leichter machen, sowohl unter Winboard wie auch unter Arena.

1. Installation:

  • Der Motor sollte ohne Parameter in der Kommandozeile funktionieren.
  • Das Buch sollte ohne Ändern von Konfigurationsdateien funktionieren.
  • Die Hashtabellen sollten auf einen vernünftigen, nicht zu hohen Wert eingestellt werden.
  • Bitte fügen Sie eine init-Datei bei, die den gleichen Namen wie die exe-Datei hat. Auf diese Weise kann man Kommandozeilenparameter, Autornamen und Land herausfinden.

2. Wert-Anzeige:

  • Mattwerte sollten nach dem Crafty-Standard (Matt=32767) angezeigt werden.
  • Werte sollten immer aus der Sicht des Motors angezeigt werden.

3. Analysemodus:

  • Ob hier Buchzüge angezeigt werden sollten, ist sicher Geschmacksache, wenn ja, dann sollten sie mit '()' eingeklammert werden.
  • Die Analyse sollte nicht beendet werden, wenn ein Matt gefunden wurde. Manche Programme finden nämlich ein kürzeres Matt erst nach längerer Suche, was bei Mattaufgaben ärgerlich ist.
  • Im Analysemodus sollten die Motoren besonders schnell auf Eingaben reagieren, da häufig in einer Partie hin- und hergesprungen wird mit den unvermeidlichen häufigen 'undo' bzw. 'MOVE'- Befehlen.


Arena - Hilfe -Sonstiges - Zugansagen

Zugansagen mittels Klangdateien

Wir haben sehr gute Zugansagen in deutsch und englisch von Jörg Borchardt auf unserer Internetseite.

Die folgenden Dateinamen müssen benutzt werden, wenn Sie Zugansagen haben möchten. Am besten sollte man sie im Verzeichnis 'Sounds' direkt unter dem Arena-Verzeichnis unterbringen:

0-0.wav
0-0-0.wav
1from.wav
1to.wav
2from.wav
2to.wav
3from.wav
3to.wav
4from.wav
4to.wav
5from.wav
5to.wav
6from.wav
6to.wav
7from.wav
7to.wav
8from.wav
8to.wav Afrom.wav
Bfrom.wav
Bishop.wav
Cfrom.wav
Checkmate.wav
Click.wav
Dfrom.wav
drawAccept.wav
Drawoffer.wav
Efrom.wav
EnPassant.wav
Ffrom.wav
Gfrom.wav
Hfrom.wav
King.wav
Knight.wav
Oke.wav
Pawn.wav
Queen.wav
Resign.wav
Rook.wav
Stalemate.wav
Takes.wav


Arena - Hilfe -Sonstiges - Notizzettel

Notizzettel

Zu diesem Dialog gelangen Sie über Hilfe / Notizen.

Zeigt die Datei 'my.txt' im Arena Verzeichnis mit dem Editor an. Dies ist eine Textdatei für ihre persönliche Notizen.


Arena - Hilfe -Sonstiges - Partieübersicht

Partieübersicht

Unter Optionen erreichen Sie den Menüpunkt Übersicht (Umsch-F9).

Sie sehen eine Übersicht über die aktuelle Partie mit den erfolgten Zügen und Bewertung. Sie können mit einem Klick mit einer Maustaste zu der jeweiligen Stellung springen.

Ein Doppelklick auf die Stellung springt zur Stellung und schließt gleichzeitig das Übersichts-Fenster.


Arena - Hilfe -Sonstiges - Der Autoplayer

Der Autoplayer

Hierhin gelangen Sie mit "Extras / Autoplayer" oder Strg+A.

Mit dieser Funktion können Sie automatisierte Partieserien von zwei Programmen auf zwei Rechnern gegeneinander durchführen. Das hat den Vorteil, dass beide Programme ihren jeweiligen Rechner komplett alleine für sich zur Verfügung haben.

Dazu benötigen Sie ein serielles Kabel (Nullmodemkabel) zwischen den beiden Rechnern. Auf der [image] Registerkarte Optionen müssen Sie dafür den richtigen seriellen Anschluss wählen.

Registerkarte "Spielen"

Die Anzahl der zu spielenden Partien können Sie mit dem Eingabefeld "Anzahl Partien" vor dem Start einer Partieserie festlegen. Diese Einstellung ist nur für den Betrieb als Master möglich.

Der aktuelle Spielstand wird rechts oben angezeigt. Die 4 Zahlen bedeuten: "Gewonnene Partien hier/ Gewonnene Partien Gegner/Remis/unbekanntes Ergebnis". Arena versucht nicht, die Partie abzuschätzen oder in irgendeiner Weise das Resultat zu bestimmen. Nur Partien mit klarem Ergebnis (Matt, Patt, Stellungswiederholung, zu wenig Material, 50-Züge Regel , wenn der unter Arena laufende Motor aufgegeben hat und Arena als Master agiert oder wenn der Gegner im erweiterten Modus ein Aufgeben-Signal schickt) werden als Sieg, Niederlage oder Remis gewertet. Alle anderen kommen in die Kategorie "unbekannt". Dies trifft z.B. für Partien zu, bei denen der Gegner irgendwann nicht mehr geantwortet hat, weil er z.B. aufgegeben hat, dies aber nicht gesendet hat. Auch wenn Arena zum Beenden der Partie und zum Speichern aufgefordert wurde, aber das Resultat nicht klar ist, tritt dieser Fall ein.

Wenn "Master" angehakt ist, dann läuft Arena als Master, sonst als Slave.

Mit "Starte Verbindung" starten Sie den Verbindungsaufbau und das Match. Sie sollten zuerst den Slave starten, dann den Master.

Mit "Abbrechen" können Sie ein laufendes Match abbrechen. Es kann bislang noch nicht wiederaufgenommen werden.

Mit "Schließen" schließen Sie den Autoplayer-Dialog. Für einen Abbruch des Matches sollten Sie vorher "Abbrechen" drücken.

Registerkarte "Optionen"

Da es keine Möglichkeit gibt, den Namen des Gegners herauszufinden, müssen Sie ihn im Feld "Name des Gegners" selbst eintragen. Dies ist wichtig, wenn Sie die Partien in einer PGN Datei speichern.

Auch der Name des Matches kann gesetzt werden. Er wird im "Event" Feld der Partie in der PGN Datei gespeichert.

Unter "Anschluss" müssen Sie den Anschluss wählen, an dem das serielle Kabel hängt, z.B. COM1 oder COM2.

Wenn "Partien speichern" ausgewählt ist, dann werden die Partien automatisch in einer PGN Datei gespeichert. Den Namen der Datei können Sie im darunter liegenden Eingabefeld eingeben.

Das "Timeout" sollten Sie so wählen, dass es ca. dem 7-fachen der durchschnittlichen Zeit eines Zuges entspricht, besser vielleicht noch größer. Sie sollten den Timeout also genau der gewählten Spielstufe anpassen. Diese Einstellung ist nur für den Betrieb als Master gültig. Der Timeout ist notwendig, falls der Slave auf der Gegenseite einmal nicht mehr reagiert, weil er z.B. aufgegeben hat.

"Start mit schwarz" bedeutet, dass der Motor, der auf dem Master läuft, bei der ersten Partie mit schwarz anfängt zu rechnen. Wenn "Wechsele Farben" ausgeschaltet ist, dann bleibt dies auch für den Rest des Matches so. Diese Einstellung ist nur für den Betrieb als Master gültig.

"Wechsele Farben" bedeutet, dass bei jeder neuen Partie die Seiten (schwarz und weiß) gewechselt werden. Diese Einstellung ist nur für den Betrieb als Master gültig.

Registerkarte "Erweitert"

"Sende Unterverwandlungen" bedeutet, dass die neuere Protokollerweiterung verwendet wird, nach der auch Unterverwandlungen erlaubt sind. Die erste Version des Autoplayers kannte keine Unterverwandlungen. Wenn Sie also gegen ein älteres Programm mit altem Autoplayer spielen lassen, dann sollten Sie hier "Sende Unterverwandlungen" ausschalten.

"Fehlersuche-Protokoll" bedeutet, dass in der Liste auf der [image] Registerkarte "Fehlersuche" mehr Informationen dargestellt werden.

Registerkarte "Fehlersuche"

Hier sieht man alle Ein- und Ausgaben, die ausgetauscht werden. Wenn bekannt, werden Sie auch beschrieben.

Wie Sie ihre Rechner einstellen sollten, um den Autoplayer zu benutzen:

1. Überprüfen sie, dass die Rechner mit dem Nullmodem-Kabel verbunden sind.
2. Starten Sie die Programme oder Oberflächen, die gegeneinander spielen sollen.
3. Stellen Sie die Spielstufe für die Spielserie ein.
4. Überprüfen Sie die Einstellungen der Motoren, die Sie verwenden möchten. Wichtig sind z.B. Einstellungen für das Aufgeben (s.u.), Hashtabellengröße, Verfügbarkeit der Endspieldatenbanken und das Pondern.
5. Wählen Sie den korrekten seriellen Anschluß in der Autoplayer-Konfiguration der beiden Programme.
6. Setzen Sie die Optionen für den Autoplayer in dem Programm, das Master sein soll. Z.B. ob die Seiten gewechselt werden sollen, die Anzahl der zu spielenden Partien etc.
7. Starten Sie den Autoplayer auf dem Programm, dass der Slave sein soll.
8. Starten Sie den Autoplayer auf dem Programm, dass der Master sein soll.
9. Sie können den Autoplayer jederzeit unterbrechen. Dies sollten Sie dann aber bei beiden Programmen tun.

Wichtige Arena Einstellungen:

Wenn Sie Arena als Master laufen lassen, sollten Sie Aufgeben einschalten, entweder in der Konfiguration des Motors oder, wenn Sie einen UCI-Motor verwenden, in den UCI-Optionen in dem Dialog Motoren/ Installieren und Auswählen.

Wenn Sie Arena als Slave laufen lassen, sollten Sie ebenfalls Aufgeben einschalten. Nur dann, wenn das gegnerische Programm/ die gegnerische Benutzeroberfläche keine Auto 232- Protokollerweiterungen unterstützt, sollten Sie "Aufgeben" ausschalten. Es gibt dann keinen Weg, dem Gegner mitzuteilen, wenn ein Motor, der unter Arena läuft, aufgibt. Also muss das gegnerische Programm die Wartezeit zum Timeout verstreichen lassen, bis die Partie als beendet angesehen wird. In den meisten Fällen verlieren Sie dadurch Zeit. Fast alle Oberflächen unterstützen allerdings heutzutage die Erweiterungen.

Im gegnerischen Programm oder der gegnerischen Oberfläche sollte daher "erweiterter Modus" (oder Ähnliches) eingeschaltet sein, da die Erweiterungen des Auto 232-Protokolls von Arena unterstützt werden.

Dank:

Der Autoplayer ist eine Entwicklung von Dr. Christian Donninger. Die Erweiterungen des Protokolls bezüglich Remisangeboten und Aufgeben werden unterstützt. Es existieren Treiber und Einbindungen in viele kommerzielle Programme. Der Autoplayer wird für gründliche Tests von Schachprogrammen und Motoren in langen Testmatches verwendet.


Arena - Hilfe -Glossar

Glossar

GUI

Graphical User Interface, Oberfläche. Die GUI zeigt dem Benutzer Schachbrett, Zugliste, Informationen über den Suchvorgang des Motors an. Arena und Winboard sind Oberflächen für Schach.

Halbzug

Ein Halbzug ist immer ein Zug von weiß oder schwarz, im Gegensatz zu einem Zug, der normalerweise im Schach einen Zug von weiß und schwarz bezeichnet.

Motor

Ein Schachmotor führt die Berechnung eines Zuges aus. Er gibt Hauptvarianten zur Information für den Benutzer aus. Gegensatz zu Oberfläche, GUI. Motoren verständigen sich mit der GUI mittels Protokollen. Beispiele: SOS, Ruffian.

SOS

SOS - Das ist der Name eines starken Schachmotors, programmiert von Rudolf Huber. SOS war der erste Motor, der Arena Partner wurde und liegt den meisten Arena Paketen bei.

Pondern, Permanent Brain

Rechnen, während der Gegner am Zug ist. Der Schachmotor kann
z.B. während der Gegner an seinem Zug überlegt, Berechnungen anstellen und seine Gegenzüge berechnen. Eine größere Spielstärke ist meist das Resultat.

Protokoll

Protokolle dienen der Kommunikation zwischen Schachmotor und Oberfläche. Die Wichtigsten sind UCI und Winboard.


Arena - Hilfe -Index

Index

Arena-Unterstützungs-Forum
Aufstellen
Baumsuche
Bedienerzeit
Blitz (=Fischer-Uhr)
Das Turnier-Infofenster
DGT 2000 Schachuhr
DGT XL Schachuhr
Die Arena - Versionsanzeige
Die Speicheranzeige
Fehler-Überwachung
gemeinsame Parameter für alle UCI-Motoren
GUI
Halbzug
Kurzhilfen
Legalität prüfen
Motor
PGN-Optionen
Pondern
Protokoll
Remis anbieten
Rutschsystem
Schrifteninstallation
SOS
Speichern der Lieblings-Spielstufen
TrueType Schriftarten unter Arena
UCI-Protokoll
Unendlich
Verlassen des DGT-Modus
Werkzeugleisten-Konfiguration
Winboard
Zeitüberschreitung beachten
Zeitüberschreitungen im Turniermodus